summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosh Ellithorpe2017-07-21 21:53:08 -0700
committerJosh Ellithorpe2017-07-21 21:53:08 -0700
commite0d0276036651bb536061ac905202c9f8246aa8c (patch)
tree04e6161ea4c26addfb7da8a443e4be483e3e0200
parente518e8cbc8142141b51b1cb7f79e345795ce4f8b (diff)
downloadaur-e0d0276036651bb536061ac905202c9f8246aa8c.tar.gz
Updated to Bitcoin ABC 0.14.4
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD55
2 files changed, 28 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1787a990d27..cd6dfd6ef884 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,39 +1,25 @@
# Generated by mksrcinfo v8
-# Wed Jul 19 04:51:14 UTC 2017
+# Sat Jul 22 04:51:11 UTC 2017
pkgbase = bitcoin-abc-qt
- pkgdesc = Bitcoin ABC qt wallet
- pkgver = 0.14.3
+ pkgdesc = Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt
+ pkgver = 0.14.4
pkgrel = 1
url = https://bitcoinabc.org
install = bitcoin.install
arch = i686
arch = x86_64
license = MIT
- makedepends = autoconf
- makedepends = automake
- makedepends = binutils
makedepends = boost
- makedepends = boost-libs
- makedepends = libevent
- makedepends = libtool
- makedepends = m4
- makedepends = make
- makedepends = miniupnpc
- makedepends = pkg-config
- makedepends = protobuf
- makedepends = qrencode
- makedepends = qt5-base
makedepends = qt5-tools
- makedepends = zeromq
- depends = boost
depends = boost-libs
- depends = desktop-file-utils
depends = libevent
+ depends = desktop-file-utils
depends = qt5-base
- depends = miniupnpc
- depends = qrencode
depends = protobuf
+ depends = openssl
+ depends = miniupnpc
depends = zeromq
+ depends = qrencode
provides = bitcoin-cli
provides = bitcoin-daemon
provides = bitcoin-tx
@@ -44,13 +30,13 @@ pkgbase = bitcoin-abc-qt
conflicts = bitcoin-qt
backup = etc/bitcoin/bitcoin.conf
backup = etc/logrotate.d/bitcoin
- source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.14.3.tar.gz
+ source = https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v0.14.4.tar.gz
source = bitcoin.conf
source = bitcoin.logrotate
source = bitcoin.service
source = bitcoin-reindex.service
source = bitcoin.install
- sha256sums = 5e2d5ee094ce35b4b57506fee1ac1116a4872a7bd3e62f0668e0766d59d4b934
+ sha256sums = a5792263a5f832ab3ad005d019b2bfc75aac712a285aff3138f9f4eb33d64b01
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
diff --git a/PKGBUILD b/PKGBUILD
index 1df6a73db6eb..ed3397b2335b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,13 @@
# Maintainer: Josh Ellithorpe <quest@mac.com>
pkgname=bitcoin-abc-qt
-pkgver=0.14.3
+pkgver=0.14.4
pkgrel=1
-pkgdesc="Bitcoin ABC qt wallet"
+pkgdesc="Bitcoin ABC with bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt"
arch=('i686' 'x86_64')
url="https://bitcoinabc.org"
-depends=('boost'
- 'boost-libs'
- 'desktop-file-utils'
- 'libevent'
- 'qt5-base'
- 'miniupnpc'
- 'qrencode'
- 'protobuf'
- 'zeromq')
-makedepends=('autoconf'
- 'automake'
- 'binutils'
- 'boost'
- 'boost-libs'
- 'libevent'
- 'libtool'
- 'm4'
- 'make'
- 'miniupnpc'
- 'pkg-config'
- 'protobuf'
- 'qrencode'
- 'qt5-base'
- 'qt5-tools'
- 'zeromq')
+depends=('boost-libs' 'libevent' 'desktop-file-utils' 'qt5-base' 'protobuf' 'openssl' 'miniupnpc' 'zeromq' 'qrencode')
+makedepends=('boost' 'qt5-tools')
license=('MIT')
source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.conf
@@ -38,7 +15,7 @@ source=(https://github.com/Bitcoin-ABC/bitcoin-abc/archive/v$pkgver.tar.gz
bitcoin.service
bitcoin-reindex.service
bitcoin.install)
-sha256sums=('5e2d5ee094ce35b4b57506fee1ac1116a4872a7bd3e62f0668e0766d59d4b934'
+sha256sums=('a5792263a5f832ab3ad005d019b2bfc75aac712a285aff3138f9f4eb33d64b01'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
@@ -50,10 +27,6 @@ provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt')
conflicts=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt')
install=bitcoin.install
-# half of available processing units or one if only one is available
-_nproc=$(($(nproc)/2))
-[[ ${_nproc} < 1 ]] && _nproc=1
-
build() {
cd "$srcdir/bitcoin-abc-$pkgver"
@@ -61,7 +34,6 @@ build() {
./autogen.sh
./configure \
--prefix=/usr \
- --sbindir=/usr/bin \
--libexecdir=/usr/lib/bitcoin \
--sysconfdir=/etc \
--sharedstatedir=/usr/share/bitcoin \
@@ -69,15 +41,18 @@ build() {
--enable-hardening \
--with-gui=qt5 \
--with-gnu-ld \
- --with-incompatible-bdb
- make -j$_nproc
+ --with-incompatible-bdb \
+ --disable-maintainer-mode \
+ --enable-reduce-exports \
+ --disable-gui-tests
+ make
}
check() {
cd "$srcdir/bitcoin-abc-$pkgver"
msg2 'Testing...'
- make -j$_nproc check
+ make check
}
package() {
@@ -99,6 +74,14 @@ package() {
msg2 'Installing man pages...'
install -Dm 644 doc/man/*.1 -t "$pkgdir/usr/share/man/man1"
+ msg2 'Installing rpcuser.py...'
+ sed 's/python2/python/' <share/rpcuser/rpcuser.py >rpcuser.py
+ install -Dm 755 rpcuser.py -t "$pkgdir/etc/bitcoin"
+
+ msg2 'Installing examples...'
+ install -Dm644 "contrib/debian/examples/bitcoin.conf" \
+ -t "$pkgdir/usr/share/doc/bitcoin/examples"
+
msg2 'Installing documentation...'
install -dm 755 "$pkgdir/usr/share/doc/bitcoin"
for _doc in \