summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquest2020-06-24 16:16:46 -0700
committerquest2020-06-24 16:16:46 -0700
commit2465eb3750e721805b55f10519e7b3c36ceb7337 (patch)
treeef2460beb9345e2f7decca0ef52fa20a44cb3d66
parentf850ff7364211ddb90bbaf07502bc51a2eb70dfe (diff)
downloadaur-2465eb3750e721805b55f10519e7b3c36ceb7337.tar.gz
Fix QT build by adding QPainterPath import
-rw-r--r--.SRCINFO2
-rw-r--r--20200624-fix-qpainterpath-on-recent-qt.patch12
-rw-r--r--PKGBUILD8
3 files changed, 20 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 647a29af6e5a..3a7820d0321d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -38,12 +38,14 @@ pkgbase = bitcoin-cash-node-qt
source = bitcoin.service
source = bitcoin-reindex.service
source = bitcoin.install
+ source = 20200624-fix-qpainterpath-on-recent-qt.patch
sha256sums = a4f959edc39523423e6f791aef5a448b5c2ab9ca3319f329fd6facc7af422843
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880
sha256sums = 35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679
sha256sums = abef8a36e4990b85b3a556f546ea8f8349bb7c9d10dbbd7ff8013ae0b931a849
+ sha256sums = f76f4ff434632c19e39d9ff7627786f304bed2ee33cfba843ae06e5c003dc60e
pkgname = bitcoin-cash-node-qt
diff --git a/20200624-fix-qpainterpath-on-recent-qt.patch b/20200624-fix-qpainterpath-on-recent-qt.patch
new file mode 100644
index 000000000000..ab555f692c2c
--- /dev/null
+++ b/20200624-fix-qpainterpath-on-recent-qt.patch
@@ -0,0 +1,12 @@
+diff --git a/src/qt/trafficgraphwidget.cpp b/src/qt/trafficgraphwidget.cpp
+index ae93572b7..815ee4882 100644
+--- a/src/qt/trafficgraphwidget.cpp
++++ b/src/qt/trafficgraphwidget.cpp
+@@ -9,6 +9,7 @@
+
+ #include <QColor>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QTimer>
+
+ #include <cmath>
diff --git a/PKGBUILD b/PKGBUILD
index d0032ea1372b..13cf8773b07f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,13 +14,15 @@ source=(https://github.com/bitcoin-cash-node/bitcoin-cash-node/archive/v$pkgver.
bitcoin.logrotate
bitcoin.service
bitcoin-reindex.service
- bitcoin.install)
+ bitcoin.install
+ 20200624-fix-qpainterpath-on-recent-qt.patch)
sha256sums=('a4f959edc39523423e6f791aef5a448b5c2ab9ca3319f329fd6facc7af422843'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'9643eed2c20d78a9c7347df64099765773615f79d3b8a95693d871c933516880'
'35ff9331d7df8b90adfc7d82752cca4f8b7ff23a29e5d10b07e4e3fc78050679'
- 'abef8a36e4990b85b3a556f546ea8f8349bb7c9d10dbbd7ff8013ae0b931a849')
+ 'abef8a36e4990b85b3a556f546ea8f8349bb7c9d10dbbd7ff8013ae0b931a849'
+ 'f76f4ff434632c19e39d9ff7627786f304bed2ee33cfba843ae06e5c003dc60e')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt' 'bitcoin-seeder')
@@ -30,6 +32,8 @@ install=bitcoin.install
build() {
cd "$srcdir/bitcoin-cash-node-$pkgver"
+ patch -Np1 < ../20200624-fix-qpainterpath-on-recent-qt.patch
+
msg2 'Building...'
mkdir -p build
pushd build