summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorquest2023-05-19 20:11:00 -1000
committerquest2023-05-19 20:11:00 -1000
commit24ea3ee5765a84cf1b80af6fef449c412a4df28f (patch)
treec96eeb5cb0b64f3e8aea15eaea785f1f455d5d28
parent1582be880fed5d37c33aae590f05699d29a792f3 (diff)
downloadaur-24ea3ee5765a84cf1b80af6fef449c412a4df28f.tar.gz
Fix build issues
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--queue.patch58
3 files changed, 61 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1e077217a73..642f18a92db1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-cash-node-qt
pkgdesc = Bitcoin Cash Node with bitcoind, bitcoin-cli, bitcoin-tx, bitcoin-seeder and bitcoin-qt
pkgver = 26.0.0
- pkgrel = 4
+ pkgrel = 5
url = https://bitcoincashnode.org
install = bitcoin.install
arch = i686
@@ -50,6 +50,6 @@ pkgbase = bitcoin-cash-node-qt
sha256sums = e2d6c370fa9f1564013ce0d255f764b8972284d5909d509a306a43994a49a113
sha256sums = 0ba95ed8914f1c3d7fb3601a9735d53be0445aa070a003f7938bfff754677578
sha256sums = 4b374456a28d1172933aad0b285aa7dd4e9d67058b9b9958dd0065c6c46acba1
- sha256sums = a668667fdcb86ea13b14e4fe3d8878e08f1eb0b0c23eaa1c4e251f93dac7194d
+ sha256sums = 910564b80418ad93a5569f2c41878357ba19d1698c8093e9116a356163e619fe
pkgname = bitcoin-cash-node-qt
diff --git a/PKGBUILD b/PKGBUILD
index 5fc93cd02590..8335b5673857 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitcoin-cash-node-qt
pkgver=26.0.0
-pkgrel=4
+pkgrel=5
pkgdesc="Bitcoin Cash Node with bitcoind, bitcoin-cli, bitcoin-tx, bitcoin-seeder and bitcoin-qt"
arch=('i686' 'x86_64')
url="https://bitcoincashnode.org"
@@ -26,7 +26,7 @@ sha256sums=('c87dfdf97ec8a1ee5ddb6447fcdea6e42714c79bb9424e5312dba5b083a8fcd2'
'e2d6c370fa9f1564013ce0d255f764b8972284d5909d509a306a43994a49a113'
'0ba95ed8914f1c3d7fb3601a9735d53be0445aa070a003f7938bfff754677578'
'4b374456a28d1172933aad0b285aa7dd4e9d67058b9b9958dd0065c6c46acba1'
- 'a668667fdcb86ea13b14e4fe3d8878e08f1eb0b0c23eaa1c4e251f93dac7194d')
+ '910564b80418ad93a5569f2c41878357ba19d1698c8093e9116a356163e619fe')
backup=('etc/bitcoin/bitcoin.conf'
'etc/logrotate.d/bitcoin')
provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx' 'bitcoin-qt' 'bitcoin-seeder')
diff --git a/queue.patch b/queue.patch
index efac903be643..4e3eb3cb5c32 100644
--- a/queue.patch
+++ b/queue.patch
@@ -21,4 +21,60 @@ index 99ab618e23..4fd04a7dc2 100644
+#include <deque>
#include <limits>
#include <list>
- #include <optional> \ No newline at end of file
+ #include <optional>
+--- src/support/lockedpool.h
++++ src/support/lockedpool.h
+@@ -11,6 +11,7 @@
+ #include <memory>
+ #include <mutex>
+ #include <unordered_map>
++#include <stdexcept>
+
+ /**
+ * OS-dependent allocation and deallocation of locked/pinned memory pages.
+--- src/tinyformat.h
++++ src/tinyformat.h
+@@ -138,6 +138,7 @@
+ #include <locale>
+ #include <sstream>
+ #include <stdexcept>
++#include <cstdint>
+
+ #ifndef TINYFORMAT_ERROR
+ #define TINYFORMAT_ERROR(reason) assert(0 && reason)
+--- src/base58.h
++++ src/base58.h
+@@ -20,6 +20,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdint>
+
+ /**
+ * Encode a byte sequence as a base58-encoded string.
+--- src/wallet/test/wallet_tests.cpp
++++ src/wallet/test/wallet_tests.cpp
+@@ -607,7 +607,22 @@
+ BOOST_CHECK_EQUAL(CalculateP2PKHInputSize(true), DUMMY_P2PKH_INPUT_SIZE);
+ }
+
+-BOOST_FIXTURE_TEST_CASE(wallet_bip69, ListCoinsTestingSetup) {
++struct Upgrade9NotActivatedTestingSetup : ListCoinsTestingSetup {
++ Upgrade9NotActivatedTestingSetup() : ListCoinsTestingSetup() {
++ gArgs.ForceSetArg("-upgrade9activationtime", "9223372036854775807"); // force activation always off for this test fixture
++ LOCK(cs_main);
++ // Ensure upgrade 9 (tokens) is not active for next block and mempool
++ BOOST_CHECK(!IsUpgrade9Enabled(::GetConfig().GetChainParams().GetConsensus(), ::ChainActive().Tip()));
++ }
++ ~Upgrade9NotActivatedTestingSetup() {
++ gArgs.ClearArg("-upgrade9activationtime");
++ }
++};
++
++BOOST_FIXTURE_TEST_CASE(wallet_bip69, Upgrade9NotActivatedTestingSetup) {
++ // Note: The entire point of this test is to *just* test tx sorting with/without bip69 enabled when token data is
++ // present/absent, and as such we didn't bother creating consensus-respecting CashToken txns for this test (which
++ // is why this test requires upgrade9 be disabled).
+ Defer d([]{
+ // undo forceSetArg
+ gArgs.ClearArg("-usebip69");