summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUncle Hunto2016-04-16 20:32:16 -0700
committerUncle Hunto2016-04-16 20:32:16 -0700
commit08ac8fb31a78e5ac88e00a890f667fec9668f612 (patch)
tree39e7845ffe51578af40d3519b8820c45c4af2956
parentf0bf4d32e38f4ddec5195fcdc0e2ab4574326948 (diff)
downloadaur-08ac8fb31a78e5ac88e00a890f667fec9668f612.tar.gz
Update to Qt5, remove upnp due to security concerns
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD10
2 files changed, 15 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98aa0d2fab51..218b01d76317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,27 @@
# Generated by mksrcinfo v8
-# Tue Mar 8 01:50:32 UTC 2016
+# Sun Apr 17 03:31:09 UTC 2016
pkgbase = bitcoin-classic-git
pkgdesc = Bitcoin Classic versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, most recent stable branch, w/GUI and wallet
- pkgver = v0.12.0cl1.r2.gd10f990
- pkgrel = 1
+ pkgver = v0.12.0cl1.r14.gc596b82
+ pkgrel = 2
url = https://bitcoinclassic.com/
install = bitcoin-qt.install
arch = i686
arch = x86_64
license = MIT
makedepends = boost
- makedepends = automoc4
+ makedepends = libevent
+ makedepends = qt5-base
+ makedepends = qt5-tools
makedepends = qrencode
- makedepends = miniupnpc
makedepends = protobuf
depends = boost-libs
- depends = openssl
- depends = miniupnpc
+ depends = desktop-file-utils
+ depends = libevent
+ depends = qt5-base
depends = protobuf
depends = qrencode
- depends = qt4
+ depends = openssl
provides = bitcoin-daemon
provides = bitcoin-cli
provides = bitcoin-qt
diff --git a/PKGBUILD b/PKGBUILD
index aea8822b4f43..9e4f6e220bba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Uncle Hunto <unclehunto äτ ÝãΗ00 Ð0τ ÇÖΜ>
pkgname=bitcoin-classic-git
-pkgver=v0.12.0cl1.r2.gd10f990
-pkgrel=1
+pkgver=v0.12.0cl1.r14.gc596b82
+pkgrel=2
pkgdesc='Bitcoin Classic versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, most recent stable branch, w/GUI and wallet'
arch=('i686' 'x86_64')
url="https://bitcoinclassic.com/"
license=('MIT')
-depends=('boost-libs' 'openssl' 'miniupnpc' 'protobuf' 'qrencode' 'qt4')
-makedepends=('boost' 'automoc4' 'qrencode' 'miniupnpc' 'protobuf')
+depends=('boost-libs' 'desktop-file-utils' 'libevent' 'qt5-base' 'protobuf' 'qrencode' 'openssl')
+makedepends=('boost' 'libevent' 'qt5-base' 'qt5-tools' 'qrencode' 'protobuf')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
install=bitcoin-qt.install
@@ -26,7 +26,7 @@ build() {
msg2 'Building...'
CXXFLAGS="$CXXFLAGS -DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT=1"
./autogen.sh
- ./configure --prefix=/usr --with-incompatible-bdb --with-gui=qt4
+ ./configure --prefix=/usr --with-incompatible-bdb --with-gui=qt5
make -j$(nproc)
}