summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-10-08 13:44:37 -0700
committerAndy Weidenbaum2015-10-08 13:44:37 -0700
commit128a26cb52c87c0cc813e8c8f185554641d8c8cc (patch)
treed0b999835df2b485ce552e987b9e32ab2ba2b69c
parent47b6bb5877e7a01df48fa3966d41f6ec045ee1a9 (diff)
downloadaur-128a26cb52c87c0cc813e8c8f185554641d8c8cc.tar.gz
increment pkgrel to 2; added patch to build with latest miniupnpc
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--miniupnpc.patch30
3 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6235b2df829b..dbc192d705c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-core
pkgdesc = Bitcoin Core headless P2P node
pkgver = 0.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://bitcoin.org
install = bitcoin.install
arch = i686
@@ -30,11 +30,13 @@ pkgbase = bitcoin-core
backup = etc/bitcoin/bitcoin.conf
backup = etc/logrotate.d/bitcoin
source = bitcoin-0.11.0.tar.gz::https://codeload.github.com/bitcoin/bitcoin/tar.gz/v0.11.0
+ source = miniupnpc.patch::https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch
source = bitcoin.conf
source = bitcoin.logrotate
source = bitcoin.service
source = bitcoin-reindex.service
sha256sums = 2bcd61a4c288e5cc5d7fbe724606c610a20037332b06f7a9e99c1153eef73aef
+ sha256sums = 0910004577764c2251a33c4868c7358a42da68f94d6462e44bbcb1945cefd748
sha256sums = 67c464e4314ab5f7234a091098a05706989394086e4ee21e1d9155b9d1421796
sha256sums = 8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f
sha256sums = 5e45f2ceaeb7bfa60aeb66ca4167068191eb4358af03f95ac70fd96d9b006349
diff --git a/PKGBUILD b/PKGBUILD
index c9b5654c89e6..dc687f8e3969 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitcoin-core
pkgver=0.11.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Core headless P2P node"
arch=('i686' 'x86_64')
url="https://bitcoin.org"
@@ -21,11 +21,13 @@ makedepends=('autoconf'
'yasm')
license=('MIT')
source=(${pkgname%-core}-$pkgver.tar.gz::https://codeload.github.com/bitcoin/bitcoin/tar.gz/v$pkgver
+ miniupnpc.patch::https://github.com/bitcoin/bitcoin/commit/9f3e48e5219a09b5ddfd6883d1f0498910eff4b6.patch
bitcoin.conf
bitcoin.logrotate
bitcoin.service
bitcoin-reindex.service)
sha256sums=('2bcd61a4c288e5cc5d7fbe724606c610a20037332b06f7a9e99c1153eef73aef'
+ '0910004577764c2251a33c4868c7358a42da68f94d6462e44bbcb1945cefd748'
'67c464e4314ab5f7234a091098a05706989394086e4ee21e1d9155b9d1421796'
'8f05207b586916d489b7d25a68eaacf6e678d7cbb5bfbac551903506b32f904f'
'5e45f2ceaeb7bfa60aeb66ca4167068191eb4358af03f95ac70fd96d9b006349'
@@ -36,6 +38,13 @@ provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx')
conflicts=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-qt' 'bitcoin-tx')
install=bitcoin.install
+prepare() {
+ cd "$srcdir/${pkgname%-core}-$pkgver"
+
+ msg2 'Applying patch for miniupnpc 1.9.20150730...'
+ patch -p1 --merge < "$srcdir/miniupnpc.patch"
+}
+
build() {
cd "$srcdir/${pkgname%-core}-$pkgver"
diff --git a/miniupnpc.patch b/miniupnpc.patch
new file mode 100644
index 000000000000..88c2f10b3117
--- /dev/null
+++ b/miniupnpc.patch
@@ -0,0 +1,30 @@
+From 9f3e48e5219a09b5ddfd6883d1f0498910eff4b6 Mon Sep 17 00:00:00 2001
+From: Pavel Vasin <pavel@vasin.nl>
+Date: Sun, 23 Aug 2015 23:53:49 +0300
+Subject: [PATCH] add support for miniupnpc api version 14
+
+The value of new arg ttl is set to 2 as it's recommended default.
+---
+ src/net.cpp | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/src/net.cpp b/src/net.cpp
+index fb5726a..4c6331f 100644
+--- a/src/net.cpp
++++ b/src/net.cpp
+@@ -1120,10 +1120,14 @@ void ThreadMapPort()
+ #ifndef UPNPDISCOVER_SUCCESS
+ /* miniupnpc 1.5 */
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0);
+-#else
++#elif MINIUPNPC_API_VERSION < 14
+ /* miniupnpc 1.6 */
+ int error = 0;
+ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, &error);
++#else
++ /* miniupnpc 1.9.20150730 */
++ int error = 0;
++ devlist = upnpDiscover(2000, multicastif, minissdpdpath, 0, 0, 2, &error);
+ #endif
+
+ struct UPNPUrls urls;