summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2020-03-10 22:05:31 +0100
committermrxx2020-03-10 22:05:31 +0100
commit9c21589e4eda58c9eb35db5c966a14c908eac163 (patch)
treef9856d02c0fe9d06dd140c7d53c040ce0d9d8aa1
parentb54edd50a6836880fc08b29932c6c4edc8b24d01 (diff)
downloadaur-9c21589e4eda58c9eb35db5c966a14c908eac163.tar.gz
Remove nproc from make; Update service units
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--bitcoind-reindex.service12
-rw-r--r--bitcoind.service12
4 files changed, 27 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c9353840f7b..5f375d055f22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-core
pkgdesc = Bitcoin Core headless P2P node
pkgver = 0.19.1
- pkgrel = 1
+ pkgrel = 2
url = https://bitcoincore.org
install = bitcoind.install
arch = aarch64
@@ -47,8 +47,8 @@ pkgbase = bitcoin-core
sha256sums = f2591d555b8e8c2e1bd780e40d53a91e165d8b3c7e0391ae2d24a0c0f23a7cc0
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73
- sha256sums = a25e1a1e42d21f97282a53b8e571f0cef2081ce365dd70743131288ccc579b5c
- sha256sums = a04799dece0dc3decaa8c3bdab39fb8bdb074187f9b506a1e25603b572e58ae7
+ sha256sums = 7429a9db1da6bc2eed1ae87f61ab9faecaa3d5d6113422f99a146cc1d8e4b5fd
+ sha256sums = b5ef856ccf61fd784afa136387d4cf867988b5f525375a0706072e6262166d83
sha256sums = f126b4824e43d9760ab2021460a37d859986f07e1ac9245ee4938e832739f73a
sha256sums = 0b4f7ec41cf88aa1278d089a03f116c33bac62dec038903f4ced58da67afb980
sha256sums = f1c3727220df06993a61cc9f4ef25c83cdaf3624179b5ead8383bc9ef7109e70
diff --git a/PKGBUILD b/PKGBUILD
index 8e554a9bd752..1c1ce47ef959 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bitcoin-core
pkgver=0.19.1
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Core headless P2P node"
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
url="https://bitcoincore.org"
@@ -24,8 +24,8 @@ source=(https://bitcoincore.org/bin/bitcoin-core-$pkgver/bitcoin-$pkgver.tar.gz
sha256sums=('f2591d555b8e8c2e1bd780e40d53a91e165d8b3c7e0391ae2d24a0c0f23a7cc0'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73'
- 'a25e1a1e42d21f97282a53b8e571f0cef2081ce365dd70743131288ccc579b5c'
- 'a04799dece0dc3decaa8c3bdab39fb8bdb074187f9b506a1e25603b572e58ae7'
+ '7429a9db1da6bc2eed1ae87f61ab9faecaa3d5d6113422f99a146cc1d8e4b5fd'
+ 'b5ef856ccf61fd784afa136387d4cf867988b5f525375a0706072e6262166d83'
'f126b4824e43d9760ab2021460a37d859986f07e1ac9245ee4938e832739f73a'
'0b4f7ec41cf88aa1278d089a03f116c33bac62dec038903f4ced58da67afb980'
'f1c3727220df06993a61cc9f4ef25c83cdaf3624179b5ead8383bc9ef7109e70'
@@ -38,10 +38,6 @@ provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx')
conflicts=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-qt' 'bitcoin-tx' 'bitcoin-core-git')
install=bitcoind.install
-# half of available processing units or one if only one is available
-_nproc=$(($(nproc)/2))
-[[ ${_nproc} < 1 ]] && _nproc=1
-
build() {
cd "$srcdir/${pkgname%-core}-$pkgver"
@@ -59,7 +55,7 @@ build() {
--disable-wallet \
--without-miniupnpc \
--with-gnu-ld
- make -j$_nproc
+ make
}
check() {
diff --git a/bitcoind-reindex.service b/bitcoind-reindex.service
index 6cc8c7708c96..5418f52da700 100644
--- a/bitcoind-reindex.service
+++ b/bitcoind-reindex.service
@@ -5,8 +5,9 @@
# See "man systemd.service" for details.
# Note that almost all daemon options could be specified in
-# /etc/bitcoin/bitcoin.conf, except for those explicitly specified as arguments
-# in ExecStart=
+# /etc/bitcoin/bitcoin.conf, but keep in mind those explicitly
+# specified as arguments in ExecStart= will override those in the
+# config file.
[Unit]
Description=Bitcoin daemon (reindex)
@@ -19,6 +20,10 @@ ExecStart=/usr/bin/bitcoind -daemon \
-reindex \
-datadir=/var/lib/bitcoind
+# Make sure the config directory is readable by the service user
+PermissionsStartOnly=true
+ExecStartPre=/bin/chgrp bitcoin /etc/bitcoin
+
# Process management
####################
@@ -54,6 +59,9 @@ PrivateTmp=true
# Mount /usr, /boot/ and /etc read-only for the process.
ProtectSystem=full
+# Deny access to /home, /root and /run/user
+ProtectHome=true
+
# Disallow the process and all of its children to gain
# new privileges through execve().
NoNewPrivileges=true
diff --git a/bitcoind.service b/bitcoind.service
index d94bac01d5e9..9efe19ed1de0 100644
--- a/bitcoind.service
+++ b/bitcoind.service
@@ -5,8 +5,9 @@
# See "man systemd.service" for details.
# Note that almost all daemon options could be specified in
-# /etc/bitcoin/bitcoin.conf, except for those explicitly specified as arguments
-# in ExecStart=
+# /etc/bitcoin/bitcoin.conf, but keep in mind those explicitly
+# specified as arguments in ExecStart= will override those in the
+# config file.
[Unit]
Description=Bitcoin daemon
@@ -18,6 +19,10 @@ ExecStart=/usr/bin/bitcoind -daemon \
-conf=/etc/bitcoin/bitcoin.conf \
-datadir=/var/lib/bitcoind
+# Make sure the config directory is readable by the service user
+PermissionsStartOnly=true
+ExecStartPre=/bin/chgrp bitcoin /etc/bitcoin
+
# Process management
####################
@@ -53,6 +58,9 @@ PrivateTmp=true
# Mount /usr, /boot/ and /etc read-only for the process.
ProtectSystem=full
+# Deny access to /home, /root and /run/user
+ProtectHome=true
+
# Disallow the process and all of its children to gain
# new privileges through execve().
NoNewPrivileges=true