summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormrxx2020-06-03 18:27:41 +0200
committermrxx2020-06-03 18:27:41 +0200
commitb65f9d98e6a448f13946cda921efa03d2086bfa3 (patch)
tree217ca8d309d10da11b2fed97bcc7a09c94c266ed
parent9c21589e4eda58c9eb35db5c966a14c908eac163 (diff)
downloadaur-b65f9d98e6a448f13946cda921efa03d2086bfa3.tar.gz
Updpkg: 0.20.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD16
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f375d055f22..d821912adc3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoin-core
pkgdesc = Bitcoin Core headless P2P node
- pkgver = 0.19.1
- pkgrel = 2
+ pkgver = 0.20.0
+ pkgrel = 1
url = https://bitcoincore.org
install = bitcoind.install
arch = aarch64
@@ -34,7 +34,7 @@ pkgbase = bitcoin-core
backup = etc/bitcoin/bitcoin.conf
backup = etc/logrotate.d/bitcoin
backup = etc/logrotate.d/bitcoind
- source = https://bitcoincore.org/bin/bitcoin-core-0.19.1/bitcoin-0.19.1.tar.gz
+ source = https://bitcoincore.org/bin/bitcoin-core-0.20.0/bitcoin-0.20.0.tar.gz
source = bitcoin.conf
source = bitcoind.logrotate
source = bitcoind.service
@@ -44,11 +44,11 @@ pkgbase = bitcoin-core
source = bitcoin-core-01-userdel.hook
source = bitcoin-core-02-chown.hook
source = bitcoin-core-02-rm-rf.hook
- sha256sums = f2591d555b8e8c2e1bd780e40d53a91e165d8b3c7e0391ae2d24a0c0f23a7cc0
+ sha256sums = ec5a2358ee868d845115dc4fc3ed631ff063c57d5e0a713562d083c5c45efb28
sha256sums = b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35
sha256sums = 7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73
- sha256sums = 7429a9db1da6bc2eed1ae87f61ab9faecaa3d5d6113422f99a146cc1d8e4b5fd
- sha256sums = b5ef856ccf61fd784afa136387d4cf867988b5f525375a0706072e6262166d83
+ sha256sums = a25e1a1e42d21f97282a53b8e571f0cef2081ce365dd70743131288ccc579b5c
+ sha256sums = a04799dece0dc3decaa8c3bdab39fb8bdb074187f9b506a1e25603b572e58ae7
sha256sums = f126b4824e43d9760ab2021460a37d859986f07e1ac9245ee4938e832739f73a
sha256sums = 0b4f7ec41cf88aa1278d089a03f116c33bac62dec038903f4ced58da67afb980
sha256sums = f1c3727220df06993a61cc9f4ef25c83cdaf3624179b5ead8383bc9ef7109e70
diff --git a/PKGBUILD b/PKGBUILD
index 1c1ce47ef959..dc73adb78417 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Andy Weidenbaum <archbaum@gmail.com>
pkgname=bitcoin-core
-pkgver=0.19.1
-pkgrel=2
+pkgver=0.20.0
+pkgrel=1
pkgdesc="Bitcoin Core headless P2P node"
arch=('aarch64' 'armv6h' 'armv7h' 'i686' 'x86_64')
url="https://bitcoincore.org"
@@ -21,11 +21,11 @@ source=(https://bitcoincore.org/bin/bitcoin-core-$pkgver/bitcoin-$pkgver.tar.gz
bitcoin-core-01-userdel.hook
bitcoin-core-02-chown.hook
bitcoin-core-02-rm-rf.hook)
-sha256sums=('f2591d555b8e8c2e1bd780e40d53a91e165d8b3c7e0391ae2d24a0c0f23a7cc0'
+sha256sums=('ec5a2358ee868d845115dc4fc3ed631ff063c57d5e0a713562d083c5c45efb28'
'b1908344281498d39bfa40c3b9725f9c95bf22602cd46e6120a1f17bad9dae35'
'7bf4bdad419c1ee30b88c7e4190707c5ff250da8b23d68d5adf14043f8e2ac73'
- '7429a9db1da6bc2eed1ae87f61ab9faecaa3d5d6113422f99a146cc1d8e4b5fd'
- 'b5ef856ccf61fd784afa136387d4cf867988b5f525375a0706072e6262166d83'
+ 'a25e1a1e42d21f97282a53b8e571f0cef2081ce365dd70743131288ccc579b5c'
+ 'a04799dece0dc3decaa8c3bdab39fb8bdb074187f9b506a1e25603b572e58ae7'
'f126b4824e43d9760ab2021460a37d859986f07e1ac9245ee4938e832739f73a'
'0b4f7ec41cf88aa1278d089a03f116c33bac62dec038903f4ced58da67afb980'
'f1c3727220df06993a61cc9f4ef25c83cdaf3624179b5ead8383bc9ef7109e70'
@@ -38,6 +38,10 @@ provides=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-tx')
conflicts=('bitcoin-cli' 'bitcoin-daemon' 'bitcoin-qt' 'bitcoin-tx' 'bitcoin-core-git')
install=bitcoind.install
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
build() {
cd "$srcdir/${pkgname%-core}-$pkgver"
@@ -55,7 +59,7 @@ build() {
--disable-wallet \
--without-miniupnpc \
--with-gnu-ld
- make
+ make -j$_nproc
}
check() {