summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2017-06-07 15:43:33 -0700
committerAndy Weidenbaum2017-06-07 15:43:33 -0700
commita15c34f7073893234c517f4f4c9bee60ad8861da (patch)
treecc56b7483d86bc58e81e33791d341c7f70b654a8
parent59e131579ceb62ec16daabbb9b907dc917225d83 (diff)
downloadaur-a15c34f7073893234c517f4f4c9bee60ad8861da.tar.gz
increment pkgrel; fix make -j for nproc=1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 82cfba5302f1..7ed710fe025d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sat Apr 22 17:12:41 UTC 2017
+# Wed Jun 7 22:36:19 UTC 2017
pkgbase = bitcoin-core-git
pkgdesc = Bitcoin Core headless P2P node
pkgver = 20170422
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bitcoin/bitcoin
install = bitcoin.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index b2e961789edb..4c91e1d3a1a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitcoin-core-git
pkgver=20170422
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Core headless P2P node"
arch=('i686' 'x86_64')
url="https://github.com/bitcoin/bitcoin"
@@ -35,6 +35,10 @@ provides=('bitcoin-cli' 'bitcoin-core' 'bitcoin-daemon' 'bitcoin-tx')
conflicts=('bitcoin-cli' 'bitcoin-core' 'bitcoin-daemon' 'bitcoin-qt' 'bitcoin-tx')
install=bitcoin.install
+# half of available processing units or one if only one is available
+_nproc=$(($(nproc)/2))
+[[ ${_nproc} < 1 ]] && _nproc=1
+
pkgver() {
cd ${pkgname%%-*}
git log -1 --format="%cd" --date=short | sed "s|-||g"
@@ -56,14 +60,14 @@ build() {
--with-gui=no \
--disable-wallet \
--with-gnu-ld
- make -j$(($(nproc)/2))
+ make -j$_nproc
}
check() {
cd "${pkgname%%-*}"
msg2 'Testing...'
- make -j$(($(nproc)/2)) check
+ make -j$_nproc check
}
package() {