summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2023-09-02 23:06:45 -0400
committerredfish2023-09-02 23:06:45 -0400
commit11be479003083a62aea7fca0e4e13f0df3f1655e (patch)
treef66d3b68f37a289810ba815b84179f1558d97303
parent8e15d215238c6900a4849bbc9406f545aeb9fe1f (diff)
downloadaur-11be479003083a62aea7fca0e4e13f0df3f1655e.tar.gz
update to 2.0.0.0
Note that the patch regarding VARINT static assert failure: the argument is unsignd, so the DEFAULT VarIntMode works for it. So, we fixed the failure by removing the mode, letting it be default. But, upstream did the other fix, which is to cast to arg to a signed type, keeping the non-default VarIntMode. b1b51490058bbc693eca8ef7abd69dc022446201 cast nHeight to int32_t to match the VarIntMode expected type/value https://gitlab.com/bitcoinunlimited/BCHUnlimited/-/commit/b1b51490058bbc693eca8ef7abd69dc022446201
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--include-cstdint.patch20
-rw-r--r--varint-default-mode.patch11
4 files changed, 54 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a34eb9211762..a6f8d2f38c9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitcoin-unlimited
pkgdesc = Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, w/GUI and wallet
- pkgver = 1.9.1.1
+ pkgver = 2.0.0.0
pkgrel = 1
url = http://www.bitcoinunlimited.info
install = bitcoin-unlimited.install
@@ -28,8 +28,11 @@ pkgbase = bitcoin-unlimited
conflicts = bitcoin-cli
conflicts = bitcoin-qt
conflicts = bitcoin-tx
- source = https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited1.9.1.1.tar.gz
- sha256sums = 18e38a77715baa32dda9049971def39f91b029a3b8308ccc3c7d90ef453fad03
+ source = https://gitlab.com/bitcoinunlimited/BCHUnlimited/-/archive/BCHunlimited2.0.0.0/BCHUnlimited-BCHunlimited2.0.0.0.tar.bz2
+ source = include-cstdint.patch
+ source = varint-default-mode.patch
+ sha256sums = d744af691a23a46cccace8e2f5d45e17c3c70af10851a659bb28d1ab4684d0d6
+ sha256sums = 33da7529884988c62924e691ead10b59a137fcf6bd88cb0802f2090f670ba9be
+ sha256sums = b7350c2ee6de0304f02bd1b54bc13a60886b3bc7cda4f92612e760bddbb08fb7
pkgname = bitcoin-unlimited
-
diff --git a/PKGBUILD b/PKGBUILD
index fc683da75f6f..e434788ec243 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: redfish <redfish at galactica.pw>
pkgname=bitcoin-unlimited
-pkgver=1.9.1.1
-_pkgbase=BitcoinUnlimited-BCHunlimited${pkgver}
+pkgver=2.0.0.0
+_pkgbase=BCHUnlimited-BCHunlimited${pkgver}
pkgrel=1
pkgdesc='Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli,
bitcoin-tx, and bitcoin-qt, w/GUI and wallet'
@@ -15,9 +15,19 @@ optdepends=('miniupnpc' 'db4.8' 'qt5-base' 'protobuf' 'qrencode')
makedepends=('boost' 'qt5-tools')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-unlimited-git' 'bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-source=("https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited${pkgver}.tar.gz")
+source=("https://gitlab.com/bitcoinunlimited/BCHUnlimited/-/archive/BCHunlimited${pkgver}/BCHUnlimited-BCHunlimited${pkgver}.tar.bz2"
+ "include-cstdint.patch"
+ "varint-default-mode.patch")
install=$pkgname.install
+prepare() {
+ cd "$srcdir/$_pkgbase"
+
+ patch -p1 -i ../include-cstdint.patch
+ patch -p1 -i ../varint-default-mode.patch
+}
+
+
build() {
cd "$srcdir/$_pkgbase"
@@ -45,4 +55,6 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha256sums=('18e38a77715baa32dda9049971def39f91b029a3b8308ccc3c7d90ef453fad03')
+sha256sums=('d744af691a23a46cccace8e2f5d45e17c3c70af10851a659bb28d1ab4684d0d6'
+ '33da7529884988c62924e691ead10b59a137fcf6bd88cb0802f2090f670ba9be'
+ 'b7350c2ee6de0304f02bd1b54bc13a60886b3bc7cda4f92612e760bddbb08fb7')
diff --git a/include-cstdint.patch b/include-cstdint.patch
new file mode 100644
index 000000000000..798926f125de
--- /dev/null
+++ b/include-cstdint.patch
@@ -0,0 +1,20 @@
+--- a/src/extversionkeys.h 2023-09-02 21:22:46.683167966 -0400
++++ b/src/extversionkeys.h 2023-09-02 21:22:53.553190398 -0400
+@@ -8,6 +8,7 @@
+
+ #include <unordered_map>
+ #include <unordered_set>
++#include <cstdint>
+
+ #define ADD_UL(key, ul) key##ul
+
+--- a/src/test/scriptflags.h 2023-09-02 21:58:02.646743405 -0400
++++ b/src/test/scriptflags.h 2023-09-02 21:58:12.316774978 -0400
+@@ -7,6 +7,7 @@
+ #define BITCOIN_TEST_SCRIPTFLAGS_H
+
+ #include <string>
++#include <cstdint>
+
+ uint32_t ParseScriptFlags(std::string strFlags);
+ std::string FormatScriptFlags(uint32_t flags);
diff --git a/varint-default-mode.patch b/varint-default-mode.patch
new file mode 100644
index 000000000000..f46f99e997ce
--- /dev/null
+++ b/varint-default-mode.patch
@@ -0,0 +1,11 @@
+--- a/src/undo.h 2023-09-02 21:48:49.154936214 -0400
++++ b/src/undo.h 2023-09-02 21:50:18.328560717 -0400
+@@ -27,7 +27,7 @@
+ template <typename Stream>
+ void Serialize(Stream &s) const
+ {
+- ::Serialize(s, VARINT(txout->nHeight * 2 + (txout->fCoinBase ? 1 : 0), VarIntMode::NONNEGATIVE_SIGNED));
++ ::Serialize(s, VARINT(txout->nHeight * 2 + (txout->fCoinBase ? 1 : 0)));
+ if (txout->nHeight > 0)
+ {
+ // Required to maintain compatibility with older undo format.