summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredfish2020-05-24 00:23:33 -0400
committerredfish2020-05-24 00:25:53 -0400
commit2332e4bd132d79564024dcea0b61dbb6f7eb15f5 (patch)
tree6a78982608c451b45dd3ebbc9870b657bdb8136d
parent55e15e1716bce43c31ec30e0a80624b325615299 (diff)
downloadaur-2332e4bd132d79564024dcea0b61dbb6f7eb15f5.tar.gz
1.8.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD17
-rw-r--r--include-stack.patch10
4 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a9f02427c55b..383f9497b954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitcoin-unlimited
pkgdesc = Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, w/GUI and wallet
- pkgver = 1.7.0.0
+ pkgver = 1.8.0.0
pkgrel = 1
url = http://www.bitcoinunlimited.info
install = bitcoin-unlimited.install
@@ -28,8 +28,10 @@ pkgbase = bitcoin-unlimited
conflicts = bitcoin-cli
conflicts = bitcoin-qt
conflicts = bitcoin-tx
- source = https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/bucash1.7.0.0.tar.gz
- sha256sums = 667249285d51f0da539132f1e4423739eec8889326fbbb611368dc7dec068f5c
+ source = https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited1.8.0.0.tar.gz
+ source = include-stack.patch
+ sha256sums = c18b390348097c27772a9b1857d4646597b178c6c4cc6945c5ee6130ac075b55
+ sha256sums = 21b21e4f9c541d8412b5125e3d53e943b4794b5247f34f50bb84eaa1757cf9e0
pkgname = bitcoin-unlimited
diff --git a/.gitignore b/.gitignore
index ca455bc135da..262db9d5bc0f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*.tar.xz
*.tar.gz
+*.pkg.tar.zst
src/
pkg/
diff --git a/PKGBUILD b/PKGBUILD
index dba5c1cef5c4..174acf475554 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: redfish <redfish at galactica.pw>
pkgname=bitcoin-unlimited
-pkgver=1.7.0.0
-_pkgbase=BitcoinUnlimited-bucash${pkgver}
+pkgver=1.8.0.0
+_pkgbase=BitcoinUnlimited-BCHunlimited${pkgver}
pkgrel=1
pkgdesc='Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli,
bitcoin-tx, and bitcoin-qt, w/GUI and wallet'
@@ -15,10 +15,16 @@ optdepends=('miniupnpc' 'db4.8' 'qt5-base' 'protobuf' 'qrencode')
makedepends=('boost' 'qt5-tools')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-unlimited-git' 'bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-source=("https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/bucash${pkgver}.tar.gz")
-sha256sums=('667249285d51f0da539132f1e4423739eec8889326fbbb611368dc7dec068f5c')
+source=("https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited${pkgver}.tar.gz"
+ include-stack.patch)
install=$pkgname.install
+prepare() {
+ cd "$srcdir/$_pkgbase"
+ # fix compilation error
+ patch -p1 < ../include-stack.patch
+}
+
build() {
cd "$srcdir/$_pkgbase"
@@ -45,3 +51,6 @@ package() {
"$pkgdir/usr/share/man/man5/bitcoin.conf.5"
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
+
+sha256sums=('c18b390348097c27772a9b1857d4646597b178c6c4cc6945c5ee6130ac075b55'
+ '21b21e4f9c541d8412b5125e3d53e943b4794b5247f34f50bb84eaa1757cf9e0')
diff --git a/include-stack.patch b/include-stack.patch
new file mode 100644
index 000000000000..6f759872dc4c
--- /dev/null
+++ b/include-stack.patch
@@ -0,0 +1,10 @@
+--- a/src/unlimited.cpp 2020-05-24 00:01:58.645744803 -0400
++++ b/src/unlimited.cpp 2020-05-24 00:02:03.732479996 -0400
+@@ -54,6 +54,7 @@
+ #include <limits>
+ #include <queue>
+ #include <thread>
++#include <stack>
+
+ using namespace std;
+