summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitri Kaparis2020-11-19 18:01:45 +0200
committerDimitri Kaparis2020-11-19 18:01:45 +0200
commitc6f7d85d981bcfa37b50fbbfadf99aeb15f7d493 (patch)
treed0b3a05bb6aceab5886e31f2de5e866e6f86d548
parent4f51d7484c212d9bba4cb70637b38b565754356f (diff)
downloadaur-c6f7d85d981bcfa37b50fbbfadf99aeb15f7d493.tar.gz
Updated to release 1.9.0.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
-rw-r--r--QtPainterPath.patch20
-rw-r--r--include-stack.patch10
4 files changed, 6 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b9c1e38385a..14db09fe6a56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitcoin-unlimited
pkgdesc = Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli, bitcoin-tx, and bitcoin-qt, w/GUI and wallet
- pkgver = 1.9.0.0
+ pkgver = 1.9.0.1
pkgrel = 1
url = http://www.bitcoinunlimited.info
install = bitcoin-unlimited.install
@@ -28,12 +28,8 @@ pkgbase = bitcoin-unlimited
conflicts = bitcoin-cli
conflicts = bitcoin-qt
conflicts = bitcoin-tx
- source = https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited1.9.0.0.tar.gz
- source = include-stack.patch
- source = QtPainterPath.patch
- sha256sums = e05a13abf5554479ea6e02f9355d9a636bd3c73e50db4db99ced35ea9550af9a
- sha256sums = 21b21e4f9c541d8412b5125e3d53e943b4794b5247f34f50bb84eaa1757cf9e0
- sha256sums = 4f0a85b972a3b6a986b4c9a17da7b1fdf7c7c22f38588057c191d90db84ed3a8
+ source = https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited1.9.0.1.tar.gz
+ sha256sums = bce8d965af68985e5f5db8d6e0915dc8986eb939bd37bf4e064185255216458c
pkgname = bitcoin-unlimited
diff --git a/PKGBUILD b/PKGBUILD
index c7d14e5b9f7c..8751cffc5ccf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: redfish <redfish at galactica.pw>
pkgname=bitcoin-unlimited
-pkgver=1.9.0.0
+pkgver=1.9.0.1
_pkgbase=BitcoinUnlimited-BCHunlimited${pkgver}
pkgrel=1
pkgdesc='Bitcoin Unlimited Cash (BCH) versions of Bitcoind, bitcoin-cli,
@@ -15,19 +15,9 @@ optdepends=('miniupnpc' 'db4.8' 'qt5-base' 'protobuf' 'qrencode')
makedepends=('boost' 'qt5-tools')
provides=('bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
conflicts=('bitcoin-unlimited-git' 'bitcoin-daemon' 'bitcoin-cli' 'bitcoin-qt' 'bitcoin-tx')
-source=("https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited${pkgver}.tar.gz"
- include-stack.patch
- QtPainterPath.patch)
+source=("https://github.com/BitcoinUnlimited/BitcoinUnlimited/archive/BCHunlimited${pkgver}.tar.gz")
install=$pkgname.install
-prepare() {
- cd "$srcdir/$_pkgbase"
- # fix compilation error
- patch -p1 < ../include-stack.patch
- # PR 2251
- patch -p1 < ../QtPainterPath.patch
-}
-
build() {
cd "$srcdir/$_pkgbase"
@@ -55,6 +45,4 @@ package() {
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha256sums=('e05a13abf5554479ea6e02f9355d9a636bd3c73e50db4db99ced35ea9550af9a'
- '21b21e4f9c541d8412b5125e3d53e943b4794b5247f34f50bb84eaa1757cf9e0'
- '4f0a85b972a3b6a986b4c9a17da7b1fdf7c7c22f38588057c191d90db84ed3a8')
+sha256sums=('bce8d965af68985e5f5db8d6e0915dc8986eb939bd37bf4e064185255216458c')
diff --git a/QtPainterPath.patch b/QtPainterPath.patch
deleted file mode 100644
index 3d6e9f166943..000000000000
--- a/QtPainterPath.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/src/qt/trafficgraphwidget.cpp 2020-08-31 22:44:52.871926632 -0400
-+++ b/src/qt/trafficgraphwidget.cpp 2020-08-31 22:44:57.071990322 -0400
-@@ -8,6 +8,7 @@
-
- #include <QColor>
- #include <QPainter>
-+#include <QPainterPath>
- #include <QTimer>
-
- #include <cmath>
---- a/src/qt/transactiongraphwidget.cpp 22:42:15.162827802 -0400
-+++ b/src/qt/transactiongraphwidget.cpp 2020-08-31 22:42:24.322971462 -0400
-@@ -8,6 +8,7 @@
-
- #include <QColor>
- #include <QPainter>
-+#include <QPainterPath>
-
- #include <cmath>
-
diff --git a/include-stack.patch b/include-stack.patch
deleted file mode 100644
index 6f759872dc4c..000000000000
--- a/include-stack.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/unlimited.cpp 2020-05-24 00:01:58.645744803 -0400
-+++ b/src/unlimited.cpp 2020-05-24 00:02:03.732479996 -0400
-@@ -54,6 +54,7 @@
- #include <limits>
- #include <queue>
- #include <thread>
-+#include <stack>
-
- using namespace std;
-