summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Grousset/tuxayo2017-04-17 01:09:28 +0200
committerVictor Grousset/tuxayo2017-04-17 01:09:28 +0200
commitc5941e21c7d25ea2a821e2a64ab9f344ef7ce44f (patch)
tree3dead2921871850e696e4eb06d58cb677ee82af5
parent23c0b88ffed0e24564af0d450d7198f016beeb8d (diff)
downloadaur-c5941e21c7d25ea2a821e2a64ab9f344ef7ce44f.tar.gz
fix pkgver() to not duplicate revision number
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1b8dffeae688..285ad390755a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitcoind-unlimited-git
pkgdesc = Bitcoin Unlimited versions of bitcoind, bitcoin-cli, and bitcoin-tx
pkgver = 1.0.1.3.r929
- pkgrel = 2
+ pkgrel = 3
url = http://www.bitcoinunlimited.info
install = bitcoin.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 4000b2728a3c..481808dd7e8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=bitcoind-unlimited-git
pkgver=1.0.1.3.r929
-pkgrel=2
+pkgrel=3
pkgdesc="Bitcoin Unlimited versions of bitcoind, bitcoin-cli, and bitcoin-tx"
arch=('i686' 'x86_64' 'armv7h')
url="http://www.bitcoinunlimited.info"
@@ -44,7 +44,7 @@ pkgver() {
# The latest version was not tagged, so throw away the version we get
# from the top-most tag, but keep,the revision height and commit hash
- git describe --long | sed "s/^v[^-]\+-\([0-9]\+\)/$pkgver.r\1/;s/-/./g"
+ git describe --long | sed "s/^v[^-]\+-\([0-9]\+\)/$pkgver/;s/-/./g"
}
build() {