summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMahdi Sarikhani2024-06-01 13:19:19 +0330
committerMahdi Sarikhani2024-06-01 13:19:19 +0330
commit7ca1eb2c23ccc9d8ade5405143e657e01aa36bc1 (patch)
tree1528498c5c82ae2f09fc48755fb16aa3e841d058
parent6ece3449511b2d53ced0615c37cd9b94f395622d (diff)
downloadaur-7ca1eb2c23ccc9d8ade5405143e657e01aa36bc1.tar.gz
v2.8.3
-rw-r--r--.SRCINFO23
-rw-r--r--.nvchecker.toml4
-rw-r--r--PKGBUILD46
3 files changed, 47 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1a24587e7d6..089eab2d9ad9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,27 @@
pkgbase = bitcomet
pkgdesc = A BitTorrent/HTTP/FTP download client
- pkgver = 2.8.1
+ pkgver = 2.8.3
pkgrel = 1
url = https://www.bitcomet.com
arch = x86_64
- license = LicenseRef-bitcomet
+ license = LicenseRef-BitComet
+ depends = cairo
+ depends = expat
+ depends = gcc-libs
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libpng
+ depends = libx11
+ depends = libxml2
+ depends = pango
depends = webkit2gtk
- source = BitComet-2.8.1-x86_64.deb::https://download.bitcomet.com/linux/x86_64/BitComet-2.8.1-x86_64.deb
+ depends = zlib
+ source = bitcomet-2.8.3.deb::https://download.bitcomet.com/linux/x86_64/BitComet-2.8.3-x86_64.deb
source = LICENSE.html::https://www.bitcomet.com/en/license
- sha256sums = 747a34b098be10f2f4741bef83703738c1cce8c077ff8f671cce791a41bcfe5d
- sha256sums = SKIP
+ sha256sums = a17a49ba23454b9a4c958336068ebc72dadffe4f2ec4190ab3af124da81a22f0
+ sha256sums = 2ca856a798f48a00847f837133e368d4c3d1e776274a45fdcc4df22a8d25fca5
pkgname = bitcomet
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..174b41274b10
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,4 @@
+[bitcomet]
+source = "regex"
+url = "https://download.bitcomet.com/linux/x86_64/"
+regex = 'BitComet-([\d.]+)-x86_64\.deb'
diff --git a/PKGBUILD b/PKGBUILD
index 8bfcf07e7c5d..5c71aea74295 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,34 @@
-# Maintainer: irmluity <45vw4yz8g@mozmail.com>
-# Maintainer: d6k283tix <d6k283tix@mozmail.com>
+# Maintainer:
+# Contributor: irmluity <45vw4yz8g@mozmail.com>
+# Contributor: d6k283tix <d6k283tix@mozmail.com>
pkgname=bitcomet
-pkgver=2.8.1
+pkgver=2.8.3
pkgrel=1
pkgdesc="A BitTorrent/HTTP/FTP download client"
arch=(x86_64)
url='https://www.bitcomet.com'
-license=('LicenseRef-bitcomet')
-depends=('webkit2gtk')
-source=(
- "BitComet-${pkgver}-${CARCH}.deb::https://download.bitcomet.com/linux/x86_64/BitComet-2.8.1-x86_64.deb"
- "LICENSE.html::https://www.bitcomet.com/en/license"
-)
-sha256sums=(
- "747a34b098be10f2f4741bef83703738c1cce8c077ff8f671cce791a41bcfe5d"
- "SKIP"
-)
-
-prepare() {
- cd $srcdir
- tar -xf data.tar.xz
-}
+license=('LicenseRef-BitComet')
+depends=('cairo'
+ 'expat'
+ 'gcc-libs'
+ 'gdk-pixbuf2'
+ 'glib2'
+ 'glibc'
+ 'gtk3'
+ 'hicolor-icon-theme'
+ 'libpng'
+ 'libx11'
+ 'libxml2'
+ 'pango'
+ 'webkit2gtk'
+ 'zlib')
+source=("${pkgname}-${pkgver}.deb::https://download.bitcomet.com/linux/x86_64/BitComet-${pkgver}-x86_64.deb"
+ "LICENSE.html::https://www.bitcomet.com/en/license")
+sha256sums=('a17a49ba23454b9a4c958336068ebc72dadffe4f2ec4190ab3af124da81a22f0'
+ '2ca856a798f48a00847f837133e368d4c3d1e776274a45fdcc4df22a8d25fca5')
package() {
- install -d $pkgdir/usr
- cp -r $srcdir/usr/ $pkgdir/
- install -Dm644 "$srcdir/LICENSE.html" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.html"
+ bsdtar -xf data.tar.xz -C "${pkgdir}" --no-same-owner --no-same-permissions
+ install -Dm644 LICENSE.html -t "${pkgdir}/usr/share/licenses/${pkgname}"
}