summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArtem Savkov2017-01-04 15:01:39 +0100
committerArtem Savkov2017-01-04 15:01:39 +0100
commit59d6bfaaebe248a3d33fdf29a0fd4e3704aa13c9 (patch)
tree19a17159a0d9bdcf26aa377e5bc3e597e12ae13e
parent4647b4d0309f079031c30d6cd307ac0f0ed547a0 (diff)
downloadaur-59d6bfaaebe248a3d33fdf29a0fd4e3704aa13c9.tar.gz
Remove libwebsockets dependency.
bitlbee-discord is no longer dependant on libwebsockets and instead implements websockets itself. Removing the dependency and accompanying config magic.
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9db0c531d55a..fa3c3bd5b30e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
-# Maintainer: Ranndom <Ranndom@rnndm.xyz>
+# Maintainer: Artem Savkov <artem.savkov@gmail.com>
pkgname=bitlbee-discord-git
-pkgver=74.ae894c5
+pkgver=125.d4c29da
pkgrel=1
pkgdesc="Bitlbee plugin for Discord"
arch=('i686' 'x86_64')
url="https://github.com/sm00th/bitlbee-discord"
license=('GPL')
depends=('bitlbee')
-makedepends=('git' 'libwebsockets-git' 'autoconf' 'automake' 'libtool')
+makedepends=('git' 'autoconf' 'automake' 'libtool')
source=("git+https://github.com/sm00th/bitlbee-discord")
sha256sums=('SKIP')
@@ -20,8 +20,7 @@ pkgver() {
build() {
cd "bitlbee-discord"
./autogen.sh
- # libwebsockets-git is screwed up pkg-config wise
- PKG_CONFIG_PATH="/usr/lib/lib64/pkgconfig" LIBWEBSOCKETS_LIBS="-L/usr/lib/lib64" ./configure
+ ./configure
make
}