summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2016-01-25 06:17:07 +0000
committerColin Arnott2016-01-25 06:17:07 +0000
commit33534462762c80086c4214c1f5e226f19a1935ae (patch)
tree10056288772ec1c7c0ea072649efc123bb41816b
downloadaur-33534462762c80086c4214c1f5e226f19a1935ae.tar.gz
initial commit -- based off polyzen's bitlbee-facebook-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c246edf6a36
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 06:16:50 UTC 2016
+pkgbase = bitlbee-facebook
+ pkgdesc = Facebook protocol plugin for BitlBee
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/jgeboski/bitlbee-facebook
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ license = GPL
+ depends = bitlbee
+ depends = json-glib
+ source = https://github.com/jgeboski/bitlbee-facebook/archive/v1.0.0.tar.gz
+ sha512sums = 14cf6263c12636465a73f6fa442083af2c2f7bddc101fca84a8a6cec4b8c58cd0d5e0aea3901c25bd27ea7f2eb5b5fb65543a1501db948066cc780f52339a94e
+
+pkgname = bitlbee-facebook
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b304eb9d5932
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Colin Arnott <arnottcr@gmail.com>
+# Contributor: polyzen <polycitizen@gmail.com>
+# Contributor: mickael9 <mickael9 at gmail dot com>
+
+pkgname=bitlbee-facebook
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='Facebook protocol plugin for BitlBee'
+arch=('i686' 'x86_64' 'armv7h')
+url='https://github.com/jgeboski/bitlbee-facebook'
+license=('GPL')
+depends=('bitlbee' 'json-glib')
+source=('https://github.com/jgeboski/bitlbee-facebook/archive/v1.0.0.tar.gz')
+sha512sums=('14cf6263c12636465a73f6fa442083af2c2f7bddc101fca84a8a6cec4b8c58cd0d5e0aea3901c25bd27ea7f2eb5b5fb65543a1501db948066cc780f52339a94e')
+
+pkgver() {
+ cd ${pkgname%%-git}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${pkgname%%-git}
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd ${pkgname%%-git}
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: