summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Arnott2016-01-25 06:40:57 +0000
committerColin Arnott2016-01-25 06:40:57 +0000
commitd984df6345b81497dcdb592943b73869562c825d (patch)
tree1325cb6ca1146263f9c1843b13749db68e80c64a
parentb355a66d582904d757c28f01dd70e68162985a00 (diff)
downloadaur-d984df6345b81497dcdb592943b73869562c825d.tar.gz
added .gitignore, fixed sha512sum, removed *-git from file paths, removed pkgver() function; sorry, forgot to actually build it before pushing
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore15
-rw-r--r--PKGBUILD15
3 files changed, 23 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1bcb99861e41..c22eba83155a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Jan 25 06:30:56 UTC 2016
+# Mon Jan 25 06:40:34 UTC 2016
pkgbase = bitlbee-facebook
pkgdesc = Facebook protocol plugin for BitlBee
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/jgeboski/bitlbee-facebook
arch = any
license = GPL
depends = bitlbee
depends = json-glib
source = https://github.com/jgeboski/bitlbee-facebook/archive/v1.0.0.tar.gz
- sha512sums = 14cf6263c12636465a73f6fa442083af2c2f7bddc101fca84a8a6cec4b8c58cd0d5e0aea3901c25bd27ea7f2eb5b5fb65543a1501db948066cc780f52339a94e
+ sha512sums = a8e3520c799c8b7b526afe322f6713f9a9d83d8763c06349737b4c759a7c0b4ce64feb362eeba12a80eec0f9db669291b521257d52f316bcaa2b51d80db2789b
pkgname = bitlbee-facebook
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3c73f4f708d4
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,15 @@
+# ignore everything
+*
+!.gitignore
+
+# except PKGBUILD needed files
+!PKGBUILD
+!.SCRINFO
+!*.install
+!ChangeLog
+
+# common wing-man files
+!*.diff
+!*.patch
+
+# add files that don't have an online source
diff --git a/PKGBUILD b/PKGBUILD
index 7f16998486d0..c3d7adf9af72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,29 +4,24 @@
pkgname=bitlbee-facebook
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc='Facebook protocol plugin for BitlBee'
arch=('any')
url='https://github.com/jgeboski/bitlbee-facebook'
license=('GPL')
depends=('bitlbee' 'json-glib')
-source=('https://github.com/jgeboski/bitlbee-facebook/archive/v1.0.0.tar.gz')
-sha512sums=('14cf6263c12636465a73f6fa442083af2c2f7bddc101fca84a8a6cec4b8c58cd0d5e0aea3901c25bd27ea7f2eb5b5fb65543a1501db948066cc780f52339a94e')
-
-pkgver() {
- cd ${pkgname%%-git}
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+source=("https://github.com/jgeboski/$pkgname/archive/v$pkgver.tar.gz")
+sha512sums=('a8e3520c799c8b7b526afe322f6713f9a9d83d8763c06349737b4c759a7c0b4ce64feb362eeba12a80eec0f9db669291b521257d52f316bcaa2b51d80db2789b')
build() {
- cd ${pkgname%%-git}
+ cd $pkgname-$pkgver
./autogen.sh
./configure --prefix=/usr
make
}
package() {
- cd ${pkgname%%-git}
+ cd $pkgname-$pkgver
make DESTDIR="$pkgdir" install
}