summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordequis2015-08-25 01:16:14 -0300
committerdequis2015-08-25 01:16:14 -0300
commitd87343e886da36a7eb315b909bca5024827c309b (patch)
tree4804ba05881c89e6beb57da83c8437fcbd04b848
downloadaur-d87343e886da36a7eb315b909bca5024827c309b.tar.gz
Initial import from aur-mirror
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD57
-rw-r--r--bitlbee.install22
-rw-r--r--bitlbee.tmpfiles1
4 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eed60862db7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = bitlbee-libpurple
+ pkgdesc = Brings instant messaging (XMPP, MSN, Yahoo!, AIM, ICQ, Twitter) to IRC. libpurple enabled.
+ pkgver = 3.4
+ pkgrel = 1
+ url = http://www.bitlbee.org/
+ install = bitlbee.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = asciidoc
+ makedepends = libotr
+ depends = gnutls
+ depends = glib2
+ depends = libpurple
+ optdepends = skype4py: to use skyped
+ optdepends = libotr: for OTR encryption support
+ provides = bitlbee=3.4
+ conflicts = bitlbee
+ backup = etc/bitlbee/bitlbee.conf
+ backup = etc/bitlbee/motd.txt
+ source = http://get.bitlbee.org/src/bitlbee-3.4.tar.gz
+ source = bitlbee.tmpfiles
+ sha1sums = 3b22d9da741903a293fe3c25511448276c75b58a
+ sha1sums = 3695ed2fe22436c4d0fc3ead829f7d1f89bc491c
+
+pkgname = bitlbee-libpurple
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13e05c0bbdec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+
+# Contributor: Fernando Jiménez Solano (fjim) <fjim@sdfeu.org>
+# Contributor: FUBAR <mrfubar@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Maintainer: dx <dx@dxzone.com.ar>
+
+pkgname=bitlbee-libpurple
+_pkgname=bitlbee
+pkgver=3.4
+pkgrel=1
+pkgdesc='Brings instant messaging (XMPP, MSN, Yahoo!, AIM, ICQ, Twitter) to IRC. libpurple enabled.'
+url='http://www.bitlbee.org/'
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('gnutls' 'glib2' 'libpurple')
+makedepends=('asciidoc' 'libotr')
+optdepends=('skype4py: to use skyped'
+ 'libotr: for OTR encryption support')
+provides=('bitlbee=3.4')
+conflicts=('bitlbee')
+source=("http://get.bitlbee.org/src/${_pkgname}-${pkgver}.tar.gz"
+ 'bitlbee.tmpfiles')
+sha1sums=('3b22d9da741903a293fe3c25511448276c75b58a'
+ '3695ed2fe22436c4d0fc3ead829f7d1f89bc491c')
+backup=('etc/bitlbee/bitlbee.conf'
+ 'etc/bitlbee/motd.txt')
+install=${_pkgname}.install
+
+build() {
+ cd "${_pkgname}-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --etcdir=/etc/bitlbee \
+ --sbindir=/usr/bin \
+ --pidfile=/run/bitlbee/bitlbee.pid \
+ --ipcsocket=/run/bitlbee/bitlbee.sock \
+ --systemdsystemunitdir=/usr/lib/systemd/system \
+ --ssl=gnutls \
+ --strip=0 \
+ --otr=plugin \
+ --skype=plugin \
+ --purple=1
+
+ make
+}
+
+package() {
+ make -C "${_pkgname}-$pkgver" DESTDIR="$pkgdir" install{,-etc,-dev,-systemd}
+
+ install -o65 -g65 -dm770 "$pkgdir/var/lib/bitlbee"
+ install -Dm644 "$srcdir/bitlbee.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/bitlbee.conf"
+}
diff --git a/bitlbee.install b/bitlbee.install
new file mode 100644
index 000000000000..c8a8f93a1ba1
--- /dev/null
+++ b/bitlbee.install
@@ -0,0 +1,22 @@
+post_install() {
+ if ! getent group bitlbee &>/dev/null; then
+ groupadd -r -g 65 bitlbee >/dev/null
+ fi
+ if ! getent passwd bitlbee &>/dev/null; then
+ useradd -r -u 65 -g bitlbee -d /var/lib/bitlbee -s /bin/false -c bitlbee bitlbee >/dev/null
+ fi
+ systemd-tmpfiles --create bitlbee.conf
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd bitlbee &>/dev/null; then
+ userdel bitlbee >/dev/null
+ fi
+ if getent group bitlbee &>/dev/null; then
+ groupdel bitlbee >/dev/null
+ fi
+}
diff --git a/bitlbee.tmpfiles b/bitlbee.tmpfiles
new file mode 100644
index 000000000000..da72a0a7998b
--- /dev/null
+++ b/bitlbee.tmpfiles
@@ -0,0 +1 @@
+d /run/bitlbee 0755 bitlbee bitlbee - -