summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRay Song2016-04-06 00:58:45 +0800
committerRay Song2016-04-06 01:01:44 +0800
commit8a098ab6139415617275529393c8f6abb8aaa8e3 (patch)
tree40c9eeda00f5c92506bfcf7d92774f99e51a5dcb
downloadaur-8a098ab6139415617275529393c8f6abb8aaa8e3.tar.gz
initial
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD63
-rw-r--r--bitlbee.install22
-rw-r--r--bitlbee.tmpfiles1
-rw-r--r--unicode-channel.patch25
5 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..92874a207d34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = bitlbee-libpurple-unicode-channel
+ pkgdesc = Brings instant messaging (XMPP, MSN, Yahoo!, AIM, ICQ, Twitter) to IRC. libpurple enabled. (patched for unicode channel names)
+ pkgver = 3.4.2
+ pkgrel = 1
+ url = http://www.bitlbee.org/
+ install = bitlbee.install
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = libotr
+ makedepends = python
+ depends = gnutls
+ depends = glib2
+ depends = libpurple
+ optdepends = skype4py: to use skyped
+ optdepends = libotr: for OTR encryption support
+ provides = bitlbee=3.4.2
+ conflicts = bitlbee
+ conflicts = bitlbee-libpurple
+ backup = etc/bitlbee/bitlbee.conf
+ backup = etc/bitlbee/motd.txt
+ source = http://get.bitlbee.org/src/bitlbee-3.4.2.tar.gz
+ source = bitlbee.tmpfiles
+ source = unicode-channel.patch
+ sha1sums = c93eab4161754235a2bc04ba3dc0fc66ce2d34f2
+ sha1sums = 3695ed2fe22436c4d0fc3ead829f7d1f89bc491c
+ sha1sums = a3f9bc95b5f1518cf619e220e2f8be6110fb3e40
+
+pkgname = bitlbee-libpurple-unicode-channel
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4890dcf039e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,63 @@
+
+# Contributor: Fernando Jiménez Solano (fjim) <fjim@sdfeu.org>
+# Contributor: FUBAR <mrfubar@gmail.com>
+# Contributor: simo <simo@archlinux.org>
+# Contributor: Jeff 'codemac' Mickey <jeff@archlinux.org>
+# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
+# Contributor: Gaetan Bisson <bisson@archlinux.org>
+# Contributor: Dave Reisner <dreisner@archlinux.org>
+# Maintainer: Ray Song <i@maskray.me>
+
+pkgname=bitlbee-libpurple-unicode-channel
+_pkgname=bitlbee
+pkgver=3.4.2
+pkgrel=1
+pkgdesc='Brings instant messaging (XMPP, MSN, Yahoo!, AIM, ICQ, Twitter) to IRC. libpurple enabled. (patched for unicode channel names)'
+url='http://www.bitlbee.org/'
+license=('GPL')
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
+depends=('gnutls' 'glib2' 'libpurple')
+makedepends=('libotr' 'python')
+optdepends=('skype4py: to use skyped'
+ 'libotr: for OTR encryption support')
+provides=("bitlbee=${pkgver}")
+conflicts=('bitlbee' 'bitlbee-libpurple')
+source=("http://get.bitlbee.org/src/${_pkgname}-${pkgver}.tar.gz"
+ 'bitlbee.tmpfiles' 'unicode-channel.patch')
+sha1sums=('c93eab4161754235a2bc04ba3dc0fc66ce2d34f2'
+ '3695ed2fe22436c4d0fc3ead829f7d1f89bc491c'
+ 'a3f9bc95b5f1518cf619e220e2f8be6110fb3e40')
+backup=('etc/bitlbee/bitlbee.conf'
+ 'etc/bitlbee/motd.txt')
+install=${_pkgname}.install
+
+prepare() {
+ cd "${_pkgname}-$pkgver"
+ patch -p1 < $srcdir/unicode-channel.patch
+}
+
+build() {
+ cd "${_pkgname}-$pkgver"
+
+ ./configure \
+ --prefix=/usr \
+ --etcdir=/etc/bitlbee \
+ --sbindir=/usr/bin \
+ --pidfile=/run/bitlbee/bitlbee.pid \
+ --ipcsocket=/run/bitlbee/bitlbee.sock \
+ --systemdsystemunitdir=/usr/lib/systemd/system \
+ --ssl=gnutls \
+ --strip=0 \
+ --otr=plugin \
+ --skype=plugin \
+ --purple=1
+
+ make
+}
+
+package() {
+ make -C "${_pkgname}-$pkgver" DESTDIR="$pkgdir" install{,-etc,-dev,-systemd}
+
+ install -o65 -g65 -dm770 "$pkgdir/var/lib/bitlbee"
+ install -Dm644 "$srcdir/bitlbee.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/bitlbee.conf"
+}
diff --git a/bitlbee.install b/bitlbee.install
new file mode 100644
index 000000000000..c8a8f93a1ba1
--- /dev/null
+++ b/bitlbee.install
@@ -0,0 +1,22 @@
+post_install() {
+ if ! getent group bitlbee &>/dev/null; then
+ groupadd -r -g 65 bitlbee >/dev/null
+ fi
+ if ! getent passwd bitlbee &>/dev/null; then
+ useradd -r -u 65 -g bitlbee -d /var/lib/bitlbee -s /bin/false -c bitlbee bitlbee >/dev/null
+ fi
+ systemd-tmpfiles --create bitlbee.conf
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if getent passwd bitlbee &>/dev/null; then
+ userdel bitlbee >/dev/null
+ fi
+ if getent group bitlbee &>/dev/null; then
+ groupdel bitlbee >/dev/null
+ fi
+}
diff --git a/bitlbee.tmpfiles b/bitlbee.tmpfiles
new file mode 100644
index 000000000000..da72a0a7998b
--- /dev/null
+++ b/bitlbee.tmpfiles
@@ -0,0 +1 @@
+d /run/bitlbee 0755 bitlbee bitlbee - -
diff --git a/unicode-channel.patch b/unicode-channel.patch
new file mode 100644
index 000000000000..fadf82d6b7c9
--- /dev/null
+++ b/unicode-channel.patch
@@ -0,0 +1,25 @@
+--- a/irc_channel.c 2016-04-06 00:35:16.862674632 +0800
++++ b/irc_channel.c 2016-04-06 00:37:24.614969527 +0800
+@@ -530,7 +530,7 @@
+ int i, j;
+
+ for (i = j = 0; name[i]; i++) {
+- if (name[i] > ' ' && name[i] != ',') {
++ if ((unsigned char)name[i] > ' ' && name[i] != ',') {
+ name[j++] = name[i];
+ }
+ }
+@@ -612,12 +612,7 @@
+ char *translit_name;
+ gsize bytes_written;
+
+- translit_name = g_convert_with_fallback(hint, -1, "ASCII//TRANSLIT", "UTF-8", "", NULL, &bytes_written, NULL);
+-
+- if (!translit_name) {
+- /* Same thing as in nick_gen() in nick.c, try again without //TRANSLIT */
+- translit_name = g_convert_with_fallback(hint, -1, "ASCII", "UTF-8", "", NULL, &bytes_written, NULL);
+- }
++ translit_name = g_convert_with_fallback(hint, -1, "UTF-8", "UTF-8", "", NULL, &bytes_written, NULL);
+
+ if (!translit_name) {
+ return NULL;