summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranother2015-06-14 15:00:11 +0200
committeranother2015-06-14 15:00:11 +0200
commit179b81556c1dccb199fa7b94f4aa00cca262284c (patch)
tree9face4456f062a2d5b32ee1ec059c00e697f3bf4
downloadaur-179b81556c1dccb199fa7b94f4aa00cca262284c.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore33
-rw-r--r--PKGBUILD27
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..62316a6a8c94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bitmap
+ pkgdesc = X-bitmap (XBM) editor and converter utilities
+ pkgver = 1.0.8
+ pkgrel = 2
+ url = http://www.x.org/
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = xbitmaps
+ depends = libxaw>=1.0.7
+ source = http://ftp.x.org/pub/individual/app/bitmap-1.0.8.tar.gz
+ sha256sums = 1a2fbd10a2ca5cd93f7b77bbb0555b86d8b35e0fc18d036b1607c761755006fc
+ sha384sums = 6c563594855a8b2eb5209ea7ecde5de46ddfa8c56c79651a966329a288b7c8a7d3e932acdac4777cb32d40580cac4dde
+ sha512sums = 08d676495abe58a9be4cdebbb6fec88fe6dd5c196061713ac607f2222ae8f66e4dc7f6f7a1c35b8a30417ee1a8437b92b61229ef15e6ba1f4baead892d4b0927
+
+pkgname = bitmap
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0490f42ef0e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,33 @@
+# Copyright (c) 2014 GitHub, Inc.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# AUR metadata
+.AURINFO
+
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..789bee6ca413
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: another <code § deadcode § eu>
+# Contributor: (unknown)
+pkgname=bitmap
+pkgver=1.0.8
+pkgrel=2
+pkgdesc="X-bitmap (XBM) editor and converter utilities"
+arch=('i686' 'x86_64')
+url="http://www.x.org/"
+license=('MIT')
+depends=('libxaw>=1.0.7')
+makedepends=('xbitmaps')
+source=("http://ftp.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('1a2fbd10a2ca5cd93f7b77bbb0555b86d8b35e0fc18d036b1607c761755006fc')
+sha384sums=('6c563594855a8b2eb5209ea7ecde5de46ddfa8c56c79651a966329a288b7c8a7d3e932acdac4777cb32d40580cac4dde')
+sha512sums=('08d676495abe58a9be4cdebbb6fec88fe6dd5c196061713ac607f2222ae8f66e4dc7f6f7a1c35b8a30417ee1a8437b92b61229ef15e6ba1f4baead892d4b0927')
+
+build(){
+ cd "${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package(){
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR=${pkgdir} install
+ install -D -m 0644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}