summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJuraj Fiala2016-04-09 09:20:04 +0200
committerJuraj Fiala2016-04-09 09:20:04 +0200
commit9362fc814a51ab431b7ebe35bee66501963645d8 (patch)
treeaef2b74c890a25378e6c399aa259f6c4e35ba3b0
parent2375adb936a2d1fbb94c248c77b4c621cf6f5698 (diff)
downloadaur-9362fc814a51ab431b7ebe35bee66501963645d8.tar.gz
Workaround version acquire fail, seperate build and install process.
Also lay foundations for PGP verification and code checks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD42
2 files changed, 37 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57e97751839a..2e64a53cbccf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Apr 7 14:53:32 UTC 2016
+# Sat Apr 9 07:20:04 UTC 2016
pkgbase = bitmask_client
pkgdesc = Encrypted communication for mere mortals.
pkgver = 0.9.1
- pkgrel = 1
+ pkgrel = 2
url = https://bitmask.net/
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index c4004adfe0de..4d6b85d0f6aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Juraj Fiala <doctorjellyface at riseup dot net>
+_srcname=leap.bitmask
pkgname=bitmask_client
pkgver=0.9.1
-pkgrel=1
+pkgrel=2
pkgdesc='Encrypted communication for mere mortals.'
arch=('any')
url='https://bitmask.net/'
@@ -27,27 +28,54 @@ depends=(
'python2-leap_soledad_client'
'python2-leap_keymanager'
'python2-leap_mail'
- 'python2-leap_pycommon')
+ 'python2-leap_pycommon'
+)
makedepends=(
- 'python-pyside-tools')
+ 'python-pyside-tools'
+)
+# Disable tests for now as they fail
+#checkdepends=(
+ #'python2-nose'
+ #'python2-nose-exclude'
+ #'python2-mock'
+ #'python2-coverage'
+ #'python2-pep8'
+ #'python2-flake8'
+ #'python2-tox'
+#)
source=("https://github.com/leapcode/$pkgname/archive/$pkgver.tar.gz")
+validpgpkeys=('BE23FB4A0E9DB36ECB9AB8BE23638BF72C593BC1')
sha256sums=('7e907adeef60c61378c505d29f69d1cf777495215b356ce7ea3b0dc2b5c70dab')
prepare() {
- cd "$srcdir/$pkgname-$pkgver"
+ # Workaround version acquire fail
+ mv "$srcdir/$pkgname-$pkgver" "$srcdir/$_srcname-$pkgver"
+
+ cd "$srcdir/$_srcname-$pkgver"
# Install to /usr/bin instead of /usr/sbin
sed -i 's/sbin/bin/' setup.py
+
+ # Point the tests to python2 executables
+ #sed -i 's/\/bin\/nosetests/\/bin\/nosetests2/' run_tests.sh
+ #sed -i 's/flake8/flake8-python2/' run_tests.sh
}
build() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$srcdir/$_srcname-$pkgver"
# Qt
make
+ # Python
+ python2 setup.py build
}
+#check() {
+ #cd "$srcdir/$_srcname-$pkgver"
+ #sh run_tests.sh -N
+#}
+
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir" --optimize=1
+ cd "$srcdir/$_srcname-$pkgver"
+ python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
}
# vim:set ts=2 sw=2 et: