summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGötz Christ2020-07-31 17:59:05 -0500
committerGötz Christ2020-07-31 18:00:40 -0500
commitbc82302eba33296f2a7e3581e5d915c082db3686 (patch)
treedd1bb61371a5b727a9d898b10b6bc920836a8f0f
parent9c230034a66c794debc380c4f393654794ec8799 (diff)
downloadaur-bc82302eba33296f2a7e3581e5d915c082db3686.tar.gz
Update to 1.42.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore6
-rw-r--r--Makefile28
-rw-r--r--PKGBUILD18
4 files changed, 49 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b092bd9edc21..73fdb4121d1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = bitrise
pkgdesc = Run your bitrise.io automations offline
- pkgver = 1.3.4
+ pkgver = 1.42.0
pkgrel = 1
url = https://github.com/bitrise-io/bitrise
install = bitrise.install
arch = x86_64
license = MIT
- depends = envman
- depends = stepman
+ optdepends = envman
+ optdepends = stepman
provides = bitrise
- source = https://github.com/bitrise-io/bitrise/releases/download/1.3.4/bitrise-Linux-x86_64
+ source = https://github.com/bitrise-io/bitrise/releases/download/1.42.0/bitrise-Linux-x86_64
source = https://raw.githubusercontent.com/bitrise-io/bitrise/master/LICENSE
- md5sums = 1bc712c3ac35d12c6796c4e87ecff083
- md5sums = 10c39cc7466456c17298b32d04bfa8d9
+ sha256sums = d75cc141c159d9f52c109114483d9d0ce7679509904721489f4991921472bef2
+ sha256sums = a0379118157469b6a466bf070c8986ffbca0874d10bb4950e0c6018544914414
pkgname = bitrise
diff --git a/.gitignore b/.gitignore
index 72e8ffc0db8a..c87dbf791a2e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1,5 @@
-*
+*.pkg.tar*
+LICENSE
+bitrise-*
+pkg
+src
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8a02706c1167
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,28 @@
+all: clean build git install
+
+clean:
+ rm -r src pkg || true
+
+geninteg:
+ sed -i '/.*sums=(/,$$d' PKGBUILD
+ makepkg --geninteg >> PKGBUILD
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
+
+makepkg:
+ makepkg -s
+
+build: geninteg srcinfo makepkg
+
+git: git_add git_commit
+
+git_add:
+ git add PKGBUILD .SRCINFO
+
+git_commit: VERSION = $(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')
+git_commit:
+ git commit -m "Update to ${VERSION}"
+
+install:
+ makepkg --install
diff --git a/PKGBUILD b/PKGBUILD
index e3f87c5a1a01..304c5f09025d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
-# Maintainer: Jni <jni.viens at protonmail dot com>
+# Maintainers: goetzc
+# Contributors: Jni <jni.viens at protonmail dot com>
pkgname=bitrise
-pkgver=1.3.5
+pkgver=1.42.0
pkgrel=1
pkgdesc="Run your bitrise.io automations offline"
-arch=(x86_64)
+arch=('x86_64')
url="https://github.com/bitrise-io/bitrise"
license=('MIT')
-depends=(envman stepman)
-provides=(bitrise)
+provides=('bitrise')
+optdepends=('envman' 'stepman')
install=$pkgname.install
-source=(https://github.com/bitrise-io/bitrise/releases/download/1.3.4/bitrise-Linux-$CARCH
+source=("https://github.com/bitrise-io/bitrise/releases/download/$pkgver/bitrise-Linux-$CARCH"
https://raw.githubusercontent.com/bitrise-io/bitrise/master/LICENSE)
-md5sums=('1bc712c3ac35d12c6796c4e87ecff083'
- '10c39cc7466456c17298b32d04bfa8d9')
package() {
install -Dm644 "$srcdir/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm755 "$srcdir/$pkgname-Linux-$CARCH" "$pkgdir/usr/bin/bitrise"
}
+
+sha256sums=('d75cc141c159d9f52c109114483d9d0ce7679509904721489f4991921472bef2'
+ 'a0379118157469b6a466bf070c8986ffbca0874d10bb4950e0c6018544914414')