summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Desaulniers2023-07-16 08:47:26 -0400
committerPatrick Desaulniers2023-07-16 08:47:26 -0400
commitc51098e41a61f477d8880b262c4edd01175527fe (patch)
treecda531a918d67c97e403815b5db3f1cd10456192
parenta9fe1c790102eb65c76c825546ec155cac0df748 (diff)
downloadaur-c51098e41a61f477d8880b262c4edd01175527fe.tar.gz
Fix build; cleanup handling of submodules
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD27
2 files changed, 24 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76ec24318fb0..befd01da0afc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = bitrot-git
pkgdesc = Bitrot audio plugins (LV2, VST2 and LADSPA)
- pkgver = r15.70534bc
+ pkgver = r16.06a72cd
pkgrel = 1
url = https://github.com/grejppi/bitrot.git
arch = i686
arch = x86_64
license = Apache
makedepends = git
- makedepends = python
+ makedepends = waf
depends = gcc-libs
+ depends = glibc
provides = bitrot
conflicts = bitrot
- source = bitrot::git+https://github.com/grejppi/bitrot.git
+ source = git+https://github.com/grejppi/bitrot.git
+ source = git+https://github.com/grejppi/DPF.git#branch=custom
+ md5sums = SKIP
md5sums = SKIP
pkgname = bitrot-git
diff --git a/PKGBUILD b/PKGBUILD
index e77e650a8729..256086627365 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,46 @@
# Maintainer: Patrick Desaulniers <desaulniers dot patrick at carrefour dot cegepvicto dot ca>
pkgname=bitrot-git
-pkgver=r15.70534bc
+pkgver=r16.06a72cd
pkgrel=1
pkgdesc="Bitrot audio plugins (LV2, VST2 and LADSPA)"
arch=('i686' 'x86_64')
url="https://github.com/grejppi/bitrot.git"
license=('Apache')
-depends=('gcc-libs')
-makedepends=('git' 'python')
+depends=('gcc-libs' 'glibc')
+makedepends=('git' 'waf')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
-source=("${pkgname%-*}::git+https://github.com/grejppi/bitrot.git")
-md5sums=('SKIP')
+source=("git+https://github.com/grejppi/bitrot.git"
+ "git+https://github.com/grejppi/DPF.git#branch=custom")
+md5sums=('SKIP'
+ 'SKIP')
pkgver() {
cd "${pkgname%-*}"
+
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
cd "${pkgname%-*}"
- git submodule update --init --recursive
- ./waf configure --prefix="/usr"
+
+ git submodule init
+ git config submodule.libs/DPF.url "$srcdir/DPF"
+ git -c protocol.file.allow=always submodule update
+
+ waf configure --prefix="/usr"
}
build() {
cd "${pkgname%-*}"
- ./waf
+
+ waf
}
package() {
cd "${pkgname%-*}"
+
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- ./waf install --destdir="$pkgdir"
+ waf install --destdir="$pkgdir"
}