summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEnte2016-02-02 15:06:10 +0100
committerEnte2016-02-02 15:06:10 +0100
commitc12900f44368fdfc8a488af685f4925b757c0555 (patch)
treee23f6d8a353fb73fc14b1898b355134ff21e4a77
downloadaur-c12900f44368fdfc8a488af685f4925b757c0555.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--Makefile7
-rw-r--r--PKGBUILD16
-rw-r--r--PKGBUILD.template15
-rw-r--r--vars.sh3
5 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..636de46c5cbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 14:05:27 UTC 2016
+pkgbase = bitscope
+ pkgdesc = Full bitscope software package for oscilloscopes
+ pkgver = 2.0
+ pkgrel = 1
+ url = http://www.bitscope.com
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = bitscope-dso
+ depends = bitscope-logic
+ depends = bitscope-meter
+ depends = bitscope-chart
+ depends = bitscope-server
+
+pkgname = bitscope
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..b203c4809787
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,7 @@
+# Bitscope Makefile
+# module level
+# Mischa Lehmann <ducksource@duckpond.ch>
+# vim: set noexpandtab list:
+include ../include.mk
+TEMPLATE := PKGBUILD.template
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46da223761f3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer : EnteEnteEnte <ducksource@duckpond.ch>
+# vim: set ts=2 sw=2 et:
+
+pkgname="bitscope"
+pkgver="2.0"
+pkgrel=1
+pkgdesc="Full bitscope software package for oscilloscopes"
+arch=('i686' 'x86_64')
+url="http://www.bitscope.com"
+license=('custom')
+depends=(bitscope-dso bitscope-logic bitscope-meter bitscope-chart bitscope-server)
+
+package() {
+ echo "do nothing" > /dev/null
+}
+
diff --git a/PKGBUILD.template b/PKGBUILD.template
new file mode 100644
index 000000000000..9610ec499fe3
--- /dev/null
+++ b/PKGBUILD.template
@@ -0,0 +1,15 @@
+# Maintainer : EnteEnteEnte <ducksource@duckpond.ch>
+# vim: set ts=2 sw=2 et:
+
+pkgname="__NAME__"
+pkgver="__VERSION__"
+pkgrel=__REL__
+pkgdesc="Full bitscope software package for oscilloscopes"
+arch=('i686' 'x86_64')
+url="http://www.bitscope.com"
+license=('custom')
+depends=(bitscope-dso bitscope-logic bitscope-meter bitscope-chart bitscope-server)
+
+package() {
+ echo "do nothing" > /dev/null
+}
diff --git a/vars.sh b/vars.sh
new file mode 100644
index 000000000000..37c121a88bce
--- /dev/null
+++ b/vars.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+VERSION="2.0"
+REL=1