summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-12 14:03:01 +0800
committerChocobo12017-08-12 14:10:22 +0800
commit852273794e59a53164c2ca475b6961bb37450d14 (patch)
treef177e25ff718c48ad905f1450341272ca676c8e4
downloadaur-852273794e59a53164c2ca475b6961bb37450d14.tar.gz
newpkg: bitstream-git 1.2.r14.ge940899-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD29
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a81460fcad2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = bitstream-git
+ pkgdesc = A set of C headers allowing a simpler access to binary structures such as specified by MPEG, DVB, IETF, SMPTE, IEEE, SCTE, etc
+ pkgver = 1.2.r14.ge940899
+ pkgrel = 1
+ url = https://www.videolan.org/developers/bitstream.html
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = glibc
+ provides = bitstream
+ conflicts = bitstream
+ source = git+https://code.videolan.org/videolan/bitstream.git
+ sha256sums = SKIP
+
+pkgname = bitstream-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3248c5c59dbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=bitstream-git
+pkgver=1.2.r14.ge940899
+pkgrel=1
+pkgdesc="A set of C headers allowing a simpler access to binary structures such as specified by MPEG, DVB, IETF, SMPTE, IEEE, SCTE, etc"
+arch=('any')
+url="https://www.videolan.org/developers/bitstream.html"
+license=('MIT')
+depends=('glibc')
+makedepends=('git')
+provides=('bitstream')
+conflicts=('bitstream')
+source=("git+https://code.videolan.org/videolan/bitstream.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "bitstream"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "bitstream"
+
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/bitstream/COPYING"
+}