summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorasm0dey2018-11-11 12:34:14 +0300
committerasm0dey2018-11-11 12:34:14 +0300
commitf4da56b823a17e7841104051a2cde6adacdbb893 (patch)
treeb9c1483d8d2c64835078fac2b1cebb245d461cd5
downloadaur-f4da56b823a17e7841104051a2cde6adacdbb893.tar.gz
Initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD25
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48e374a4883f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = bittorrent-tracker-editor-bin
+ pkgdesc = Software for add or remove tracker from torrent files
+ pkgver = 1.33.0.beta.5
+ pkgrel = 1
+ url = https://github.com/GerryFerdinandus/bittorrent-tracker-editor/
+ arch = x86_64
+ license = MIT
+ depends = gtk2
+ source = https://github.com/GerryFerdinandus/bittorrent-tracker-editor/releases/download/1.33.0.beta.5/trackereditor_linux_amd64.zip
+ source = LICENSE::https://raw.githubusercontent.com/GerryFerdinandus/bittorrent-tracker-editor/master/MIT_License.txt
+ md5sums = 9e165a8d8de75a99bd2c4109eefb707f
+ md5sums = 67fc79e3a495880245a6abd65c47320b
+
+pkgname = bittorrent-tracker-editor-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ef0e1d2276a7
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+LICENSE
+*tar.xz
+*.zip
+src/
+pkg/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ffd0ffe8886
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: asm0dey <pavel.finkelshtein+AUR@gmail.com>
+pkgname=bittorrent-tracker-editor-bin
+pkgver=1.33.0.beta.5
+pkgrel=1
+pkgdesc="Software for add or remove tracker from torrent files"
+arch=('x86_64')
+url="https://github.com/GerryFerdinandus/bittorrent-tracker-editor/"
+license=('MIT')
+depends=("gtk2")
+source=("https://github.com/GerryFerdinandus/bittorrent-tracker-editor/releases/download/$pkgver/trackereditor_linux_amd64.zip"
+ "LICENSE::https://raw.githubusercontent.com/GerryFerdinandus/bittorrent-tracker-editor/master/MIT_License.txt"
+)
+md5sums=('9e165a8d8de75a99bd2c4109eefb707f'
+ '67fc79e3a495880245a6abd65c47320b'
+)
+package() {
+ cd "$srcdir"
+ install -D -m 755 trackereditor "$pkgdir/opt/trackereditor/trackereditor"
+ install -D -m 644 LICENSE "$pkgdir/usr/share/licenses/bittorrent-tracker-editor-bin/LICENSE"
+ mkdir - p "$pkgdir/usr/bin"
+ ln -sf "/opt/trackereditor/trackereditor" "$pkgdir/usr/bin/trackereditor"
+}
+
+# vim: ts=4 sw=4 et:
+