summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman Beslik2015-07-03 17:00:18 +0300
committerRoman Beslik2015-07-03 17:00:18 +0300
commit99c1fc19ca1b26abfea646c6755052d33a9d2da8 (patch)
tree4b1590a09b89a302f6d846926a428271ceb893d7
downloadaur-99c1fc19ca1b26abfea646c6755052d33a9d2da8.tar.gz
init
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD28
-rw-r--r--_.install11
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a10764dfeb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = bittorrent2player
+ pkgdesc = Transfers data from the BitTorrent network to another protocol (currently HTTP) which is more suitable for media players.
+ pkgver = 1.5
+ pkgrel = 1
+ url = http://www.beroal.in.ua/prg/bittorrent2player/
+ install = _.install
+ arch = any
+ license = LGPL
+ depends = python2
+ depends = python2-distribute
+ depends = libtorrent-rasterbar>=0.15.7
+ depends = desktop-file-utils
+ backup = etc/bittorrent2player/logging.conf
+ source = http://www.beroal.in.ua/prg/bittorrent2player/src/bittorrent2player-1.5.tar.gz
+ sha512sums = c6a79ef8229e23beb20d74ca29d2ef12fa01a15fb6fba20a6b41551f56360df6eb3359c9ae368580f39da82f1418a818acc5da03b6ee3c0d224050df2c9522b1
+
+pkgname = bittorrent2player
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f1f2352e7353
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Roman Beslik <me@beroal.in.ua>
+
+pkgname=bittorrent2player
+pkgver=1.5
+pkgrel=1
+url=("http://www.beroal.in.ua/prg/bittorrent2player/")
+pkgdesc="Transfers data from the BitTorrent network to another protocol (currently HTTP) which is more suitable for media players."
+arch=("any")
+license=("LGPL")
+depends=("python2" "python2-distribute" "libtorrent-rasterbar>=0.15.7" "desktop-file-utils")
+makedepends=()
+backup=("etc/bittorrent2player/logging.conf")
+install=_.install
+source=("http://www.beroal.in.ua/prg/$pkgname/src/$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"/ --optimize=1
+}
+
+sha512sums=( \
+ "c6a79ef8229e23beb20d74ca29d2ef12fa01a15fb6fba20a6b41551f56360df6eb3359c9ae368580f39da82f1418a818acc5da03b6ee3c0d224050df2c9522b1"
+ )
diff --git a/_.install b/_.install
new file mode 100644
index 000000000000..80312d4a6041
--- /dev/null
+++ b/_.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}