summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmls2015-07-09 17:32:26 +0200
committersmls2015-07-09 17:32:26 +0200
commitbcf03086fe912f703f4c4594239c50a165ee7b45 (patch)
tree15e7648e2ca15acb671b5bfefdff748bdc701de6
downloadaur-bcf03086fe912f703f4c4594239c50a165ee7b45.tar.gz
Initial upload under new name bittriprunner-hib
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD51
-rw-r--r--bittriprunner.desktop10
3 files changed, 82 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e8c3de826a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = bittriprunner-hib
+ pkgdesc = BIT.TRIP RUNNER, a rhythm-based action platformer
+ pkgver = 1.0.4+h20120927
+ pkgrel = 1
+ url = http://bittripgame.com/bittrip-runner.html
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = sdl
+ depends = libgl
+ depends = openal
+ depends = libvorbis
+ source = bittriprunner.desktop
+ md5sums = 651aad252c4b42fea26f388642dce6ca
+ source_i686 = hib://bit.trip.runner-linux-1.0-4_i386-1348702546.tar.gz
+ md5sums_i686 = 900019b5994e1b8b2e08fcf07d9c1c08
+ source_x86_64 = hib://bit.trip.runner_1.0-4_amd64-1348702546.tar.gz
+ md5sums_x86_64 = 026712ac29972467f0b167a3eeaa3933
+
+pkgname = bittriprunner-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52e34aa0ba95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Sam S. <smls75@gmail.com>
+# Original submitter: Yann Kaiser <kaiser.yann@gmail.com>
+
+pkgname=bittriprunner-hib
+pkgver=1.0.4+h20120927
+_hibver=1.0-4
+_buildver=1348702546
+pkgrel=1
+pkgdesc="BIT.TRIP RUNNER, a rhythm-based action platformer"
+url="http://bittripgame.com/bittrip-runner.html"
+arch=('i686' 'x86_64')
+license=('custom')
+depends=('sdl' 'libgl' 'openal' 'libvorbis')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Manually download it to \"$(pwd)\", or set up a hib:// DLAGENT in /etc/makepkg.conf."; exit 1')
+
+source=('bittriprunner.desktop')
+md5sums=('651aad252c4b42fea26f388642dce6ca')
+
+source_i686+=("hib://bit.trip.runner-linux-${_hibver}_i386-${_buildver}.tar.gz")
+md5sums_i686+=('900019b5994e1b8b2e08fcf07d9c1c08')
+
+source_x86_64+=("hib://bit.trip.runner_${_hibver}_amd64-${_buildver}.tar.gz")
+md5sums_x86_64+=('026712ac29972467f0b167a3eeaa3933')
+
+_archive_subdir="bit.trip.runner-1.0";
+_installname="bittriprunner"
+
+package() {
+ cd $srcdir
+
+ # Install game files
+ mkdir -p "${pkgdir}/opt/${_installname}"
+ cp -r "${_archive_subdir}/bit.trip.runner"/* "${pkgdir}/opt/${_installname}/"
+
+ # Install launcher script
+ echo -e "#!/bin/sh\ncd /opt/${_installname} && ./bit.trip.runner" \
+ > "launcher.sh"
+ install -Dm755 "launcher.sh" "${pkgdir}/usr/bin/${_installname}"
+
+ # Install icon
+ install -Dm644 "${_archive_subdir}/bit.trip.runner/RUNNER.png" \
+ "${pkgdir}/usr/share/pixmaps/${_installname}.png"
+
+ # Install desktop entry
+ install -Dm644 "${_installname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_installname}.desktop"
+
+ # Install documentation
+ mkdir -p "${pkgdir}/usr/share/doc/${_installname}"
+ cp -r "${_archive_subdir}/README"* "${pkgdir}/usr/share/doc/${_installname}"
+}
diff --git a/bittriprunner.desktop b/bittriprunner.desktop
new file mode 100644
index 000000000000..94126dd2d6f5
--- /dev/null
+++ b/bittriprunner.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Categories=Game;
+Name=BIT.TRIP RUNNER
+Comment=Gaijin Games
+GenericName=2D Action Platformer
+Icon=bittriprunner
+Exec=/usr/bin/bittriprunner
+Terminal=false