summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2019-06-26 00:39:05 +0200
committerDaniel Peukert2019-06-26 00:39:05 +0200
commit0921f000812404e7337289246f7c998d56e7b89e (patch)
tree7daa4aa9f794bf815b296bb81d8f3b5f7a795d6a
downloadaur-0921f000812404e7337289246f7c998d56e7b89e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.editorconfig9
-rw-r--r--.gitignore16
-rw-r--r--PKGBUILD29
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af0ceddc7c81
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bitw-git
+ pkgdesc = Minimalist BitWarden client with Secret Service API implementation
+ pkgver = r29.c019359
+ pkgrel = 1
+ url = https://github.com/mvdan/bitw
+ arch = x86_64
+ arch = i686
+ arch = arm
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = BSD
+ makedepends = go
+ source = bitw::git+https://github.com/mvdan/bitw
+ sha256sums = SKIP
+
+pkgname = bitw-git
diff --git a/.editorconfig b/.editorconfig
new file mode 100644
index 000000000000..657972b0a3a1
--- /dev/null
+++ b/.editorconfig
@@ -0,0 +1,9 @@
+root = true
+
+[*]
+charset = utf-8
+end_of_line = lf
+insert_final_newline = true
+indent_style = tab
+tab_width = 4
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93902b97c110
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,16 @@
+# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
+*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb321e7a3379
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+_pkgname='bitw'
+pkgname="$_pkgname-git"
+pkgver='r29.c019359'
+pkgrel='1'
+pkgdesc='Minimalist BitWarden client with Secret Service API implementation'
+arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
+url="https://github.com/mvdan/$_pkgname"
+license=('BSD')
+makedepends=('go')
+source=("$_pkgname::git+$url")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ go build -gcflags "all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-extldflags $LDFLAGS" -o "$_pkgname" .
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 'LICENSE.google' "$pkgdir/usr/share/licenses/$pkgname/LICENSE.google"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}