summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2019-06-26 21:43:15 +0200
committerDaniel Peukert2019-06-26 21:43:15 +0200
commit0b3e89d261754ec33759150eea2d81808317c94d (patch)
tree4f0e7a824b4ef47e149b0ffdbd6a5ea05c28a90b
parent0921f000812404e7337289246f7c998d56e7b89e (diff)
downloadaur-0b3e89d261754ec33759150eea2d81808317c94d.tar.gz
Added GOPATH
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index af0ceddc7c81..6ff78b41e4b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitw-git
pkgdesc = Minimalist BitWarden client with Secret Service API implementation
- pkgver = r29.c019359
+ pkgver = r30.b2f1cee
pkgrel = 1
url = https://github.com/mvdan/bitw
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index cb321e7a3379..da2e82f9a920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
_pkgname='bitw'
pkgname="$_pkgname-git"
-pkgver='r29.c019359'
+pkgver='r30.b2f1cee'
pkgrel='1'
pkgdesc='Minimalist BitWarden client with Secret Service API implementation'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -18,6 +18,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
+ export GOPATH="$srcdir/gopath"
go build -gcflags "all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-extldflags $LDFLAGS" -o "$_pkgname" .
}