summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2024-01-28 00:01:13 +0100
committerDaniel Peukert2024-01-28 00:01:13 +0100
commit1e0fae80c04737e40dc37db26cf31b9d47900ab2 (patch)
tree7aa6f72665a1f903020b84e403661f8050af5e04
parent3b5893b2783dfbfcf8a6f3836e7994752b76b9f3 (diff)
downloadaur-1e0fae80c04737e40dc37db26cf31b9d47900ab2.tar.gz
Sync pkgbuilds repo with AUR
-rw-r--r--.SRCINFO2
-rw-r--r--.gitignore28
-rw-r--r--PKGBUILD4
3 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b2720f095e8..8dbebd892cc3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,7 +8,7 @@ pkgbase = bitw-git
arch = pentium4
arch = armv7h
arch = aarch64
- license = BSD
+ license = BSD-3-Clause
makedepends = git
makedepends = go>=1.19
optdepends = wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)
diff --git a/.gitignore b/.gitignore
index 82b3c183d5d4..076d904dd4ac 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,14 +1,14 @@
-# from https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-*.tar
-*.tar.*
-*.rpm
-*.jar
-*.exe
-*.msi
-*.zip
-*.tgz
-*.log
-*.log.*
-*.sig
-
-*/
+# Only exclude files from the root of the package repo, as some AUR helpers download sources into the directory of the repo,
+# which causes the gitignore file to apply to them too, which breaks some builds
+# Based on https://github.com/github/gitignore/blob/main/ArchLinuxPackages.gitignore
+/*.tar
+/*.tar.*
+/*.rpm
+/*.jar
+/*.exe
+/*.msi
+/*.zip
+/*.tgz
+/*.log
+/*.log.*
+/*.sig
diff --git a/PKGBUILD b/PKGBUILD
index c5e0d3e79b64..6624b43f1161 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ pkgrel='1'
pkgdesc='Minimalist BitWarden client with Secret Service API implementation - git version'
arch=('x86_64' 'i686' 'pentium4' 'armv7h' 'aarch64')
url="https://github.com/mvdan/$_pkgname"
-license=('BSD')
+license=('BSD-3-Clause')
makedepends=('git' 'go>=1.19')
optdepends=(
'wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)'
@@ -51,5 +51,5 @@ check() {
package() {
cd "$srcdir/"
install -Dm755 "$_bindir/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm644 "$_sourcedirectory/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$_sourcedirectory/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/BSD-3-Clause"
}