summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-11-27 12:06:25 +0100
committerDaniel Peukert2020-11-27 12:06:25 +0100
commit4963146843046e129ce0c548d176c347ec5ea34e (patch)
treed8000fae500c72d7958a1d7186fdacb2523a301a
parent2d4af31d03dc45b9bc64b84077b8a74bae98c982 (diff)
downloadaur-4963146843046e129ce0c548d176c347ec5ea34e.tar.gz
Updated minimal go version for bitw-git
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dce80ef651da..41dd44a62f2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitw-git
pkgdesc = Minimalist BitWarden client with Secret Service API implementation - git version
- pkgver = r53.aa676ad
- pkgrel = 2
+ pkgver = r68.g12abc07
+ pkgrel = 1
url = https://github.com/mvdan/bitw
arch = x86_64
arch = i686
@@ -11,7 +11,7 @@ pkgbase = bitw-git
arch = aarch64
license = BSD
makedepends = git
- makedepends = go>=1.13
+ makedepends = go>=1.14
optdepends = wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)
optdepends = xclip: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)
optdepends = xsel: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)
diff --git a/PKGBUILD b/PKGBUILD
index 303ceb54ec12..514b91b02413 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
-# Maintainer: Daniel Peukert <dan.peukert@gmail.com>
+# Maintainer: Daniel Peukert <daniel@peukert.cc>
_pkgname='bitw'
pkgname="$_pkgname-git"
-pkgver='r53.aa676ad'
-pkgrel='2'
+pkgver='r68.g12abc07'
+pkgrel='1'
pkgdesc='Minimalist BitWarden client with Secret Service API implementation - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mvdan/$_pkgname"
license=('BSD')
-makedepends=('git' 'go>=1.13')
+makedepends=('git' 'go>=1.14')
optdepends=(
'wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)'
'xclip: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)'
@@ -29,7 +29,7 @@ prepare() {
pkgver() {
cd "$srcdir/$_sourcedirectory/"
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {