summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2019-06-27 02:33:11 +0200
committerDaniel Peukert2019-06-27 02:33:11 +0200
commit575bba8d6396220a8f7c579ef0badb948480ad84 (patch)
treed7f812702a16bde6af34209a17f818f58a7ec6cf
parent0b3e89d261754ec33759150eea2d81808317c94d (diff)
downloadaur-575bba8d6396220a8f7c579ef0badb948480ad84.tar.gz
Clean up go cache afterwards
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ff78b41e4b6..8e0e0520e3e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitw-git
pkgdesc = Minimalist BitWarden client with Secret Service API implementation
pkgver = r30.b2f1cee
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mvdan/bitw
arch = x86_64
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index da2e82f9a920..eb305511838c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname='bitw'
pkgname="$_pkgname-git"
pkgver='r30.b2f1cee'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Minimalist BitWarden client with Secret Service API implementation'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mvdan/$_pkgname"
@@ -17,8 +17,8 @@ pkgver() {
}
build() {
- cd "$srcdir/$_pkgname"
export GOPATH="$srcdir/gopath"
+ cd "$srcdir/$_pkgname"
go build -gcflags "all=-trimpath=$PWD" -asmflags "all=-trimpath=$PWD" -ldflags "-extldflags $LDFLAGS" -o "$_pkgname" .
}
@@ -27,4 +27,5 @@ package() {
install -Dm644 'LICENSE' "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
install -Dm644 'LICENSE.google' "$pkgdir/usr/share/licenses/$pkgname/LICENSE.google"
install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+ go clean -modcache
}