summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Peukert2020-06-06 22:13:28 +0200
committerDaniel Peukert2020-06-06 22:13:28 +0200
commit8d4034a74dd36a95d2690752f6b3800463770c22 (patch)
tree9a60ba1849ae16bdc6f40a58ea5b871791d1e276
parent1627bec28a84aee846320278b64473ac52c1c802 (diff)
downloadaur-8d4034a74dd36a95d2690752f6b3800463770c22.tar.gz
Add optdepends and set GOPATH in bitw-git because golang thinks it's really funny to put shit in $HOME
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a382312db63..dce80ef651da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitw-git
pkgdesc = Minimalist BitWarden client with Secret Service API implementation - git version
pkgver = r53.aa676ad
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mvdan/bitw
arch = x86_64
arch = i686
@@ -12,6 +12,9 @@ pkgbase = bitw-git
license = BSD
makedepends = git
makedepends = go>=1.13
+ optdepends = wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)
+ optdepends = xclip: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)
+ optdepends = xsel: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)
provides = bitw
provides = org.freedesktop.secrets
conflicts = bitw
diff --git a/PKGBUILD b/PKGBUILD
index a4dc233a78f6..6490768a9787 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,17 @@
_pkgname='bitw'
pkgname="$_pkgname-git"
pkgver='r53.aa676ad'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Minimalist BitWarden client with Secret Service API implementation - git version'
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/mvdan/$_pkgname"
license=('BSD')
makedepends=('git' 'go>=1.13')
+optdepends=(
+ 'wl-clipboard: clipboard utility for Wayland (one of the optdepends is required for the tests to pass - build time dep)'
+ 'xclip: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)'
+ 'xsel: clipboard utility for X11 (one of the optdepends is required for the tests to pass - build time dep)'
+)
provides=("$_pkgname" 'org.freedesktop.secrets')
conflicts=("$_pkgname")
source=("$pkgname::git+$url")
@@ -15,6 +20,7 @@ sha256sums=('SKIP')
_sourcedirectory="$pkgname"
_bindir="$pkgname-bin"
+_gopath="$pkgname-gopath"
prepare() {
mkdir -p "$srcdir/$_bindir/"
@@ -27,6 +33,7 @@ pkgver() {
build() {
cd "$srcdir/$_sourcedirectory/"
+ export GOPATH="$srcdir/$_gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"
@@ -37,6 +44,7 @@ build() {
check() {
cd "$srcdir/$_sourcedirectory/"
+ export GOPATH="$srcdir/$_gopath"
export CGO_CPPFLAGS="${CPPFLAGS}"
export CGO_CFLAGS="${CFLAGS}"
export CGO_CXXFLAGS="${CXXFLAGS}"