summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Brown II2018-05-21 15:36:30 -0500
committerStephen Brown II2018-05-21 15:39:41 -0500
commitdc818f503f4fd59193e3c2427809bca6fb25aa02 (patch)
treed2ed85da3e44902901d5d90f3ca268fc8796a2bd
downloadaur-dc818f503f4fd59193e3c2427809bca6fb25aa02.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD17
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab3539e9faa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Mon May 21 20:35:18 UTC 2018
+pkgbase = bitwarden-cli
+ pkgdesc = The command line vault (Windows, macOS, & Linux). bitwarden.com
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://bitwarden.com
+ arch = x86_64
+ license = GPL
+ options = !strip
+ source_x86_64 = https://github.com/bitwarden/cli/releases/download/v0.3.0/bw-linux.zip
+ sha256sums_x86_64 = 7E599AAC3127E5DB0DEF4E33906E649E16DFCFF10FEDD42D664ED9898B14C452
+
+pkgname = bitwarden-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..11c19a8856c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Contributor: Stephen Brown II <Stephen [dot] Brown2 [at] gmail.com>
+pkgname=bitwarden-cli
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="The command line vault (Windows, macOS, & Linux). bitwarden.com"
+arch=('x86_64')
+url="https://bitwarden.com"
+license=('GPL')
+groups=('')
+depends=('')
+options=('!strip') # '!emptydirs')
+source_x86_64=("https://github.com/bitwarden/cli/releases/download/v${pkgver}/bw-linux.zip")
+sha256sums_x86_64=('7E599AAC3127E5DB0DEF4E33906E649E16DFCFF10FEDD42D664ED9898B14C452')
+
+package(){
+ install -D "${srcdir}/bw" "${pkgdir}/usr/local/bin/bw"
+}