summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Hansen2022-03-11 08:41:11 -0800
committerScott Hansen2022-03-11 08:41:11 -0800
commitfa717cd976745f2f12b83c810ee1651aa99270ef (patch)
tree7bddd0ff88b39f93f874d84935d3f4ebb13662d7
downloadaur-fa717cd976745f2f12b83c810ee1651aa99270ef.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD40
-rw-r--r--bitwarden-menu.install8
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab945e42b096
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = bitwarden-menu-git
+ pkgdesc = Dmenu/Rofi frontend for Bitwarden/Vaultwarden.
+ pkgver = r50.7cb8386
+ pkgrel = 1
+ url = https://github.com/firecat53/bitwarden-menu
+ install = bitwarden-menu.install
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-setuptools
+ makedepends = python-wheel
+ depends = python
+ depends = python-pynput
+ depends = bitwarden-cli
+ optdepends = dmenu: either dmenu or rofi is required
+ optdepends = rofi: either dmenu or rofi is required
+ optdepends = xdotool: required for typing non-U.S. Unicode characters
+ optdepends = ydotool: required for Wayland support
+ provides = bitwarden-menu
+ conflicts = bitwarden-menu
+ source = git+https://github.com/firecat53/bitwarden-menu.git
+ md5sums = SKIP
+
+pkgname = bitwarden-menu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49c2bbfa8fb7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Scott Hansen (firecat53) firecat4153 at gmail dot com
+
+_pkgname=bitwarden-menu
+_gitname=bitwarden-menu
+pkgname=$_pkgname-git
+pkgver=r50.7cb8386
+pkgrel=1
+pkgdesc="Dmenu/Rofi frontend for Bitwarden/Vaultwarden."
+
+arch=('any')
+url="https://github.com/firecat53/bitwarden-menu"
+license=('MIT')
+depends=('python' 'python-pynput' 'bitwarden-cli')
+makedepends=('git' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+optdepends=('dmenu: either dmenu or rofi is required'
+ 'rofi: either dmenu or rofi is required'
+ 'xdotool: required for typing non-U.S. Unicode characters'
+ 'ydotool: required for Wayland support')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("git+https://github.com/firecat53/$_gitname.git")
+md5sums=('SKIP')
+install="$_pkgname.install"
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_gitname"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_gitname"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_gitname/bwm.1" "$pkgdir/usr/share/man/man1/bwm.1"
+}
diff --git a/bitwarden-menu.install b/bitwarden-menu.install
new file mode 100644
index 000000000000..eb63f4b0ab06
--- /dev/null
+++ b/bitwarden-menu.install
@@ -0,0 +1,8 @@
+## arg 1: the new package version
+post_install() {
+cat <<End-of-message
+
+Copy /usr/share/doc/bitwarden-menu-git/config.ini.example into ~/.config/bwm/config.ini and edit. Add vault URLs and logins to config file if desired.
+
+End-of-message
+}