summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMagnus Bergmark2019-01-04 20:44:38 +0100
committerMagnus Bergmark2019-01-04 20:44:38 +0100
commit8d5d976defdf5ca0647a6ced1bf9dc1cd223472c (patch)
tree57de7688fcba8c0cdd24d54fc8bc94963100bff0
downloadaur-8d5d976defdf5ca0647a6ced1bf9dc1cd223472c.tar.gz
Setup 0.1 release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f359c3e34c79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = bitwarden-rofi
+ pkgdesc = Wrapper for Bitwarden bitwarden/cli and Rofi
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/mattydebie/bitwarden-rofi
+ arch = any
+ license = GPL3
+ depends = rofi
+ depends = jq
+ depends = bitwarden-cli
+ optdepends = xsel: copy to clipboard,
+ optdepends = xclip: copy to clipboard
+ source = https://github.com/mattydebie/bitwarden-rofi/archive/0.1.tar.gz
+ sha512sums = 631add4ea96865a70da8984690a4f26afb7b3f199200dd129bcf0a9bbe0306c8e19af32df318ad0f16460818b24fa3119662baae44b9f45825186ef190a82060
+
+pkgname = bitwarden-rofi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f6584948d81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Magnus Bergmark <magnus.bergmark@gmail.com>
+pkgname=bitwarden-rofi
+pkgver=0.1
+pkgrel=1
+pkgdesc="Wrapper for Bitwarden bitwarden/cli and Rofi"
+arch=('any')
+url="https://github.com/mattydebie/$pkgname"
+license=('GPL3')
+depends=('rofi' 'jq' 'bitwarden-cli')
+optdepends=('xsel: copy to clipboard',
+ 'xclip: copy to clipboard')
+makedepends=()
+source=("https://github.com/mattydebie/$pkgname/archive/$pkgver.tar.gz")
+sha512sums=('631add4ea96865a70da8984690a4f26afb7b3f199200dd129bcf0a9bbe0306c8e19af32df318ad0f16460818b24fa3119662baae44b9f45825186ef190a82060')
+
+package() {
+ cd "$pkgname-$pkgver"
+ local doc_path="$pkgdir/usr/share/doc/${pkgname}"
+
+ install -Dm755 "bwmenu" "$pkgdir/usr/bin/bwmenu"
+
+ install -Dm755 -d "$pkgdir/usr/share/doc/${pkgname}"
+ install -Dm755 -d "$pkgdir/usr/share/doc/${pkgname}/img"
+
+ install -Dm644 "README.md" "${doc_path}/README.md"
+ install -Dm644 img/* "${doc_path}/img/"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}
+