summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias De Bie2019-04-19 21:01:05 +0200
committerMatthias De Bie2019-04-19 21:02:28 +0200
commit1e8797994ed3eb9347d1050e13c458e345c2b290 (patch)
tree2e177bbd5834ab86037d5b2a0a4950c7fa48d40d
downloadaur-1e8797994ed3eb9347d1050e13c458e345c2b290.tar.gz
initial commit
Signed-off-by: Matthias De Bie <mattydebie@gmail.com>
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..30bbc097b579
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = bitwarden-rofi-git
+ pkgdesc = Wrapper for Bitwarden bitwarden/cli and Rofi
+ pkgver = VERSION
+ pkgrel = 1
+ url = https://github.com/mattydebie/bitwarden-rofi
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = rofi
+ depends = jq
+ depends = bitwarden-cli
+ depends = xdotool
+ optdepends = xsel: copy to clipboard
+ optdepends = xclip: copy to clipboard
+ provides = bitwarden-rofi
+ conflicts = bitwarden-rofi
+ replaces = bitwarden-rofi
+ source = git+https://github.com/mattydebie/bitwarden-rofi.git
+ md5sums = SKIP
+
+pkgname = bitwarden-rofi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..df4effc4ad00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Matthias De Bie <mattydebie@gmail.com>
+pkgname=bitwarden-rofi-git
+pkgver=VERSION
+pkgrel=1
+pkgdesc="Wrapper for Bitwarden bitwarden/cli and Rofi"
+arch=('any')
+url="https://github.com/mattydebie/bitwarden-rofi"
+license=('GPL3')
+depends=('rofi' 'jq' 'bitwarden-cli' 'xdotool')
+makedepends=('git')
+optdepends=('xsel: copy to clipboard' 'xclip: copy to clipboard')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+source=("git+https://github.com/mattydebie/${pkgname%-git}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+# Git, tags available
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}" || exit 1
+ local doc_path="$pkgdir/usr/share/doc/${pkgname}"
+
+ install -Dm755 "bwmenu" "$pkgdir/usr/bin/bwmenu"
+
+ install -Dm755 -d "$pkgdir/usr/share/doc/${pkgname}"
+ install -Dm755 -d "$pkgdir/usr/share/doc/${pkgname}/img"
+
+ install -Dm644 "README.md" "${doc_path}/README.md"
+ install -Dm644 img/* "${doc_path}/img/"
+
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}