summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2018-07-12 14:15:10 +0200
committerMarkus Richter2018-07-12 14:15:10 +0200
commitfc57fc2ed877a16c7cb67feba3d65ad91ba866de (patch)
tree2732a50fc334b8bbb163893231eecea6907354eb
parent90705dea9ed7e2ce0ea8438499c314238b6a3a10 (diff)
downloadaur-fc57fc2ed877a16c7cb67feba3d65ad91ba866de.tar.gz
updpkg, use upstream .env, fix license, add openssl dep
-rw-r--r--.SRCINFO11
-rw-r--r--0001-Disable-Vault.patch11
-rw-r--r--PKGBUILD18
-rw-r--r--bitwarden_rs.env23
4 files changed, 27 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15486656fc0e..786b7ced3994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-git
- pkgdesc = A lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
- pkgver = r161.869352c
+ pkgdesc = An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
+ pkgver = r166.470ad14
pkgrel = 1
url = https://github.com/dani-garcia/bitwarden_rs
install = bitwarden_rs.install
@@ -8,21 +8,22 @@ pkgbase = bitwarden_rs-git
arch = x86_64
arch = armv7h
arch = aarch64
- license = GPLv3
+ license = GPL3
makedepends = rust-nightly
makedepends = cargo-nightly
+ depends = openssl
provides = bitwarden_rs
conflicts = bitwarden_rs
conflicts = bitwarden_rs-vault-git
conflicts = bitwarden_rs-vault
source = git+https://github.com/dani-garcia/bitwarden_rs.git
source = bitwarden_rs.install
- source = bitwarden_rs.env
source = bitwarden_rs.service
+ source = 0001-Disable-Vault.patch
sha512sums = SKIP
sha512sums = ea6ac7d915887078d7e091b99d53f2ee6fbf11ad5a80e04309263e7b06ce43de6e90e69ad62e3c99eaf81f825aebe930bf45888041225a156d74f324dfa10578
- sha512sums = 77536fee00f85378f54e7d0fd7e94d4f7c8142195cebd8bfabe032c99864908a2ffdcfcdf77bc90e58a9e66455d7eb0418a66b9f6ad87da3e5d6a107f0546476
sha512sums = 773dc0830b4eaf3a1d4134a52a6157e6a94265c6212ae8cc24b9584f9c444b9a0f822325f487ce9c23c363f743f1f64f269352f030e98e336816aee0a68048f6
+ sha512sums = 704057f0bf6d71ab9888378c3d66ee97c5019e8b18d0f22f93615fef60bef7df80a11ad7ebf5cca1cc49c90ba3f9d84515a160555e395790f325510f8a81f5cd
pkgname = bitwarden_rs-git
diff --git a/0001-Disable-Vault.patch b/0001-Disable-Vault.patch
new file mode 100644
index 000000000000..1b29f53e66c2
--- /dev/null
+++ b/0001-Disable-Vault.patch
@@ -0,0 +1,11 @@
+--- .env 2018-07-12 12:10:14.679534090 +0200
++++ .env 2018-07-12 12:19:46.984580164 +0200
+@@ -12,7 +12,7 @@
+
+ ## Web vault settings
+ # WEB_VAULT_FOLDER=web-vault/
+-# WEB_VAULT_ENABLED=true
++WEB_VAULT_ENABLED=false
+
+ ## Controls if new users can register
+ # SIGNUPS_ALLOWED=true
diff --git a/PKGBUILD b/PKGBUILD
index b3699bdc59cb..625422b1289c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,15 @@
pkgname=bitwarden_rs-git
_pkgbase=bitwarden_rs
-pkgver=r161.869352c
+pkgver=r166.470ad14
pkgrel=1
-pkgdesc="A lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
+pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url="https://github.com/dani-garcia/bitwarden_rs"
-license=('GPLv3')
+license=('GPL3')
groups=()
makedepends=('rust-nightly' 'cargo-nightly')
+depends=('openssl')
provides=("$_pkgbase")
conflicts=("$_pkgbase" "${_pkgbase}-vault-git" "${_pkgbase}-vault")
replaces=()
@@ -18,13 +19,13 @@ options=()
install=bitwarden_rs.install
source=('git+https://github.com/dani-garcia/bitwarden_rs.git'
"${_pkgbase}.install"
- "${_pkgbase}.env"
- "${_pkgbase}.service")
+ "${_pkgbase}.service"
+ "0001-Disable-Vault.patch")
noextract=()
sha512sums=('SKIP'
'ea6ac7d915887078d7e091b99d53f2ee6fbf11ad5a80e04309263e7b06ce43de6e90e69ad62e3c99eaf81f825aebe930bf45888041225a156d74f324dfa10578'
- '77536fee00f85378f54e7d0fd7e94d4f7c8142195cebd8bfabe032c99864908a2ffdcfcdf77bc90e58a9e66455d7eb0418a66b9f6ad87da3e5d6a107f0546476'
- '773dc0830b4eaf3a1d4134a52a6157e6a94265c6212ae8cc24b9584f9c444b9a0f822325f487ce9c23c363f743f1f64f269352f030e98e336816aee0a68048f6')
+ '773dc0830b4eaf3a1d4134a52a6157e6a94265c6212ae8cc24b9584f9c444b9a0f822325f487ce9c23c363f743f1f64f269352f030e98e336816aee0a68048f6'
+ '704057f0bf6d71ab9888378c3d66ee97c5019e8b18d0f22f93615fef60bef7df80a11ad7ebf5cca1cc49c90ba3f9d84515a160555e395790f325510f8a81f5cd')
pkgver() {
@@ -38,6 +39,7 @@ pkgver() {
build() {
#build bitwarden_rs
cd "$srcdir/$_pkgbase"
+ patch -N -i "$srcdir/0001-Disable-Vault.patch"
cargo build --release
}
@@ -45,7 +47,7 @@ package() {
# setup systemd service
install -D -m 0644 "$srcdir/bitwarden_rs.service" "$pkgdir/usr/lib/systemd/system/bitwarden_rs.service"
# copy default config file
- install -D -m 0644 "$srcdir/bitwarden_rs.env" "$pkgdir/etc/bitwarden_rs.env"
+ install -D -m 0644 "$srcdir/$_pkgbase/.env" "$pkgdir/etc/bitwarden_rs.env"
# copy binary
install -D -m0755 "$srcdir/$_pkgbase/target/release/bitwarden_rs" "$pkgdir/usr/bin/bitwarden_rs"
}
diff --git a/bitwarden_rs.env b/bitwarden_rs.env
deleted file mode 100644
index ca04a2544ad2..000000000000
--- a/bitwarden_rs.env
+++ /dev/null
@@ -1,23 +0,0 @@
-# Environment-variables to configure bitwarden_rs
-
-# --- Bitwarden config
-
-# DATA_FOLDER = data
-# RSA_KEY_FILENAME = data/rsa_key
-# DATABASE_URL = data/db.sqlite3
-# ICON_CACHE_FOLDER = data/icon_cache
-# ATTACHMENTS_FOLDER = data/attachments
-# LOCAL_ICON_EXTRACTOR = false
-# SIGNUPS_ALLOWED = true
-# PASSWORD_ITERATIONS = 100000
-
-# --- Web-Vault-config
-
-# Web-Vault can not be enabled because of missing files.
-WEB_VAULT_ENABLED = false
-# WEB_VAULT_FOLDER = web-vault/
-
-# --- Rocket-config
-# ROCKET_PORT = 8000
-# ROCKET_LISTEN = localhost
-# ... See https://api.rocket.rs/rocket/config/index.html for more options, e.g. TLS.