summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2021-04-16 16:39:58 +0200
committerMarkus Richter2021-04-16 16:39:58 +0200
commit231f41f8fc775e491fed0d2f8bccccdf256b1ea0 (patch)
tree71741569b319549ce1d5359ec50ad5af79be1994
parent1371707b0740de5cfc88b0d08b7489695cb4b79b (diff)
downloadaur-231f41f8fc775e491fed0d2f8bccccdf256b1ea0.tar.gz
1.20.0
Upstream Changes: - Implemented Send functionality - Updated web vault to 2.19.0 - CORS fixes - Updated diagnostics page with more info - Updated dependencies 1.19.0 Upstream Changes: - Updated the admin interface: - Added diagnostic and debug information. - Added option to sort users by date. - Added ability to modify a user's type in an organization and to delete the whole organization. - Added support for the Personal Ownership policy, which when enabled disables the use of the personal vault to non-admin users of an organization. - Basic experimental support for LDAP import using the official Directory Connector. - Note that users can't be created by this tool, it only can add or remove them from an organization. - Autoimported users join the organization with user level and they need to be confirmed by an admin or owner from the web vault. If SMTP is enabled, users will need to accept the email invitation beforehand. - Important: enabling the checkbox "Overwrite existing organization users..." in the Directory Connector can cause already existing users from the organization to be removed when syncing if they aren't present in the LDAP server, while the official server differenciates between manually added and autoimported users, and won't delete the manually added ones. This only applies to the user level, and not to managers, admins or owners, and will probably be changed in the future to align with upstream. - Updated web vault to 2.18.1. - Synced global domains data with upstream.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 536388547069..dd639f2688b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-sqlite
pkgdesc = An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
- pkgver = 1.18.0
+ pkgver = 1.20.0
pkgrel = 1
url = https://github.com/dani-garcia/bitwarden_rs
install = bitwarden_rs.install
@@ -18,13 +18,13 @@ pkgbase = bitwarden_rs-sqlite
conflicts = bitwarden_rs-mysql
conflicts = bitwarden_rs-postgresql
backup = etc/bitwarden_rs.env
- source = https://github.com/dani-garcia/bitwarden_rs/archive/1.18.0.tar.gz
+ source = https://github.com/dani-garcia/bitwarden_rs/archive/1.20.0.tar.gz
source = bitwarden_rs.install
source = bitwarden_rs.service
source = bitwarden_rs.sysusers.conf
source = bitwarden_rs.tmpfiles.conf
source = 0001-Disable-Vault.patch
- sha512sums = 5ba0200050e8ec02b0d6ef03cf1d350a45f74552636e0f77a925d09ae0c7cd76a13a65cbae634b7f6b38fbe59ad978ed859cada31610ea5e760a8eb8888ee178
+ sha512sums = 96fc0c3d55ed770af7209f881e107c33cf8ddf5179c504eacbc155dcb0f28641e5d28dd9cbd4f071540a7aac3d0e40b519de1fb85a523c6b74fb91a930d329a8
sha512sums = ae1e05b613d3178bf3fa273ff6661c567140a43826e681b5164ef7d101c1243e5ff93e9caf7193984626d363b8b8b7c076e6646b865699d4cbe482a3dc4f91e7
sha512sums = 6f6b05881ee3344bdc553fae00a709404ddd086af347f909b3f3a620aabd2294b7dd2892472cd72515e9ceced2449eacbd9ef24626a1429776ea4599673a665b
sha512sums = 15b00b0dc9122f98ce8d7b55668fdfbb2e0387563e7d9ad6c0ebc73b75e46e1ccdb3a2186a453795a1b3e2d45358ff5a8076d5cf30319ab2c21539d20cff81c6
diff --git a/PKGBUILD b/PKGBUILD
index 546ca8ed4219..224df0cbd326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=bitwarden_rs-sqlite
_pkgbase=bitwarden_rs
-pkgver=1.18.0
+pkgver=1.20.0
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -12,7 +12,7 @@ license=('GPL3')
depends=('openssl')
makedepends=('rust-nightly' 'cargo-nightly')
optdepends=("bitwarden_rs-vault: Web Interface 'Vault'")
-conflicts=("${_pkgbase}" "${_pkgbase}-git" "${_pkgbase}-mysql" "${_pkgbase}-postgresql")
+conflicts=("${_pkgbase}" "${_pkgbase}-"{git,mysql,postgresql})
backup=('etc/bitwarden_rs.env')
install=bitwarden_rs.install
source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
@@ -21,7 +21,7 @@ source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.sysusers.conf"
"${_pkgbase}.tmpfiles.conf"
"0001-Disable-Vault.patch")
-sha512sums=('5ba0200050e8ec02b0d6ef03cf1d350a45f74552636e0f77a925d09ae0c7cd76a13a65cbae634b7f6b38fbe59ad978ed859cada31610ea5e760a8eb8888ee178'
+sha512sums=('96fc0c3d55ed770af7209f881e107c33cf8ddf5179c504eacbc155dcb0f28641e5d28dd9cbd4f071540a7aac3d0e40b519de1fb85a523c6b74fb91a930d329a8'
'ae1e05b613d3178bf3fa273ff6661c567140a43826e681b5164ef7d101c1243e5ff93e9caf7193984626d363b8b8b7c076e6646b865699d4cbe482a3dc4f91e7'
'6f6b05881ee3344bdc553fae00a709404ddd086af347f909b3f3a620aabd2294b7dd2892472cd72515e9ceced2449eacbd9ef24626a1429776ea4599673a665b'
'15b00b0dc9122f98ce8d7b55668fdfbb2e0387563e7d9ad6c0ebc73b75e46e1ccdb3a2186a453795a1b3e2d45358ff5a8076d5cf30319ab2c21539d20cff81c6'