summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2019-11-23 13:52:48 +0100
committerMarkus Richter2019-11-23 13:52:48 +0100
commitbdfeac2c17207238c80dcde123d81a82fc03eeb4 (patch)
treef5e600d609a9a0da19af465f9df1add8bc3848da
parent79624d27707d808c8dfdd85ef246a67bdc954f29 (diff)
downloadaur-bdfeac2c17207238c80dcde123d81a82fc03eeb4.tar.gz
1.12.0
- revert armv7h workaround - fit PKGBUILD to the archlinux rust packaging guidelines (https://wiki.archlinux.org/index.php/Rust_package_guidelines) by introducing check() and --locked Upstream Changelog: - Improved error message when HIBP key is not set, include a link to the page. - Added check for both the previous and next timeslots in TOTP, which is more forgiving of time mismatches (1.5 minutes now vs 30 seconds before), can be disabled setting `AUTHENTICATOR_DISABLE_TIME_DRIFT=true`. - Made the domain icon blacklist be cached, improving performance. - Recovery codes are now generated when adding email and Duo 2FA. - Removed MySQL libraries from SQLite images. - Added configurable SMTP timeout, and reduced the default to 15 seconds. - Updated images to be able to be built with Podman. - Added option to allow signups from specific domains only (`SIGNUPS_DOMAINS_WHITELIST=domain.com,example.org`). - Updated web vault to fix twofactorauth.org integration. - Updated dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--0002-Rollback-ARM-Toolchain.patch7
-rw-r--r--PKGBUILD19
3 files changed, 12 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71ca83182c86..0ae545be3fa8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs
pkgdesc = An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface.
- pkgver = 1.11.0
+ pkgver = 1.12.0
pkgrel = 1
url = https://github.com/dani-garcia/bitwarden_rs
install = bitwarden_rs.install
@@ -17,16 +17,14 @@ pkgbase = bitwarden_rs
conflicts = bitwarden_rs-mysql
conflicts = bitwarden_rs-postgresql
backup = etc/bitwarden_rs.env
- source = https://github.com/dani-garcia/bitwarden_rs/archive/1.11.0.tar.gz
+ source = https://github.com/dani-garcia/bitwarden_rs/archive/1.12.0.tar.gz
source = bitwarden_rs.install
source = bitwarden_rs.service
source = 0001-Disable-Vault.patch
- sha512sums = d45e3a88e5569689e9c94645f97716c05945c23aa76f1dd16e06d929d293ed90622414492f196d8ee6220477f499d3be9048ebf6ccaaca5e86370f65df0c6c2c
+ sha512sums = 5cdb328532a85ede7ca306192ba0fa311bdcc6679aa4b29b6928bd183d07c5b1fbf21de053d14cb87a6ecf8a338166c6926274a98a6ab00245422e4f6f351db4
sha512sums = 399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74
sha512sums = 4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658
sha512sums = a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028
- source_armv7h = 0002-Rollback-ARM-Toolchain.patch
- sha512sums_armv7h = f26044402b04cc8494cf97b8592ad792bdda875f13598028f020757f8b79bce03059fabf11c80f78bec392f45ab713e861711026881b152df4fb2dcf675e8247
pkgname = bitwarden_rs
diff --git a/0002-Rollback-ARM-Toolchain.patch b/0002-Rollback-ARM-Toolchain.patch
deleted file mode 100644
index bc65dd2518c2..000000000000
--- a/0002-Rollback-ARM-Toolchain.patch
+++ /dev/null
@@ -1,7 +0,0 @@
-diff --git a/rust-toolchain b/rust-toolchain
-index 3f7cead..2ad2d88 100644
---- a/rust-toolchain
-+++ b/rust-toolchain
-@@ -1 +1 @@
--nightly-2019-08-27
-+nightly-2019-05-11
diff --git a/PKGBUILD b/PKGBUILD
index 9d4b8542e08e..b694094dd96b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bitwarden_rs
_pkgbase=bitwarden_rs
-pkgver=1.11.0
+pkgver=1.12.0
pkgrel=1
pkgdesc="An unofficial lightweight implementation of the bitwarden-server using rust and sqlite. Does NOT include the web-interface."
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -18,25 +18,24 @@ source=("https://github.com/dani-garcia/bitwarden_rs/archive/$pkgver.tar.gz"
"${_pkgbase}.install"
"${_pkgbase}.service"
"0001-Disable-Vault.patch")
-source_armv7h=("0002-Rollback-ARM-Toolchain.patch")
-sha512sums=('d45e3a88e5569689e9c94645f97716c05945c23aa76f1dd16e06d929d293ed90622414492f196d8ee6220477f499d3be9048ebf6ccaaca5e86370f65df0c6c2c'
+sha512sums=('5cdb328532a85ede7ca306192ba0fa311bdcc6679aa4b29b6928bd183d07c5b1fbf21de053d14cb87a6ecf8a338166c6926274a98a6ab00245422e4f6f351db4'
'399e63002acb764895bbcf3b983642c8858343b36909eeeb73133de1a9740a3d81232bc206ff6bf3daed50f72354c5e6fd5314d0d044acd9f1cb23a933b1dd74'
'4ce188956f6fe7cfdb711b1505f6344ed2775751ea112a0506dc96455c2705ab8529ec442e4747d7810fc3535b4ca78d1864e874dab5b5306373587097e02658'
'a6f2361c7aa83e63b9a557500406b0cd660e0d7f8b16345f859faa3f96e22bdcecd7589711960486fa0401896291f7d46f66882744c69117fc146056f4a49028')
-sha512sums_armv7h=('f26044402b04cc8494cf97b8592ad792bdda875f13598028f020757f8b79bce03059fabf11c80f78bec392f45ab713e861711026881b152df4fb2dcf675e8247')
_src="$pkgname-$pkgver"
+
+
build() {
#build bitwarden_rs
cd "$srcdir/$_src"
patch -N -p1 -i "$srcdir/0001-Disable-Vault.patch"
+ cargo build --release --locked --features sqlite
+}
- if [ -e "$srcdir/0002-Rollback-ARM-Toolchain.patch" ] ;then
- # workaround for armv7h bug: https://github.com/rust-lang/rust/issues/62896
- patch -N -p1 -i "$srcdir/0002-Rollback-ARM-Toolchain.patch"
- fi
-
- cargo build --release --features sqlite
+check() {
+ cd "$srcdir/$_src"
+ cargo test --release --locked --features sqlite
}
package() {