summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2020-10-11 18:10:20 +0200
committerMarkus Richter2020-10-11 18:59:26 +0200
commita78efac975fea2110d85dcf39839fb7574a0a908 (patch)
tree433b103ca1976ed1ff918d379f6df642d5b06267
parentaa818a0c4d77a667a0abc83262f95c331e6af0bf (diff)
downloadaur-a78efac975fea2110d85dcf39839fb7574a0a908.tar.gz
2.16.2
- Update makedeps array - Adapt changes to patch from http://github.com/dani-garcia/bw_web_builds - Hide "Enterprise Single Sign-On" Button on login page Upstream Changes: - Log in with Enterprise SSO (Single sign-on) (Disabled in bitwarden_rs due to missing support) - Bug fixes - Language updates
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--0001-Set-Vault-BaseURL.patch21
-rw-r--r--PKGBUILD16
4 files changed, 32 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 372cf7253fab..bd10df3b63f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,26 @@
pkgbase = bitwarden_rs-vault
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = 2.15.1
+ pkgver = 2.16.2
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
arch = any
license = AGPL3
makedepends = npm
- makedepends = nodejs-lts-dubnium
- makedepends = python2
+ makedepends = nodejs
makedepends = git
+ makedepends = python2
depends = bitwarden_rs
conflicts = bitwarden_rs-vault-git
conflicts = bitwarden_rs-vault-bin
- source = https://github.com/bitwarden/web/archive/v2.15.1.tar.gz
- source = https://github.com/bitwarden/jslib/archive/57ace4084556758fdc2989cf1a8cf6a5d1736a29.tar.gz
+ source = https://github.com/bitwarden/web/archive/v2.16.2.tar.gz
+ source = https://github.com/bitwarden/jslib/archive/f30d6f8027055507abfdefd1eeb5d9aab25cc601.tar.gz
source = 0001-Set-Vault-BaseURL.patch
source = 0002-Disable-Git-Submodule-Commands.patch
source = bitwarden_rs-vault.install
- sha512sums = 971f23cd00c83160425f25ad8d7eca8fe78f652553f76d838f8476399ed5721234d08201359d8d85a0582b95930451521316f2af8c7c59436edc44f1ae6a19c4
- sha512sums = 771c7d61a17c6f8066e61d17895ab89ee188db43111de774ff7488bc701cc5e10e56f45e18e5bbd5b13cbf5bc54d6cb7d8bc7df4cff3ba62b71d0432d30ac8cf
- sha512sums = 6999c52081caa80ea21c43cc9b2c416a23879aa59eb7be4acd59ff669d42aec493f6525101d3fe81a2c5a5a222af6f8ec2789ebb907152c40b7a5661171fdeef
+ sha512sums = ffbfa7e2fa5cc47289062a7f1147f26be7312c7f0404235b1756acc776e372ab5525221957ea7cc4a5595409504d8705553425758ba166d210c5255620acc78f
+ sha512sums = 1801f91af9a52f0d1364137c40bc2382cc4b683206b73c6effc26ad81c547341b156713617f7c692402b77b8861cfb60ef6b2c3385d5f31a006ac4d53e6e0389
+ sha512sums = 4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634
sha512sums = adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2a45914864a2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+src/
+pkg/
+*.pkg.tar*
+
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 5e7f7608cba0..75609d89c7ae 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -48,13 +48,13 @@ index e64240ad..025fdef1 100644
- } else {
- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
- 'https://notifications.bitwarden.com'; // window.location.origin + '/notifications';
-- environmentService.enterpriseUrl = isDev ? 'http://localhost:61840' :
-- 'https://enterprise.bitwarden.com'; // window.location.origin + '/enterprise';
+- environmentService.enterpriseUrl = isDev ? 'http://localhost:52313' :
+- 'https://portal.bitwarden.com'; // window.location.origin + '/portal';
- }
+ const isDev = false;
+ environmentService.baseUrl = getBaseUrl();
+ environmentService.notificationsUrl = environmentService.baseUrl + '/notifications';
-+ environmentService.enterpriseUrl = environmentService.baseUrl + '/enterprise';
++ environmentService.enterpriseUrl = environmentService.baseUrl + '/portal';
apiService.setUrls({
- base: isDev ? null : window.location.origin,
+ base: isDev ? null : environmentService.baseUrl,
@@ -77,7 +77,7 @@ diff --git a/src/scss/styles.scss b/src/scss/styles.scss
index 676e275f..ba9888fc 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
-@@ -1,5 +1,31 @@
+@@ -1,5 +1,34 @@
@import "../css/webfonts.css";
+/**** START Bitwarden_RS CHANGES ****/
@@ -93,6 +93,9 @@ index 676e275f..ba9888fc 100644
+/* Hide any link pointing to subscriptions */
+a[href$="/settings/subscription"] { @extend %bwrs-hide; }
+
++/* Hide the `Enterprise Single Sign-On` button on the login page */
++a[href$="/sso"] { @extend %bwrs-hide; }
++
+/* Hide Two-Factor menu in Organization settings */
+app-org-settings a[href$="/settings/two-factor"] { @extend %bwrs-hide; }
+
@@ -100,10 +103,10 @@ index 676e275f..ba9888fc 100644
+app-organization-plans > form > div.form-check { @extend %bwrs-hide; }
+app-organization-plans > form > h2.mt-5 { @extend %bwrs-hide; }
+
-+/* Hide Tax Info in Organization settings */
-+app-org-account > div.secondary-header.border-0.mb-0:nth-child(3) { @extend %bwrs-hide; }
-+app-org-account > p { @extend %bwrs-hide; }
-+app-org-account > a.btn.btn-outline-secondary { @extend %bwrs-hide; }
++/* Hide Tax Info and Form in Organization settings */
++app-org-account > div.secondary-header:nth-child(3) { @extend %bwrs-hide; }
++app-org-account > div.secondary-header:nth-child(3) + p { @extend %bwrs-hide; }
++app-org-account > div.secondary-header:nth-child(3) + p + form { @extend %bwrs-hide; }
+/**** END Bitwarden_RS CHANGES ****/
+
$primary: #175DDC;
@@ -113,7 +116,7 @@ diff --git a/webpack.config.js b/webpack.config.js
index 3391d5ff..c4e2c0b5 100644
--- a/webpack.config.js
+++ b/webpack.config.js
-@@ -170,6 +170,7 @@ const config = {
+@@ -176,6 +176,7 @@ const config = {
},
minimizer: [
new TerserPlugin({
diff --git a/PKGBUILD b/PKGBUILD
index b6f6be575ce9..6120d974c1aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
-_jslib_commit="57ace4084556758fdc2989cf1a8cf6a5d1736a29"
+_jslib_commit="f30d6f8027055507abfdefd1eeb5d9aab25cc601"
pkgname=bitwarden_rs-vault
-pkgver=2.15.1
+pkgver=2.16.2
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
url="https://github.com/bitwarden/web"
license=('AGPL3')
-
-# nodejs-lts-dubnium is included because nodejs>=12 doesn't work. otherwise this would be covered by npm.
-# python2 is included because the used npm package node-sass depends on node-gyp (and therefore python2) transitively. This should be covered by the official node-gyp package (https://bugs.archlinux.org/task/62277?project=5&string=node-gyp ) which is pulled in by npm.
-makedepends=('npm' 'nodejs-lts-dubnium' 'python2' 'git')
+# python2 is included because the used npm package node-sass depends on node-gyp (and therefore python2) transitively. This issue should be solved with node-sass >4.14.1.
+makedepends=('npm' 'nodejs' 'git' 'python2')
depends=('bitwarden_rs')
conflicts=("bitwarden_rs-vault-git" "bitwarden_rs-vault-bin")
install=bitwarden_rs-vault.install
@@ -20,9 +18,9 @@ source=("https://github.com/bitwarden/web/archive/v$pkgver.tar.gz"
"0001-Set-Vault-BaseURL.patch"
"0002-Disable-Git-Submodule-Commands.patch"
"$pkgname.install")
-sha512sums=('971f23cd00c83160425f25ad8d7eca8fe78f652553f76d838f8476399ed5721234d08201359d8d85a0582b95930451521316f2af8c7c59436edc44f1ae6a19c4'
- '771c7d61a17c6f8066e61d17895ab89ee188db43111de774ff7488bc701cc5e10e56f45e18e5bbd5b13cbf5bc54d6cb7d8bc7df4cff3ba62b71d0432d30ac8cf'
- '6999c52081caa80ea21c43cc9b2c416a23879aa59eb7be4acd59ff669d42aec493f6525101d3fe81a2c5a5a222af6f8ec2789ebb907152c40b7a5661171fdeef'
+sha512sums=('ffbfa7e2fa5cc47289062a7f1147f26be7312c7f0404235b1756acc776e372ab5525221957ea7cc4a5595409504d8705553425758ba166d210c5255620acc78f'
+ '1801f91af9a52f0d1364137c40bc2382cc4b683206b73c6effc26ad81c547341b156713617f7c692402b77b8861cfb60ef6b2c3385d5f31a006ac4d53e6e0389'
+ '4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634'
'adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')