summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2020-07-21 23:43:57 +0200
committerMarkus Richter2020-07-21 23:43:57 +0200
commitaa818a0c4d77a667a0abc83262f95c331e6af0bf (patch)
tree439e8fc84447f599ac90cf7f42255e81e1d418e7
parent0bffa0bd91f76df066a95032934932796ca17eef (diff)
downloadaur-aa818a0c4d77a667a0abc83262f95c331e6af0bf.tar.gz
2.15.1
- Adapt minor compatibility changes to patch from http://github.com/dani-garcia/bw_web_builds Upstream Changes: - Hidden Passwords - Language updates
-rw-r--r--.SRCINFO12
-rw-r--r--0001-Set-Vault-BaseURL.patch15
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a817c1268f8a..372cf7253fab 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-vault
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = 2.14.0
+ pkgver = 2.15.1
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
@@ -13,14 +13,14 @@ pkgbase = bitwarden_rs-vault
depends = bitwarden_rs
conflicts = bitwarden_rs-vault-git
conflicts = bitwarden_rs-vault-bin
- source = https://github.com/bitwarden/web/archive/v2.14.0.tar.gz
- source = https://github.com/bitwarden/jslib/archive/2858724f4431038be190fc0b748efe287dd1bae6.tar.gz
+ source = https://github.com/bitwarden/web/archive/v2.15.1.tar.gz
+ source = https://github.com/bitwarden/jslib/archive/57ace4084556758fdc2989cf1a8cf6a5d1736a29.tar.gz
source = 0001-Set-Vault-BaseURL.patch
source = 0002-Disable-Git-Submodule-Commands.patch
source = bitwarden_rs-vault.install
- sha512sums = eebc1a0db9e962144c052db721a20180383bd21ae0a1f086da0e71a53f4caccbefd136adbdee8c7945e39a5426e2c3acbddd118d0eb89927b11b2f8201bc145b
- sha512sums = 545fa623f9b2774250ecb5c19222ee0cfaa1ee630fdb1f82c061d35baa8bae50a5ec3a3ba690d626fd81056bf7e029b4b2b43a2657897d27380ee49e372137e7
- sha512sums = bb4d3bdec5e9868f316bd74e07e2bfc6cc412a6bf0d38ddace98278806ca6aff487cec2cb4fdfb87b3af68103eb175a636c3f8dc6ed5710f5780f36c21f5dd8f
+ sha512sums = 971f23cd00c83160425f25ad8d7eca8fe78f652553f76d838f8476399ed5721234d08201359d8d85a0582b95930451521316f2af8c7c59436edc44f1ae6a19c4
+ sha512sums = 771c7d61a17c6f8066e61d17895ab89ee188db43111de774ff7488bc701cc5e10e56f45e18e5bbd5b13cbf5bc54d6cb7d8bc7df4cff3ba62b71d0432d30ac8cf
+ sha512sums = 6999c52081caa80ea21c43cc9b2c416a23879aa59eb7be4acd59ff669d42aec493f6525101d3fe81a2c5a5a222af6f8ec2789ebb907152c40b7a5661171fdeef
sha512sums = adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 7d1b69cb7119..5e7f7608cba0 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -1,5 +1,5 @@
diff --git a/src/app/app.component.ts b/src/app/app.component.ts
-index 2c694d95..bba34865 100644
+index 6807ec89..62dbe456 100644
--- a/src/app/app.component.ts
+++ b/src/app/app.component.ts
@@ -140,6 +140,10 @@ export class AppComponent implements OnDestroy, OnInit {
@@ -14,10 +14,10 @@ index 2c694d95..bba34865 100644
break;
case 'analyticsEventTrack':
diff --git a/src/app/services/services.module.ts b/src/app/services/services.module.ts
-index c74261dd..f61ccefe 100644
+index e64240ad..025fdef1 100644
--- a/src/app/services/services.module.ts
+++ b/src/app/services/services.module.ts
-@@ -127,22 +127,31 @@ const environmentService = new EnvironmentService(apiService, storageService, no
+@@ -127,24 +127,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
const auditService = new AuditService(cryptoFunctionService, apiService);
const eventLoggingService = new EventLoggingService(storageService, apiService, userService, cipherService);
@@ -32,7 +32,7 @@ index c74261dd..f61ccefe 100644
+ // `window.location.href` should have one of the following forms:
+ //
+ // - `https://bitwarden.example.com/base/path/`
-+ // - `https://bitwarden.example.com/base/path/#/some/endpoint[?queryParam=...]`
++ // - `https://bitwarden.example.com/base/path/#/some/route[?queryParam=...]`
+ //
+ // We want to get to just `https://bitwarden.example.com/base/path`.
+ let baseUrl = window.location.href;
@@ -48,10 +48,13 @@ index c74261dd..f61ccefe 100644
- } else {
- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
- 'https://notifications.bitwarden.com'; // window.location.origin + '/notifications';
+- environmentService.enterpriseUrl = isDev ? 'http://localhost:61840' :
+- 'https://enterprise.bitwarden.com'; // window.location.origin + '/enterprise';
- }
+ const isDev = false;
+ environmentService.baseUrl = getBaseUrl();
+ environmentService.notificationsUrl = environmentService.baseUrl + '/notifications';
++ environmentService.enterpriseUrl = environmentService.baseUrl + '/enterprise';
apiService.setUrls({
- base: isDev ? null : window.location.origin,
+ base: isDev ? null : environmentService.baseUrl,
@@ -71,7 +74,7 @@ index 5560c476..a9b954a8 100644
this.ngZone.run(() => {
this.u2fListening = false;
diff --git a/src/scss/styles.scss b/src/scss/styles.scss
-index 80951953..5c784175 100644
+index 676e275f..ba9888fc 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
@@ -1,5 +1,31 @@
@@ -107,7 +110,7 @@ index 80951953..5c784175 100644
$primary-accent: #1252A3;
$secondary: #ced4da;
diff --git a/webpack.config.js b/webpack.config.js
-index aecb1860..44acdc1d 100644
+index 3391d5ff..c4e2c0b5 100644
--- a/webpack.config.js
+++ b/webpack.config.js
@@ -170,6 +170,7 @@ const config = {
diff --git a/PKGBUILD b/PKGBUILD
index 65589a5c66d7..b6f6be575ce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
-_jslib_commit="2858724f4431038be190fc0b748efe287dd1bae6"
+_jslib_commit="57ace4084556758fdc2989cf1a8cf6a5d1736a29"
pkgname=bitwarden_rs-vault
-pkgver=2.14.0
+pkgver=2.15.1
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
@@ -20,9 +20,9 @@ source=("https://github.com/bitwarden/web/archive/v$pkgver.tar.gz"
"0001-Set-Vault-BaseURL.patch"
"0002-Disable-Git-Submodule-Commands.patch"
"$pkgname.install")
-sha512sums=('eebc1a0db9e962144c052db721a20180383bd21ae0a1f086da0e71a53f4caccbefd136adbdee8c7945e39a5426e2c3acbddd118d0eb89927b11b2f8201bc145b'
- '545fa623f9b2774250ecb5c19222ee0cfaa1ee630fdb1f82c061d35baa8bae50a5ec3a3ba690d626fd81056bf7e029b4b2b43a2657897d27380ee49e372137e7'
- 'bb4d3bdec5e9868f316bd74e07e2bfc6cc412a6bf0d38ddace98278806ca6aff487cec2cb4fdfb87b3af68103eb175a636c3f8dc6ed5710f5780f36c21f5dd8f'
+sha512sums=('971f23cd00c83160425f25ad8d7eca8fe78f652553f76d838f8476399ed5721234d08201359d8d85a0582b95930451521316f2af8c7c59436edc44f1ae6a19c4'
+ '771c7d61a17c6f8066e61d17895ab89ee188db43111de774ff7488bc701cc5e10e56f45e18e5bbd5b13cbf5bc54d6cb7d8bc7df4cff3ba62b71d0432d30ac8cf'
+ '6999c52081caa80ea21c43cc9b2c416a23879aa59eb7be4acd59ff669d42aec493f6525101d3fe81a2c5a5a222af6f8ec2789ebb907152c40b7a5661171fdeef'
'adaa6037e59f08a6a44f681c8eab915c0738069989f9d6acbf46e4d3135f69696fa7735a65158979fbc924b27f43bdf255648e615b33495ac7da418e89f27c90'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')