summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2020-07-22 00:16:17 +0200
committerMarkus Richter2020-07-22 00:16:17 +0200
commit16ee49ed9004efc0b26832beb7298e41a53fe4bf (patch)
tree64f4786576bf73215ad584527dfb304ab9e3c39b
parentb9cb1c88b9e0ef5ba2a863db932acf6eec171188 (diff)
downloadaur-16ee49ed9004efc0b26832beb7298e41a53fe4bf.tar.gz
Update BaseURL patch, build currently fails due to an upstream issue
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Set-Vault-BaseURL.patch15
-rw-r--r--PKGBUILD4
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc8d922c65bc..f7dc15d7e0a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-vault-git
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = v2.14.0.r13.g2cc0aa6f
+ pkgver = v2.15.1.r8.gf1dea8fb
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
@@ -18,7 +18,7 @@ pkgbase = bitwarden_rs-vault-git
source = 0001-Set-Vault-BaseURL.patch
source = bitwarden_rs-vault.install
sha512sums = SKIP
- sha512sums = bb4d3bdec5e9868f316bd74e07e2bfc6cc412a6bf0d38ddace98278806ca6aff487cec2cb4fdfb87b3af68103eb175a636c3f8dc6ed5710f5780f36c21f5dd8f
+ sha512sums = 5789373770b114507671a9c14d609b61acbb84c56867b73ae411953c4ce6ef6f7988b28f0efadf4d9e7a15817b8d9c4d312e22c523e8b7fd80b06f2b8ca0b409
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
pkgname = bitwarden_rs-vault-git
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 7d1b69cb7119..4dc21027ed30 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -1,5 +1,5 @@
diff --git a/src/app/app.component.ts b/src/app/app.component.ts
-index 2c694d95..bba34865 100644
+index 6807ec89..62dbe456 100644
--- a/src/app/app.component.ts
+++ b/src/app/app.component.ts
@@ -140,6 +140,10 @@ export class AppComponent implements OnDestroy, OnInit {
@@ -14,10 +14,10 @@ index 2c694d95..bba34865 100644
break;
case 'analyticsEventTrack':
diff --git a/src/app/services/services.module.ts b/src/app/services/services.module.ts
-index c74261dd..f61ccefe 100644
+index e64240ad..025fdef1 100644
--- a/src/app/services/services.module.ts
+++ b/src/app/services/services.module.ts
-@@ -127,22 +127,31 @@ const environmentService = new EnvironmentService(apiService, storageService, no
+@@ -127,24 +127,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
const auditService = new AuditService(cryptoFunctionService, apiService);
const eventLoggingService = new EventLoggingService(storageService, apiService, userService, cipherService);
@@ -32,7 +32,7 @@ index c74261dd..f61ccefe 100644
+ // `window.location.href` should have one of the following forms:
+ //
+ // - `https://bitwarden.example.com/base/path/`
-+ // - `https://bitwarden.example.com/base/path/#/some/endpoint[?queryParam=...]`
++ // - `https://bitwarden.example.com/base/path/#/some/route[?queryParam=...]`
+ //
+ // We want to get to just `https://bitwarden.example.com/base/path`.
+ let baseUrl = window.location.href;
@@ -48,10 +48,13 @@ index c74261dd..f61ccefe 100644
- } else {
- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
- 'https://notifications.bitwarden.com'; // window.location.origin + '/notifications';
+- environmentService.enterpriseUrl = isDev ? 'http://localhost:52313' :
+- 'https://enterprise.bitwarden.com'; // window.location.origin + '/enterprise';
- }
+ const isDev = false;
+ environmentService.baseUrl = getBaseUrl();
+ environmentService.notificationsUrl = environmentService.baseUrl + '/notifications';
++ environmentService.enterpriseUrl = environmentService.baseUrl + '/enterprise';
apiService.setUrls({
- base: isDev ? null : window.location.origin,
+ base: isDev ? null : environmentService.baseUrl,
@@ -71,7 +74,7 @@ index 5560c476..a9b954a8 100644
this.ngZone.run(() => {
this.u2fListening = false;
diff --git a/src/scss/styles.scss b/src/scss/styles.scss
-index 80951953..5c784175 100644
+index 676e275f..ba9888fc 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
@@ -1,5 +1,31 @@
@@ -107,7 +110,7 @@ index 80951953..5c784175 100644
$primary-accent: #1252A3;
$secondary: #ced4da;
diff --git a/webpack.config.js b/webpack.config.js
-index aecb1860..44acdc1d 100644
+index 3391d5ff..c4e2c0b5 100644
--- a/webpack.config.js
+++ b/webpack.config.js
@@ -170,6 +170,7 @@ const config = {
diff --git a/PKGBUILD b/PKGBUILD
index 2357ca60c5ec..197af4a85e70 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
pkgname=bitwarden_rs-vault-git
-pkgver=v2.14.0.r13.g2cc0aa6f
+pkgver=v2.15.1.r8.gf1dea8fb
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
@@ -19,7 +19,7 @@ source=("git+https://github.com/bitwarden/web.git"
"0001-Set-Vault-BaseURL.patch"
"${pkgname%-git}.install")
sha512sums=('SKIP'
- 'bb4d3bdec5e9868f316bd74e07e2bfc6cc412a6bf0d38ddace98278806ca6aff487cec2cb4fdfb87b3af68103eb175a636c3f8dc6ed5710f5780f36c21f5dd8f'
+ '5789373770b114507671a9c14d609b61acbb84c56867b73ae411953c4ce6ef6f7988b28f0efadf4d9e7a15817b8d9c4d312e22c523e8b7fd80b06f2b8ca0b409'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')
pkgver() {