summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2019-03-23 21:17:28 +0100
committerMarkus Richter2019-03-23 21:17:28 +0100
commit48620db8234ce1d350c30b293aa01c1fe5f329ae (patch)
treec44d0281119a7da002690da95375c6166f43550b
parent3e2c65c56cb7e7a1c42ba63b131ba846892f91f7 (diff)
downloadaur-48620db8234ce1d350c30b293aa01c1fe5f329ae.tar.gz
added changes to patch from github.com/dani-garcia/bw_web_builds
-rw-r--r--.SRCINFO2
-rw-r--r--0001-Set-Vault-BaseURL.patch29
-rw-r--r--PKGBUILD4
3 files changed, 23 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49f915bc750c..d267ecb2542d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,7 +14,7 @@ pkgbase = bitwarden_rs-vault-git
source = 0001-Set-Vault-BaseURL.patch
source = bitwarden_rs-vault.install
sha512sums = SKIP
- sha512sums = 08dabddcba9dc917c40e2a8e1058b2b7b7246e747a1178c7f5774366cef35c689e3058c60c3bd659f6aab3bca737c26d4b63bab19c914f35f8e91dabc388923f
+ sha512sums = 2a7fab6ba216e854ec6c31a6dc1df899524b5c97005de38cf9ca64cac5a7ac07355fc8e19a6e6851cc4a5d784720805b83095d27dce7a5baee898a2681578070
sha512sums = 5265612afd40cb757e7d6550ca902f9c02c558e7d03607a181df923374efdf9eff85296c216db7c96d9987eb1fe0834a7eb90de7dcd988c9f7443dc69b9469b1
pkgname = bitwarden_rs-vault-git
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index cff463775461..5605d08e1b7b 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -1,4 +1,4 @@
-index 90aad7df..95ceff61 100644
+index f1b5b392..2bfc2f2e 100644
--- a/src/app/services/services.module.ts
+++ b/src/app/services/services.module.ts
@@ -120,20 +120,16 @@ const notificationsService = new NotificationsService(userService, syncService,
@@ -37,28 +37,39 @@ index 5560c476..a9b954a8 100644
}], [], (data: any) => {
this.ngZone.run(() => {
this.u2fListening = false;
-index 5c114af5..6839385d 100644
+index 3df655fd..7e57cffe 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
-@@ -1,5 +1,23 @@
+@@ -1,5 +1,34 @@
@import "../css/webfonts.css";
+/**** START Bitwarden_RS CHANGES ****/
++/* This combines all selectors extending it into one */
++%bwrs-hide { display: none !important; }
++
++/* This allows searching for the combined style in the browsers dev-tools (look into the head tag) */
++#bwrs-hide, head { @extend %bwrs-hide; }
++
+/* Hide any link pointing to billing */
-+a[href$="/settings/billing"] {display: none !important; }
++a[href$="/settings/billing"] { @extend %bwrs-hide; }
+
+/* Hide Two-Factor menu in Organization settings */
-+app-org-settings a[href$="/settings/two-factor"] { display: none !important; }
++app-org-settings a[href$="/settings/two-factor"] { @extend %bwrs-hide; }
+
+/* Hide 2FA Duo button */
-+ul.list-group.list-group-2fa > li:nth-child(3) button { display: none !important; }
++ul.list-group.list-group-2fa > li:nth-child(3) button { @extend %bwrs-hide; }
+
+/* Hide 2FA Email button */
-+ul.list-group.list-group-2fa > li:nth-child(5) button { display: none !important; }
++ul.list-group.list-group-2fa > li:nth-child(5) button { @extend %bwrs-hide; }
+
+/* Hide organization plans */
-+app-create-organization > form > div.form-check { display: none !important; }
-+app-create-organization > form > h2.mt-5 { display: none !important; }
++app-create-organization > form > div.form-check { @extend %bwrs-hide; }
++app-create-organization > form > h2.mt-5 { @extend %bwrs-hide; }
++
++/* Hide Tax Info in Organization settings */
++app-org-account > div.secondary-header.border-0.mb-0:nth-child(3) { @extend %bwrs-hide; }
++app-org-account > p { @extend %bwrs-hide; }
++app-org-account > a.btn.btn-outline-secondary { @extend %bwrs-hide; }
+/**** END Bitwarden_RS CHANGES ****/
+
$primary: #3c8dbc;
diff --git a/PKGBUILD b/PKGBUILD
index 1308b370ca21..d5df6b7b0bae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
pkgname=bitwarden_rs-vault-git
-pkgver=v2.8.0.r32.g0220f451
+pkgver=v2.9.0.r19.gbcf0aaab
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
@@ -16,7 +16,7 @@ source=("git+https://github.com/bitwarden/web.git"
"0001-Set-Vault-BaseURL.patch"
"${pkgname%-git}.install")
sha512sums=('SKIP'
- '08dabddcba9dc917c40e2a8e1058b2b7b7246e747a1178c7f5774366cef35c689e3058c60c3bd659f6aab3bca737c26d4b63bab19c914f35f8e91dabc388923f'
+ '2a7fab6ba216e854ec6c31a6dc1df899524b5c97005de38cf9ca64cac5a7ac07355fc8e19a6e6851cc4a5d784720805b83095d27dce7a5baee898a2681578070'
'5265612afd40cb757e7d6550ca902f9c02c558e7d03607a181df923374efdf9eff85296c216db7c96d9987eb1fe0834a7eb90de7dcd988c9f7443dc69b9469b1')
pkgver() {