summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2018-08-23 13:37:57 +0200
committerMarkus Richter2018-08-23 13:47:18 +0200
commit9653e53f2e266c1e98ffba3759a4b22b9c88f499 (patch)
treeb2cfc5e1efe53e27f75082f877052b91cc30afa3
parent1019a971e4f886ec6ac0a9da68af5d18ac0ca9bf (diff)
downloadaur-9653e53f2e266c1e98ffba3759a4b22b9c88f499.tar.gz
Re-Enable Organizations
-rw-r--r--.SRCINFO6
-rw-r--r--0001-Set-Vault-BaseURL-git.patch25
-rw-r--r--PKGBUILD14
3 files changed, 40 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72760a1260f1..dff481028c16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitwarden_rs-vault-git
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = v2.1.1.r25.g7107387
- pkgrel = 3
+ pkgver = v2.1.1.r28.g34f6bc2
+ pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
arch = any
@@ -11,8 +11,10 @@ pkgbase = bitwarden_rs-vault-git
provides = bitwarden_rs-vault
conflicts = bitwarden_rs-vault
source = git+https://github.com/bitwarden/web.git
+ source = 0001-Set-Vault-BaseURL-git.patch
source = bitwarden_rs-vault.install
sha512sums = SKIP
+ sha512sums = e79bc76448f3a310eaab825d412d85d46f77dad5372a6d48f649281ed2734f48db0f42b232add39e33434ce581042c784e10324903c8c234c0f18eb72ed1e8dd
sha512sums = 5265612afd40cb757e7d6550ca902f9c02c558e7d03607a181df923374efdf9eff85296c216db7c96d9987eb1fe0834a7eb90de7dcd988c9f7443dc69b9469b1
pkgname = bitwarden_rs-vault-git
diff --git a/0001-Set-Vault-BaseURL-git.patch b/0001-Set-Vault-BaseURL-git.patch
new file mode 100644
index 000000000000..bac487fedebe
--- /dev/null
+++ b/0001-Set-Vault-BaseURL-git.patch
@@ -0,0 +1,25 @@
+--- a/src/app/services/services.module.ts
++++ b/src/app/services/services.module.ts
+@@ -120,20 +120,15 @@ const environmentService = new EnvironmentService(apiService, storageService, notificationsService);
+ const auditService = new AuditService(cryptoFunctionService, apiService);
+
+-const analytics = new Analytics(window, () => platformUtilsService.isDev() || platformUtilsService.isSelfHost(),
++const analytics = new Analytics(window, () => platformUtilsService.isDev() || platformUtilsService.isSelfHost() || true,
+ platformUtilsService, storageService, appIdService);
+ containerService.attachToWindow(window);
+
+ export function initFactory(): Function {
+ return async () => {
+ await (storageService as HtmlStorageService).init();
+- const isDev = platformUtilsService.isDev();
++ const isDev = false;
+- if (!isDev && platformUtilsService.isSelfHost()) {
+- environmentService.baseUrl = window.location.origin;
+- } else {
+- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
+- window.location.origin + '/notifications';
+- }
++ environmentService.baseUrl = window.location.origin;
+ await apiService.setUrls({
+ base: isDev ? null : window.location.origin,
+ api: isDev ? 'http://localhost:4000' : null,
diff --git a/PKGBUILD b/PKGBUILD
index d71136b9a265..b0828cb1484d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
pkgname=bitwarden_rs-vault-git
-pkgver=v2.1.1.r25.g7107387
-pkgrel=3
+pkgver=v2.1.1.r28.g34f6bc2
+pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
url="https://github.com/bitwarden/web"
@@ -13,8 +13,10 @@ conflicts=("bitwarden_rs-vault")
provides=('bitwarden_rs-vault')
install=bitwarden_rs-vault.install
source=("git+https://github.com/bitwarden/web.git"
+ "0001-Set-Vault-BaseURL-git.patch"
"${pkgname%-git}.install")
sha512sums=('SKIP'
+ 'e79bc76448f3a310eaab825d412d85d46f77dad5372a6d48f649281ed2734f48db0f42b232add39e33434ce581042c784e10324903c8c234c0f18eb72ed1e8dd'
'5265612afd40cb757e7d6550ca902f9c02c558e7d03607a181df923374efdf9eff85296c216db7c96d9987eb1fe0834a7eb90de7dcd988c9f7443dc69b9469b1')
pkgver() {
@@ -25,12 +27,18 @@ pkgver() {
)
}
+prepare() {
+ #patch paths
+ cd "$srcdir/web"
+ patch -N -i "$srcdir/0001-Set-Vault-BaseURL-git.patch" "src/app/services/services.module.ts"
+}
+
build() {
#build vault webinterface
cd "$srcdir/web"
npm install --cache "${srcdir}/npm-cache"
npm run sub:init --cache "${srcdir}/npm-cache"
- npm run dist:selfhost --cache "${srcdir}/npm-cache"
+ npm run dist --cache "${srcdir}/npm-cache"
}
package() {