summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2021-02-19 21:06:12 +0100
committerMarkus Richter2021-02-19 21:06:12 +0100
commita407b551190afea47513117b5902ba857e67ef1d (patch)
tree80808cd869b0c36ff7f8dc6cf178dd7a1b2cea1c
parentf302d4ddeec65e8be127a10417c7a8d1abe38f99 (diff)
downloadaur-a407b551190afea47513117b5902ba857e67ef1d.tar.gz
Update BaseURL patch, Hide non-existant features
-rw-r--r--.SRCINFO4
-rw-r--r--0001-Set-Vault-BaseURL.patch37
-rw-r--r--PKGBUILD4
3 files changed, 34 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11aebc4ac7b1..33ab48217b8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bitwarden_rs-vault-git
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = v2.16.2.r0.gd823e852
+ pkgver = v2.18.0.r28.gd2f1e39a
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
@@ -18,7 +18,7 @@ pkgbase = bitwarden_rs-vault-git
source = 0001-Set-Vault-BaseURL.patch
source = bitwarden_rs-vault.install
sha512sums = SKIP
- sha512sums = 4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634
+ sha512sums = 23ce8c903fb6ccb8c56dec0daf8763560ad013c5ee57a5c64ca6db2f15bd52d4e3ce2166de62c3e0ea65bcde46ec2cb6bf7013f1b2c4d0f7b7c8c4c3bbdd9fb8
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
pkgname = bitwarden_rs-vault-git
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 75609d89c7ae..41a0302c5e06 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -1,5 +1,5 @@
diff --git a/src/app/app.component.ts b/src/app/app.component.ts
-index 6807ec89..62dbe456 100644
+index 51853633..c9b3d48a 100644
--- a/src/app/app.component.ts
+++ b/src/app/app.component.ts
@@ -140,6 +140,10 @@ export class AppComponent implements OnDestroy, OnInit {
@@ -14,10 +14,10 @@ index 6807ec89..62dbe456 100644
break;
case 'analyticsEventTrack':
diff --git a/src/app/services/services.module.ts b/src/app/services/services.module.ts
-index e64240ad..025fdef1 100644
+index 3e4d8dfa..f5bf60e4 100644
--- a/src/app/services/services.module.ts
+++ b/src/app/services/services.module.ts
-@@ -127,24 +127,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
+@@ -135,25 +135,32 @@ const environmentService = new EnvironmentService(apiService, storageService, no
const auditService = new AuditService(cryptoFunctionService, apiService);
const eventLoggingService = new EventLoggingService(storageService, apiService, userService, cipherService);
@@ -46,6 +46,7 @@ index e64240ad..025fdef1 100644
- if (!isDev && platformUtilsService.isSelfHost()) {
- environmentService.baseUrl = window.location.origin;
- } else {
+- environmentService.webVaultUrl = isDev ? 'https://localhost:8080' : null;
- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
- 'https://notifications.bitwarden.com'; // window.location.origin + '/notifications';
- environmentService.enterpriseUrl = isDev ? 'http://localhost:52313' :
@@ -74,10 +75,10 @@ index 5560c476..a9b954a8 100644
this.ngZone.run(() => {
this.u2fListening = false;
diff --git a/src/scss/styles.scss b/src/scss/styles.scss
-index 676e275f..ba9888fc 100644
+index 55b3c92c..c48e2baf 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
-@@ -1,5 +1,34 @@
+@@ -1,5 +1,56 @@
@import "../css/webfonts.css";
+/**** START Bitwarden_RS CHANGES ****/
@@ -93,6 +94,9 @@ index 676e275f..ba9888fc 100644
+/* Hide any link pointing to subscriptions */
+a[href$="/settings/subscription"] { @extend %bwrs-hide; }
+
++/* Hide any link pointing to emergency access */
++a[href$="/settings/emergency-access"] { @extend %bwrs-hide; }
++
+/* Hide the `Enterprise Single Sign-On` button on the login page */
+a[href$="/sso"] { @extend %bwrs-hide; }
+
@@ -103,6 +107,25 @@ index 676e275f..ba9888fc 100644
+app-organization-plans > form > div.form-check { @extend %bwrs-hide; }
+app-organization-plans > form > h2.mt-5 { @extend %bwrs-hide; }
+
++/* Hide the `API Key` section under `My Account` */
++app-account > div:nth-child(9),
++app-account > p,
++app-account > button:nth-child(11),
++app-account > button:nth-child(12) {
++ @extend %bwrs-hide;
++}
++
++/* Hide the radio button and label for the `Custom` org user type */
++#userTypeCustom, label[for^=userTypeCustom] {
++ @extend %bwrs-hide;
++}
++
++/* Hide the warning that policy config is moving to Business Portal */
++app-org-policies > app-callout { @extend %bwrs-hide; }
++
++/* Hide `Single Organization` policy */
++app-org-policies > table > tbody > tr:nth-child(4) { @extend %bwrs-hide; }
++
+/* Hide Tax Info and Form in Organization settings */
+app-org-account > div.secondary-header:nth-child(3) { @extend %bwrs-hide; }
+app-org-account > div.secondary-header:nth-child(3) + p { @extend %bwrs-hide; }
@@ -113,10 +136,10 @@ index 676e275f..ba9888fc 100644
$primary-accent: #1252A3;
$secondary: #ced4da;
diff --git a/webpack.config.js b/webpack.config.js
-index 3391d5ff..c4e2c0b5 100644
+index b6da3558..eef05772 100644
--- a/webpack.config.js
+++ b/webpack.config.js
-@@ -176,6 +176,7 @@ const config = {
+@@ -178,6 +178,7 @@ const config = {
},
minimizer: [
new TerserPlugin({
diff --git a/PKGBUILD b/PKGBUILD
index 4121150a80ba..87ad7f443c10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
pkgname=bitwarden_rs-vault-git
-pkgver=v2.16.2.r0.gd823e852
+pkgver=v2.18.0.r28.gd2f1e39a
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
@@ -18,7 +18,7 @@ source=("git+https://github.com/bitwarden/web.git"
"0001-Set-Vault-BaseURL.patch"
"${pkgname%-git}.install")
sha512sums=('SKIP'
- '4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634'
+ '23ce8c903fb6ccb8c56dec0daf8763560ad013c5ee57a5c64ca6db2f15bd52d4e3ce2166de62c3e0ea65bcde46ec2cb6bf7013f1b2c4d0f7b7c8c4c3bbdd9fb8'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')
pkgver() {