summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Richter2020-10-11 19:30:13 +0200
committerMarkus Richter2020-10-11 19:30:13 +0200
commitf302d4ddeec65e8be127a10417c7a8d1abe38f99 (patch)
tree4f9a06ecd50fd43cf6531689e76da0382c7d95a2
parent16ee49ed9004efc0b26832beb7298e41a53fe4bf (diff)
downloadaur-f302d4ddeec65e8be127a10417c7a8d1abe38f99.tar.gz
Update BaseURL patch, update makedeps, hide SSO-Button
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore5
-rw-r--r--0001-Set-Vault-BaseURL.patch19
-rw-r--r--PKGBUILD9
4 files changed, 23 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f7dc15d7e0a3..11aebc4ac7b1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = bitwarden_rs-vault-git
pkgdesc = Integrates the Vault Web-Interface into bitwarden_rs.
- pkgver = v2.15.1.r8.gf1dea8fb
+ pkgver = v2.16.2.r0.gd823e852
pkgrel = 1
url = https://github.com/bitwarden/web
install = bitwarden_rs-vault.install
arch = any
license = AGPL3
makedepends = npm
- makedepends = nodejs-lts-dubnium
+ makedepends = nodejs
makedepends = python2
makedepends = git
depends = bitwarden_rs
@@ -18,7 +18,7 @@ pkgbase = bitwarden_rs-vault-git
source = 0001-Set-Vault-BaseURL.patch
source = bitwarden_rs-vault.install
sha512sums = SKIP
- sha512sums = 5789373770b114507671a9c14d609b61acbb84c56867b73ae411953c4ce6ef6f7988b28f0efadf4d9e7a15817b8d9c4d312e22c523e8b7fd80b06f2b8ca0b409
+ sha512sums = 4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634
sha512sums = 0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d
pkgname = bitwarden_rs-vault-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..dfe9b1b5627b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+src/
+pkg/
+*.pkg.tar*
+web/
diff --git a/0001-Set-Vault-BaseURL.patch b/0001-Set-Vault-BaseURL.patch
index 4dc21027ed30..75609d89c7ae 100644
--- a/0001-Set-Vault-BaseURL.patch
+++ b/0001-Set-Vault-BaseURL.patch
@@ -49,12 +49,12 @@ index e64240ad..025fdef1 100644
- environmentService.notificationsUrl = isDev ? 'http://localhost:61840' :
- 'https://notifications.bitwarden.com'; // window.location.origin + '/notifications';
- environmentService.enterpriseUrl = isDev ? 'http://localhost:52313' :
-- 'https://enterprise.bitwarden.com'; // window.location.origin + '/enterprise';
+- 'https://portal.bitwarden.com'; // window.location.origin + '/portal';
- }
+ const isDev = false;
+ environmentService.baseUrl = getBaseUrl();
+ environmentService.notificationsUrl = environmentService.baseUrl + '/notifications';
-+ environmentService.enterpriseUrl = environmentService.baseUrl + '/enterprise';
++ environmentService.enterpriseUrl = environmentService.baseUrl + '/portal';
apiService.setUrls({
- base: isDev ? null : window.location.origin,
+ base: isDev ? null : environmentService.baseUrl,
@@ -77,7 +77,7 @@ diff --git a/src/scss/styles.scss b/src/scss/styles.scss
index 676e275f..ba9888fc 100644
--- a/src/scss/styles.scss
+++ b/src/scss/styles.scss
-@@ -1,5 +1,31 @@
+@@ -1,5 +1,34 @@
@import "../css/webfonts.css";
+/**** START Bitwarden_RS CHANGES ****/
@@ -93,6 +93,9 @@ index 676e275f..ba9888fc 100644
+/* Hide any link pointing to subscriptions */
+a[href$="/settings/subscription"] { @extend %bwrs-hide; }
+
++/* Hide the `Enterprise Single Sign-On` button on the login page */
++a[href$="/sso"] { @extend %bwrs-hide; }
++
+/* Hide Two-Factor menu in Organization settings */
+app-org-settings a[href$="/settings/two-factor"] { @extend %bwrs-hide; }
+
@@ -100,10 +103,10 @@ index 676e275f..ba9888fc 100644
+app-organization-plans > form > div.form-check { @extend %bwrs-hide; }
+app-organization-plans > form > h2.mt-5 { @extend %bwrs-hide; }
+
-+/* Hide Tax Info in Organization settings */
-+app-org-account > div.secondary-header.border-0.mb-0:nth-child(3) { @extend %bwrs-hide; }
-+app-org-account > p { @extend %bwrs-hide; }
-+app-org-account > a.btn.btn-outline-secondary { @extend %bwrs-hide; }
++/* Hide Tax Info and Form in Organization settings */
++app-org-account > div.secondary-header:nth-child(3) { @extend %bwrs-hide; }
++app-org-account > div.secondary-header:nth-child(3) + p { @extend %bwrs-hide; }
++app-org-account > div.secondary-header:nth-child(3) + p + form { @extend %bwrs-hide; }
+/**** END Bitwarden_RS CHANGES ****/
+
$primary: #175DDC;
@@ -113,7 +116,7 @@ diff --git a/webpack.config.js b/webpack.config.js
index 3391d5ff..c4e2c0b5 100644
--- a/webpack.config.js
+++ b/webpack.config.js
-@@ -170,6 +170,7 @@ const config = {
+@@ -176,6 +176,7 @@ const config = {
},
minimizer: [
new TerserPlugin({
diff --git a/PKGBUILD b/PKGBUILD
index 197af4a85e70..4121150a80ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,15 @@
# Maintainer: Markus Richter <mqus at disroot dot org>
pkgname=bitwarden_rs-vault-git
-pkgver=v2.15.1.r8.gf1dea8fb
+pkgver=v2.16.2.r0.gd823e852
pkgrel=1
pkgdesc="Integrates the Vault Web-Interface into bitwarden_rs."
arch=('any')
url="https://github.com/bitwarden/web"
license=('AGPL3')
-# nodejs-lts-dubnium is included because nodejs>=12 doesn't work. otherwise this would be covered by npm.
-# python2 is included because the used npm package node-sass depends on node-gyp (and therefore python2) transitively. This should be covered by the official node-gyp package (https://bugs.archlinux.org/task/62277?project=5&string=node-gyp ) which is pulled in by npm.
-makedepends=('npm' 'nodejs-lts-dubnium' 'python2' 'git')
+# python2 is included because the used npm package node-sass depends on node-gyp (and therefore python2) transitively. This issue should be solved with node-sass >4.14.1.
+makedepends=('npm' 'nodejs' 'python2' 'git')
depends=('bitwarden_rs')
conflicts=("bitwarden_rs-vault" "bitwarden_rs-vault-bin")
provides=('bitwarden_rs-vault')
@@ -19,7 +18,7 @@ source=("git+https://github.com/bitwarden/web.git"
"0001-Set-Vault-BaseURL.patch"
"${pkgname%-git}.install")
sha512sums=('SKIP'
- '5789373770b114507671a9c14d609b61acbb84c56867b73ae411953c4ce6ef6f7988b28f0efadf4d9e7a15817b8d9c4d312e22c523e8b7fd80b06f2b8ca0b409'
+ '4545846940c07216b64df1922b7742ba14fc39c0ca12115f9422125dc4716d9c9d14ce0213213f44ba6fc66a6b49b9ef28bb5943a24920059a634ebb07716634'
'0b93ea1a442f15ac2445bc0cb759887b0826215edbc73dabb150de8ac136c8712c18b798ff397a06d50989332562a36382b5b7d962e60c2f2619d0f46cf9b04d')
pkgver() {