summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorManuel Wiesinger2024-05-14 18:29:14 +0100
committerManuel Wiesinger2024-05-14 18:29:14 +0100
commit25190e6538df3dadc35d2030c6f8458ed9ae51d4 (patch)
tree6458883c062bf29f109a76bafc655b0e77d9341e
parent076fcf2bdfbaf4b12274822be43e8bec16b22b11 (diff)
downloadaur-25190e6538df3dadc35d2030c6f8458ed9ae51d4.tar.gz
GCC 14 build fix, do not provide python bindings
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--upstream-gcc14.patch74
3 files changed, 82 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e897012e6788..a1707b8be2cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bitwuzla
pkgdesc = SMT solver for the theories of fixed-size bit-vectors, floating-point arithmetic, arrays and uninterpreted functions and their combinations
pkgver = 0.4.0
- pkgrel = 1
+ pkgrel = 2
url = https://bitwuzla.github.io
arch = x86_64
license = MIT
@@ -27,17 +27,18 @@ pkgbase = bitwuzla
depends = kissat
optdepends = cryptominisat5: Support for the CryptoMiniSat SAT solver
optdepends = python>=3.7: Python bindings
- provides = bitwuzla.cpython-311-x86_64-linux-gnu.so
provides = libbitwuzlabv.so
provides = libbitwuzlabb.so
provides = libbitwuzlals.so
provides = libbitwuzla.so
options = !lto
source = bitwuzla-0.4.0.tar.gz::https://github.com/bitwuzla/bitwuzla/archive/refs/tags/0.4.0.tar.gz
+ source = upstream-gcc14.patch::https://github.com/bitwuzla/bitwuzla/commit/31330f252ace62954d573e68261acd78c8554db7.patch
source = 0001-Use-installed-libraries.patch
source = 0002-Skip-Test-based-on-timeout.patch
source = 0003-Do-not-require-git.patch
b2sums = 135ed8dbe8ada22ca36f872ccc062622bfdfa87592cfcad596f9c1c0c92c99a486a7ff52707fe7dba33531405cd6c84a20a3f546d3614585721f6b7468dc2894
+ b2sums = 60caf89635e0e782e18ca7642a64da55e462720106b50d08c7977edd37954314a7b4fe2230dfdffebb834fcd6a2449fca71d4d9a50c10f3db06cd70e48142a77
b2sums = 0ebea6754d4fc270c268d4088af9bcb93596fe5ec7b1065f83d39e5c56eef93d567592443ec0a460a34bf5829b5b54f2c9971644f6fbbebbf9c43a1b440ac54d
b2sums = 7728ab77cb234b4427e7cf493817a24bf97440304efb4fc4300125ec470a0bf15430b4416d3c5fdea51dc91441640d05995ed4a08d4c628f97f4d4dc08538d7e
b2sums = 7c80c06aec86c5c75a72786cfafa03d703950efa5639726abec5466b82928ae231eed75bff29d056d6e47bf2e4ab1ce4f9634fd96f9454d0b92d90c30fd26f37
diff --git a/PKGBUILD b/PKGBUILD
index 6b77d8561d75..e058ab7f91e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
pkgbase=bitwuzla
pkgname=("${pkgbase}" "${pkgbase}-doc")
pkgver=0.4.0
-pkgrel=1
+pkgrel=2
pkgdesc='SMT solver for the theories of fixed-size bit-vectors, floating-point arithmetic, arrays and uninterpreted functions and their combinations'
arch=('x86_64')
url='https://bitwuzla.github.io'
license=('MIT')
source=("$pkgname-$pkgver.tar.gz::https://github.com/bitwuzla/bitwuzla/archive/refs/tags/${pkgver}.tar.gz"
+ "upstream-gcc14.patch::https://github.com/bitwuzla/bitwuzla/commit/31330f252ace62954d573e68261acd78c8554db7.patch"
"0001-Use-installed-libraries.patch"
"0002-Skip-Test-based-on-timeout.patch"
"0003-Do-not-require-git.patch" # git is only used to pull not installed dependencies
@@ -36,12 +37,12 @@ optdepends=(
'python>=3.7: Python bindings'
)
provides=(
- 'bitwuzla.cpython-311-x86_64-linux-gnu.so'
'libbitwuzlabv.so'
'libbitwuzlabb.so'
'libbitwuzlals.so'
'libbitwuzla.so')
b2sums=('135ed8dbe8ada22ca36f872ccc062622bfdfa87592cfcad596f9c1c0c92c99a486a7ff52707fe7dba33531405cd6c84a20a3f546d3614585721f6b7468dc2894'
+ '60caf89635e0e782e18ca7642a64da55e462720106b50d08c7977edd37954314a7b4fe2230dfdffebb834fcd6a2449fca71d4d9a50c10f3db06cd70e48142a77'
'0ebea6754d4fc270c268d4088af9bcb93596fe5ec7b1065f83d39e5c56eef93d567592443ec0a460a34bf5829b5b54f2c9971644f6fbbebbf9c43a1b440ac54d'
'7728ab77cb234b4427e7cf493817a24bf97440304efb4fc4300125ec470a0bf15430b4416d3c5fdea51dc91441640d05995ed4a08d4c628f97f4d4dc08538d7e'
'7c80c06aec86c5c75a72786cfafa03d703950efa5639726abec5466b82928ae231eed75bff29d056d6e47bf2e4ab1ce4f9634fd96f9454d0b92d90c30fd26f37')
@@ -49,6 +50,8 @@ options=('!lto')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input=../upstream-gcc14.patch
+
patch --forward --strip=1 --input=../0001-Use-installed-libraries.patch
patch --forward --strip=1 --input=../0002-Skip-Test-based-on-timeout.patch
patch --forward --strip=1 --input=../0003-Do-not-require-git.patch
diff --git a/upstream-gcc14.patch b/upstream-gcc14.patch
new file mode 100644
index 000000000000..9cd4592075c8
--- /dev/null
+++ b/upstream-gcc14.patch
@@ -0,0 +1,74 @@
+From 31330f252ace62954d573e68261acd78c8554db7 Mon Sep 17 00:00:00 2001
+From: Mathias Preiner <mathias.preiner@gmail.com>
+Date: Tue, 14 May 2024 08:37:48 -0700
+Subject: [PATCH] Fix missing includes reported by gcc14.
+
+---
+ src/lib/bitblast/aig/aig_cnf.cpp | 1 +
+ src/lib/bitblast/aig/aig_manager.cpp | 2 ++
+ src/main/options.cpp | 1 +
+ src/parser/smt2/parser.cpp | 1 +
+ test/unit/api/test_api.cpp | 1 +
+ 5 files changed, 6 insertions(+)
+
+diff --git a/src/lib/bitblast/aig/aig_cnf.cpp b/src/lib/bitblast/aig/aig_cnf.cpp
+index 11fd853ac..6875feac3 100644
+--- a/src/lib/bitblast/aig/aig_cnf.cpp
++++ b/src/lib/bitblast/aig/aig_cnf.cpp
+@@ -10,6 +10,7 @@
+
+ #include "bitblast/aig/aig_cnf.h"
+
++#include <cstdlib>
+ #include <functional>
+ #include <unordered_set>
+ #include <vector>
+diff --git a/src/lib/bitblast/aig/aig_manager.cpp b/src/lib/bitblast/aig/aig_manager.cpp
+index 00adf7308..e612a50a9 100644
+--- a/src/lib/bitblast/aig/aig_manager.cpp
++++ b/src/lib/bitblast/aig/aig_manager.cpp
+@@ -10,6 +10,8 @@
+
+ #include "bitblast/aig/aig_manager.h"
+
++#include <cstdlib>
++
+ namespace bzla::bitblast {
+
+ // AigNodeUniqueTable
+diff --git a/src/main/options.cpp b/src/main/options.cpp
+index 392a13ab5..d7d85c512 100644
+--- a/src/main/options.cpp
++++ b/src/main/options.cpp
+@@ -2,6 +2,7 @@
+
+ #include <bitwuzla/cpp/bitwuzla.h>
+
++#include <algorithm>
+ #include <cassert>
+ #include <iomanip>
+ #include <iostream>
+diff --git a/src/parser/smt2/parser.cpp b/src/parser/smt2/parser.cpp
+index 191efb108..bf957fbde 100644
+--- a/src/parser/smt2/parser.cpp
++++ b/src/parser/smt2/parser.cpp
+@@ -10,6 +10,7 @@
+
+ #include "parser/smt2/parser.h"
+
++#include <algorithm>
+ #include <iostream>
+
+ namespace bzla {
+diff --git a/test/unit/api/test_api.cpp b/test/unit/api/test_api.cpp
+index 09a39bad9..755b229a6 100644
+--- a/test/unit/api/test_api.cpp
++++ b/test/unit/api/test_api.cpp
+@@ -11,6 +11,7 @@
+ #include <bitwuzla/cpp/bitwuzla.h>
+ #include <bitwuzla/cpp/parser.h>
+
++#include <algorithm>
+ #include <chrono>
+ #include <fstream>
+