summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmr Hassan2018-08-29 14:23:13 +0200
committerAmr Hassan2018-08-29 14:23:13 +0200
commitcbbc03b2a334811af8d0da5089fc81a8cf8c741a (patch)
tree01d0bc6136af7c889445022c80250ac4abff64fe
downloadaur-cbbc03b2a334811af8d0da5089fc81a8cf8c741a.tar.gz
v1.3.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0ab49691c9b8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = bjarkan
+ pkgdesc = A bluez 5 compatible command line utility and python 3 library
+ pkgver = 1.3.0
+ pkgrel = 1
+ url = https://github.com/GetWellNetwork/bjarkan
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/GetWellNetwork/bjarkan/archive/v1.3.0.tar.gz
+ md5sums = 198816d4fb3caadfdaaef3db27b2c7ae
+
+pkgname = bjarkan
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12c3851ce830
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Amr Hassan
+
+pkgname=bjarkan
+pkgver=1.3.0
+pkgrel=1
+pkgdesc="A bluez 5 compatible command line utility and python 3 library "
+arch=("any")
+url="https://github.com/GetWellNetwork/bjarkan"
+license=("BSD")
+makedepends=("python-setuptools")
+depends=("python")
+source=("https://github.com/GetWellNetwork/bjarkan/archive/v${pkgver}.tar.gz")
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+md5sums=('198816d4fb3caadfdaaef3db27b2c7ae')