summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortioguda2023-07-28 14:15:22 -0300
committertioguda2023-07-28 14:32:33 -0300
commit90d6a11d2145465373edbaf8e271a01e0ef41644 (patch)
tree510dd3e016e88511116a6440ec204687c6344008
downloadaur-90d6a11d2145465373edbaf8e271a01e0ef41644.tar.gz
Initial Commit
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD20
-rw-r--r--bjeps2xx.install90
4 files changed, 146 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db9d0067135d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = bjeps2xx
+ pkgdesc = Pacote de instalacao do Complemento Banrisul Internet Banking destinado ao sistema operacional Linux.
+ pkgver = 4.0
+ pkgrel = 1
+ url = https://www.banrisul.com.br/bob/link/bobw00hn_conteudo_detalhe2.aspx?secao_id=3002
+ install = bjeps2xx.install
+ arch = x86_64
+ license = custom
+ options = !strip
+ options = !emptydirs
+ source_x86_64 = https://www.banrisul.com.br/bob/download/ComplementoBanrisulLinux_vsr5000.deb
+ sha512sums_x86_64 = 0481ab68157571cb06ecce08245fefbdc163045349c4920c3e521a470ddb8a5c418eeefa51d43de98d1a71196a6bdf8297abd3526c72ae0cf3ec09d8764c0af6
+
+pkgname = bjeps2xx
+ depends = cairo
+ depends = gcc-libs
+ depends = gdk-pixbuf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libsm
+ depends = libusb
+ depends = libx11
+ depends = openssl-1.1
+ depends = pango
+ depends = pcsclite
+ depends = zlib
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d2fa6035e8d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
+!bjeps2xx.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c3b8c0d9ffb0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: tioguda <tioguda@gmail.com>
+
+pkgname=bjeps2xx
+_pkgver=5000
+pkgver=4.0
+pkgrel=1
+pkgdesc="Pacote de instalacao do Complemento Banrisul Internet Banking destinado ao sistema operacional Linux."
+arch=('x86_64')
+url="https://www.banrisul.com.br/bob/link/bobw00hn_conteudo_detalhe2.aspx?secao_id=3002"
+license=('custom')
+options=('!strip' '!emptydirs')
+install=${pkgname}.install
+source_x86_64=("https://www.banrisul.com.br/bob/download/ComplementoBanrisulLinux_vsr${_pkgver}.deb")
+sha512sums_x86_64=('0481ab68157571cb06ecce08245fefbdc163045349c4920c3e521a470ddb8a5c418eeefa51d43de98d1a71196a6bdf8297abd3526c72ae0cf3ec09d8764c0af6')
+
+package(){
+ depends=('cairo' 'gcc-libs' 'gdk-pixbuf' 'gdk-pixbuf2' 'glib2' 'glibc' 'gtk3' 'libsm' 'libusb' 'libx11' 'openssl-1.1' 'pango' 'pcsclite' 'zlib')
+ # Extract package data
+ tar -xJ -f data.tar.xz -C "${pkgdir}"
+}
diff --git a/bjeps2xx.install b/bjeps2xx.install
new file mode 100644
index 000000000000..a49732f6da76
--- /dev/null
+++ b/bjeps2xx.install
@@ -0,0 +1,90 @@
+post_install() {
+ # Copyright 2013 The Chromium Authors. All rights reserved.
+ # Use of this source code is governed by a BSD-style license that can be
+ # found in the LICENSE file.
+
+ TARGET_DIR_CHROME="/etc/opt/chrome/native-messaging-hosts"
+ TARGET_DIR_CHROMIUM="/etc/chromium/native-messaging-hosts"
+ TARGET_DIR_FIREFOX="/usr/lib/mozilla/native-messaging-hosts"
+ TARGET_DIR_FONT="/usr/share/fonts/truetype/source-sans-3"
+
+ HOST_NAME=br.com.banrisul.bjess2jm_wizardserver
+
+ # Update host path in the manifest.
+ HOST_PATH=/usr/lib/BanrisulExtensao/Bjess8xm_WizardServer
+
+ ESCAPED_HOST_PATH=${HOST_PATH}
+
+ if [ -e "/usr/bin/google-chrome-stable" ];then
+ # Create directory to store native messaging host.
+ mkdir -p $TARGET_DIR_CHROME
+
+ # Copy native messaging host manifest.
+ cp /usr/local/lib/BanrisulExtensao/$HOST_NAME.json $TARGET_DIR_CHROME
+
+ sed -i -e "s|HOST_PATH|$ESCAPED_HOST_PATH|" $TARGET_DIR_CHROME/$HOST_NAME.json
+
+ # Set permissions for the manifest so that all users can read it.
+ chmod o+r $TARGET_DIR_CHROME/$HOST_NAME.json
+ fi
+
+ if [ -e "/usr/bin/chromium" ];then
+ # Create directory to store native messaging host.
+ mkdir -p $TARGET_DIR_CHROMIUM
+
+ # Copy native messaging host manifest.
+ cp /usr/local/lib/BanrisulExtensao/$HOST_NAME.json $TARGET_DIR_CHROMIUM
+
+ sed -i -e "s|HOST_PATH|$ESCAPED_HOST_PATH|" $TARGET_DIR_CHROMIUM/$HOST_NAME.json
+
+ # Set permissions for the manifest so that all users can read it.
+ chmod o+r $TARGET_DIR_CHROMIUM/$HOST_NAME.json
+ fi
+
+ if [ -e "/usr/bin/firefox" ];then
+ # Create directory to store native messaging host.
+ mkdir -p $TARGET_DIR_FIREFOX
+
+ # Copy native messaging host manifest.
+ cp /usr/local/lib/BanrisulExtensao/$HOST_NAME.firefox.json $TARGET_DIR_FIREFOX
+
+ sed -i -e "s|HOST_PATH|$ESCAPED_HOST_PATH|" $TARGET_DIR_FIREFOX/$HOST_NAME.firefox.json
+
+ # Set permissions for the manifest so that all users can read it.
+ chmod o+r $TARGET_DIR_FIREFOX/$HOST_NAME.firefox.json
+ fi
+
+ if [ "$(locale | grep "LANG")" = "LANG=pt_BR.UTF-8" ]; then
+ echo -e "\e[34;1m==>\e[39;1m O host nativo de mensagens $HOST_NAME foi instalado. \e[0m"
+ else
+ echo -e "\e[34;1m==>\e[39;1m Native messaging host $HOST_NAME has been installed. \e[0m"
+ fi
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ if [ "$(locale | grep "LANG")" = "LANG=pt_BR.UTF-8" ]; then
+ echo -e "\e[34;1m==>\e[39;1m Finalizando remocao de arquivos... \e[0m"
+ else
+ echo -e "\e[34;1m==>\e[39;1m Finishing removing files... \e[0m"
+ fi
+
+ if [ -e "/etc/opt/chrome/native-messaging-hosts/$HOST_NAME.json" ];then
+ rm -rf /etc/opt/chrome/native-messaging-hosts/$HOST_NAME.json
+ fi
+ if [ -e "/etc/chromium/native-messaging-hosts/$HOST_NAME.json" ];then
+ rm -rf /etc/chromium/native-messaging-hosts/$HOST_NAME.json
+ fi
+ if [ -e "/usr/lib/mozilla/native-messaging-hosts/$HOST_NAME.firefox.json" ];then
+ rm -rf /usr/lib/mozilla/native-messaging-hosts/$HOST_NAME.firefox.json
+ fi
+
+ if [ "$(locale | grep "LANG")" = "LANG=pt_BR.UTF-8" ]; then
+ echo -e "\e[34;1m==>\e[39;1m Arquivos removidos com sucesso. \e[0m"
+ else
+ echo -e "\e[34;1m==>\e[39;1m Files removed successfully. \e[0m"
+ fi
+}